You are not logged in.

#1 2020-03-04 08:06:57

yusufbas
Member
Registered: 2020-03-04
Posts: 2

Multiple graphical issues post-installation (wm and display)

Hello everyone, hope you are having a nice day! This is my first post.

Recently I have reinstalled Arch Linux on one of my drives. I have been using Arch for months. Everything was going fine, I have customized XFCE4, then rebooted. Some problems started to occur.

- Sometimes it hangs at boot while it is checking my drive: "/dev/sda3 clean...". But this is less often compared to my other issues. I suspect it is due to amdgpu and radeon kernel modules because it started to occur after I have added amdgpu and radeon to mkinitcpio modules array.

- Everytime when it starts, after boot messages it prints noise, then black screen for a while, and I am greeted with a zoomed LXDM. It is zoomed to the top left corner. After logging in, when I check the resolution with xrandr the output is correct, 1920x1200. However the display is still zoomed. Only solution I have found was to turn my monitor off and on. Then I get normal, non-zoomed display.

- The 3rd issue happens after restarting my monitor. Some weird window outlines rapidly appear and disappear. I have found a thread about this, solution was to disable compositor in window manager settings. Yes it solves the issue, but it effects Plank Dock too. I have used Plank Dock with no problem in the past, with compositor on.

I have RX 5700 XT as my GPU, do you think it is related to the open source drivers?

Offline

#2 2020-03-04 13:33:30

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,805

Re: Multiple graphical issues post-installation (wm and display)

I suspect it is due to amdgpu and radeon kernel modules because it started to occur after I have added amdgpu and radeon to mkinitcpio modules array.

The RX5700 XT is way to new for the radeon kernel module and only supported by the amdgpu kernel module.

Post full lspci -k , dmesg and / or journalctl -b output


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2020-03-06 04:11:53

yusufbas
Member
Registered: 2020-03-04
Posts: 2

Re: Multiple graphical issues post-installation (wm and display)

lspci -k said amdgpu module was in use, so I removed radeon from mkinitcpio modules array. I don't have the issues now, thanks.

Offline

Board footer

Powered by FluxBB