You are not logged in.

#1 2006-08-28 05:14:33

wrythe
Member
From: Seattle, WA
Registered: 2006-08-15
Posts: 80

Cannot use kernel newer than 2.6.16-ARCH

I just got myself a new laptop (Toshiba U205-S5002) and was excited as hell to get Arch installed on it. The install went well.. until I did a pacman -Syu.. my system would freeze upon reboot and the fans would turn on full blast. I did a reinstall and upgraded everything besides kernel26 and it boots up fine. I tried installing kernel26beyond and it does the same thing as before: freezes.

I thought it was an ACPI error, since that's the last bit of text I'd see before the system would freeze, so I did some searching and found a handful of grub commands to try in order to get the system to boot with a newer kernel. I tried acpi=force, acpi=no, nolapci, and some others, but to no avail; the system just froze at different stages. It usually freezes around the ACPI: IRQ statements... other times it freeze at SMP PREEMPT.. and sometimes it says SMP Motherboard not deteched.

I also read that it could be a gcc error. I did a `uname -a` to see which version the kernel was running the the space where it should be is blank. Not just missing, but there is whitespace where it should go. I did a dmesg | grep gcc and found that the kernel is running gcc 4.0, but the installed version (via pacman -Qi gcc) is 4.1 ...

Does anybody have any ideas? This is driving me crazy.

EDIT: more searching uncovered the "nosmp" option. I thought this was going to be my saviour, but, alas, it wasn't. It still hangs, but without all the SMP errors.  :x


psearch - manipulate and refine pacman searches

Offline

#2 2006-08-28 16:00:00

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: Cannot use kernel newer than 2.6.16-ARCH

As far as I know, "nosmp" is crap.  Try recompiling without SMP support and see if that helps... if it does, this is a bigger fish.

Offline

#3 2006-08-28 16:21:22

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,260

Re: Cannot use kernel newer than 2.6.16-ARCH

try noapic option,
new kernels in .17 series go into 'up mode' if no smp is available

Offline

#4 2006-08-28 16:29:07

wrythe
Member
From: Seattle, WA
Registered: 2006-08-15
Posts: 80

Re: Cannot use kernel newer than 2.6.16-ARCH

tpowa wrote:

try noapic option,
new kernels in .17 series go into 'up mode' if no smp is available

Thanks for the response, but it does the same thing. sad Hangs around the ACPI messages.


psearch - manipulate and refine pacman searches

Offline

#5 2006-08-28 16:31:08

wrythe
Member
From: Seattle, WA
Registered: 2006-08-15
Posts: 80

Re: Cannot use kernel newer than 2.6.16-ARCH

phrakture wrote:

As far as I know, "nosmp" is crap.  Try recompiling without SMP support and see if that helps... if it does, this is a bigger fish.

I would love to, but is there a way to do it without using a vanilla kernel? I the a "make menuconfig" in /usr/src/2.6.17-ARCH and set some options, but when I did "make" it gave me an error.. can't remember exactly what it was. Something like "there is no instruction" or something like that. I should've noted all this, but I didn't. Damnit.


psearch - manipulate and refine pacman searches

Offline

#6 2006-08-28 17:33:42

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: Cannot use kernel newer than 2.6.16-ARCH

wrythe wrote:

I would love to, but is there a way to do it without using a vanilla kernel?

http://wiki.archlinux.org/index.php/Cus … n_with_ABS

Offline

#7 2006-08-29 01:49:15

wrythe
Member
From: Seattle, WA
Registered: 2006-08-15
Posts: 80

Re: Cannot use kernel newer than 2.6.16-ARCH

phrakture wrote:
wrythe wrote:

I would love to, but is there a way to do it without using a vanilla kernel?

http://wiki.archlinux.org/index.php/Cus … n_with_ABS

Ah ha. I knew I shouldn't have procrastinated about learning ABS. Thanks for the direction. Hopefully things go OK.


psearch - manipulate and refine pacman searches

Offline

#8 2006-08-29 04:11:43

wrythe
Member
From: Seattle, WA
Registered: 2006-08-15
Posts: 80

Re: Cannot use kernel newer than 2.6.16-ARCH

phrakture wrote:

As far as I know, "nosmp" is crap.  Try recompiling without SMP support and see if that helps... if it does, this is a bigger fish.

I compiled a custom beyond kernel with SMP disabled and it still managed to hang at the "ACPI: Host Bridge" something or another. Thinking that SMP wasn't actually the problem, and after doing some more forum and wiki searching, I compiled the kernel a second time with "ACPI Processor" disabled and it still hung at system startup.

I'm compiling it again with both SMP and ACPI Processor disabled.. hopefully it works this time, otherwise I don't know what else to do.


psearch - manipulate and refine pacman searches

Offline

#9 2006-08-29 05:22:42

wrythe
Member
From: Seattle, WA
Registered: 2006-08-15
Posts: 80

Re: Cannot use kernel newer than 2.6.16-ARCH

Now it's haning at "Probing PCI Hardware:" sad


psearch - manipulate and refine pacman searches

Offline

#10 2006-09-07 13:52:29

DizL
Member
From: Warsaw/Rzeszow Poland
Registered: 2006-09-07
Posts: 8

Re: Cannot use kernel newer than 2.6.16-ARCH

Hi,

Toshiba Satellite A40, the same problem... hmm//
Any ideas??

DizL

Offline

#11 2006-09-21 03:34:34

wrythe
Member
From: Seattle, WA
Registered: 2006-08-15
Posts: 80

Re: Cannot use kernel newer than 2.6.16-ARCH

DizL wrote:

Hi,

Toshiba Satellite A40, the same problem... hmm//
Any ideas??

DizL

Kernel version 2.6.18 remedies this problem big_smile
It's in the testing repo rightnow.

pacman -S testing/kernel26

psearch - manipulate and refine pacman searches

Offline

Board footer

Powered by FluxBB