You are not logged in.

#1 2020-03-09 12:18:04

xerxes_
Member
Registered: 2018-04-29
Posts: 253

[SOLVED] Web links not recognized in text files in lxterminal

After last update I noticed that web links are not recognized in text files when displayed in lxterminal by for example less or some terminal text editors like mcedit, vi, etc.

Previously they were recognized by driving underscore below them when pointed by mouse and could be opened directly in default web browser or copied. Now they have to be manually selected first to be copied and there is no option to directly open them in browser.

I don't know what changed that behavior and this is not a big problem for me, but I would like to know why that changed. Also I'm not happy to lose that functionality.

Last edited by xerxes_ (2020-03-11 23:28:09)

Offline

#2 2020-03-09 12:22:36

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 22,779
Website

Re: [SOLVED] Web links not recognized in text files in lxterminal

What "terminal" are you talking about.  This has definitely never been the case in the tty, but several terminal emulators do have this feature.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#3 2020-03-09 12:27:07

xerxes_
Member
Registered: 2018-04-29
Posts: 253

Re: [SOLVED] Web links not recognized in text files in lxterminal

I'm using lxterminal, but now I checked that it works in xfce4-terminal and in termite.

Offline

#4 2020-03-09 12:29:31

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 22,779
Website

Re: [SOLVED] Web links not recognized in text files in lxterminal

And what was upgrade in your "last upgrade"?  Have you tried downgrading to confirm the problem is due to an upgrade?  If so, which package version have you traced it to?

FYI, these are all questions you should know to ask yourself without being led step by step here.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#5 2020-03-09 12:52:58

xerxes_
Member
Registered: 2018-04-29
Posts: 253

Re: [SOLVED] Web links not recognized in text files in lxterminal

This was updated recently:

[2020-03-08T22:59:38+0100] [PACMAN] Running 'pacman -Syu vocal'
[2020-03-08T22:59:38+0100] [PACMAN] synchronizing package lists
[2020-03-08T22:59:41+0100] [PACMAN] starting full system upgrade
[2020-03-08T23:03:26+0100] [ALPM] running 'ghc-unregister.hook'...
[2020-03-08T23:03:33+0100] [ALPM] transaction started
[2020-03-08T23:03:33+0100] [ALPM] upgraded libcap (2.32-1 -> 2.33-1)
[2020-03-08T23:03:33+0100] [ALPM] upgraded libinput (1.15.2-1 -> 1.15.3-1)
[2020-03-08T23:03:34+0100] [ALPM] upgraded librsvg (2:2.46.4-1 -> 2:2.48.0-1)
[2020-03-08T23:03:35+0100] [ALPM] upgraded adwaita-icon-theme (3.34.3-1 -> 3.36.0-1)
[2020-03-08T23:03:35+0100] [ALPM] upgraded libproxy (0.4.15-13 -> 0.4.15+33+g454a499-1)
[2020-03-08T23:03:36+0100] [ALPM] upgraded gsettings-desktop-schemas (3.34.0-1 -> 3.35.91+8+gc7427c9-1)
[2020-03-08T23:03:36+0100] [ALPM] upgraded glib-networking (2.62.3-1 -> 2.64.0-1)
[2020-03-08T23:03:36+0100] [ALPM] upgraded libsoup (2.68.4-1 -> 2.70.0-1)
[2020-03-08T23:03:36+0100] [ALPM] upgraded at-spi2-core (2.34.0-1 -> 2.36.0-1)
[2020-03-08T23:03:36+0100] [ALPM] installed clutter-gst (3.0.27-2)
[2020-03-08T23:03:36+0100] [ALPM] installed granite (5.3.0-1)
[2020-03-08T23:03:58+0100] [ALPM] warning: /etc/security/limits.d/10-gcr.conf installed as /etc/security/limits.d/10-gcr.conf.pacnew
[2020-03-08T23:03:58+0100] [ALPM] upgraded gcr (3.34.0-1 -> 3.35.91+13+g9986760-1)
[2020-03-08T23:04:00+0100] [ALPM] upgraded python (3.8.1-4 -> 3.8.2-1)
[2020-03-08T23:04:00+0100] [ALPM] upgraded nss (3.50-1 -> 3.51-1)
[2020-03-08T23:04:00+0100] [ALPM] upgraded gvfs (1.42.2-2 -> 1.44.0-1)
[2020-03-08T23:04:01+0100] [ALPM] installed vocal (2.4.2-2)
[2020-03-08T23:04:01+0100] [ALPM] upgraded ca-certificates-mozilla (3.50-1 -> 3.51-1)
[2020-03-08T23:04:01+0100] [ALPM] upgraded re2 (1:20200101-1 -> 1:20200303-1)
[2020-03-08T23:04:04+0100] [ALPM] upgraded chromium (80.0.3987.132-1 -> 80.0.3987.132-2)
[2020-03-08T23:04:04+0100] [ALPM] upgraded curl (7.69.0-1 -> 7.69.0-3)
[2020-03-08T23:04:04+0100] [ALPM] upgraded debootstrap (1.0.119-1 -> 1.0.120-1)
[2020-03-08T23:04:04+0100] [ALPM] upgraded poppler (0.85.0-1 -> 0.86.1-1)
[2020-03-08T23:04:04+0100] [ALPM] upgraded poppler-glib (0.85.0-1 -> 0.86.1-1)
[2020-03-08T23:04:04+0100] [ALPM] upgraded libsynctex (2019.51075-6 -> 2019.51075-7)
[2020-03-08T23:04:04+0100] [ALPM] upgraded gnome-desktop (1:3.34.4-1 -> 1:3.35.91+2+g36a8f2e2-1)
[2020-03-08T23:04:06+0100] [ALPM] upgraded evince (3.34.2-1 -> 3.36.0-1)
[2020-03-08T23:04:07+0100] [ALPM] upgraded file-roller (3.32.4-1 -> 3.36.0-1)
[2020-03-08T23:04:08+0100] [ALPM] upgraded gtksourceview4 (4.4.0-1 -> 4.6.0-1)
[2020-03-08T23:04:08+0100] [ALPM] upgraded gobject-introspection-runtime (1.62.0-3 -> 1.64.0-1)
[2020-03-08T23:04:08+0100] [ALPM] upgraded libpeas (1.24.1-2 -> 1.26.0-1)
[2020-03-08T23:04:08+0100] [ALPM] upgraded pygobject-devel (3.34.0-3 -> 3.36.0-1)
[2020-03-08T23:04:09+0100] [ALPM] upgraded python-gobject (3.34.0-3 -> 3.36.0-1)
[2020-03-08T23:04:09+0100] [ALPM] installed amtk (5.0.2-1)
[2020-03-08T23:04:09+0100] [ALPM] installed tepl (4.4.0-1)
[2020-03-08T23:04:10+0100] [ALPM] upgraded gedit (3.34.1-1 -> 3.36.0-1)
[2020-03-08T23:04:11+0100] [ALPM] upgraded gedit-plugins (3.34.1-1 -> 3.36.0-1)
[2020-03-08T23:04:16+0100] [ALPM] installed js68 (68.5.0-2)
[2020-03-08T23:04:17+0100] [ALPM] upgraded gjs (2:1.58.5-1 -> 2:1.64.0-1)
[2020-03-08T23:04:18+0100] [ALPM] upgraded gnome-calculator (3.34.1-1 -> 3.36.0-1)
[2020-03-08T23:04:19+0100] [ALPM] upgraded gnome-chess (3.34.0-1 -> 3.36.0-1)
[2020-03-08T23:04:19+0100] [ALPM] upgraded gnome-disk-utility (3.34.4-1 -> 3.36.0-1)
[2020-03-08T23:04:20+0100] [ALPM] upgraded gnome-mines (3.34.0-1 -> 3.36.0-1)
[2020-03-08T23:04:39+0100] [ALPM] upgraded webkit2gtk (2.26.4-1 -> 2.27.91-1)
[2020-03-08T23:04:40+0100] [ALPM] upgraded gnome-online-accounts (3.34.1-1 -> 3.35.90+2+g72028173-1)
[2020-03-08T23:04:41+0100] [ALPM] upgraded gnome-screensaver (3.6.1-16 -> 3.6.1-17)
[2020-03-08T23:04:41+0100] [ALPM] upgraded gpxsee (7.22-1 -> 7.25-1)
[2020-03-08T23:04:43+0100] [ALPM] upgraded gthumb (3.8.3-1 -> 3.9.1-1)
[2020-03-08T23:04:43+0100] [ALPM] upgraded gvfs-goa (1.42.2-2 -> 1.44.0-1)
[2020-03-08T23:04:43+0100] [ALPM] upgraded gvfs-google (1.42.2-2 -> 1.44.0-1)
[2020-03-08T23:04:43+0100] [ALPM] upgraded gvfs-mtp (1.42.2-2 -> 1.44.0-1)
[2020-03-08T23:04:43+0100] [ALPM] upgraded haskell-unliftio-core (0.1.2.0-9 -> 0.2.0.0-1)
[2020-03-08T23:04:43+0100] [ALPM] upgraded haskell-resourcet (1.2.3-1 -> 1.2.3-2)
[2020-03-08T23:04:43+0100] [ALPM] upgraded haskell-conduit (1.3.1.2-29 -> 1.3.1.2-30)
[2020-03-08T23:04:43+0100] [ALPM] upgraded haskell-haddock-library (1.8.0-28 -> 1.8.0-31)
[2020-03-08T23:04:43+0100] [ALPM] upgraded haskell-network-uri (2.6.3.0-24 -> 2.6.3.0-26)
[2020-03-08T23:04:44+0100] [ALPM] upgraded haskell-http (4000.3.14-125 -> 4000.3.14-127)
[2020-03-08T23:04:44+0100] [ALPM] upgraded haskell-http-client (0.6.4-75 -> 0.6.4-77)
[2020-03-08T23:04:44+0100] [ALPM] upgraded haskell-http-client-tls (0.3.5.3-186 -> 0.3.5.3-188)
[2020-03-08T23:04:44+0100] [ALPM] upgraded haskell-hxt (9.3.1.18-28 -> 9.3.1.18-30)
[2020-03-08T23:04:44+0100] [ALPM] upgraded haskell-ipynb (0.1-143 -> 0.1-144)
[2020-03-08T23:04:44+0100] [ALPM] upgraded haskell-juicypixels (3.3.4-17 -> 3.3.5-1)
[2020-03-08T23:04:44+0100] [ALPM] upgraded haskell-sandi (0.5-93 -> 0.5-94)
[2020-03-08T23:04:44+0100] [ALPM] upgraded haskell-skylighting-core (0.8.3.2-26 -> 0.8.3.2-28)
[2020-03-08T23:04:45+0100] [ALPM] upgraded haskell-skylighting (0.8.3.2-26 -> 0.8.3.2-28)
[2020-03-08T23:04:48+0100] [ALPM] upgraded haskell-texmath (0.12.0.1-19 -> 0.12.0.1-21)
[2020-03-08T23:05:10+0100] [ALPM] upgraded hedgewars (1.0.0-46 -> 1.0.0-47)
[2020-03-08T23:05:12+0100] [ALPM] upgraded imagemagick (7.0.9.27-1 -> 7.0.10.0-1)
[2020-03-08T23:05:14+0100] [ALPM] upgraded libmagick6 (6.9.10.97-1 -> 6.9.11.0-1)
[2020-03-08T23:05:16+0100] [ALPM] upgraded inkscape (0.92.4-12 -> 0.92.4-14)
[2020-03-08T23:05:16+0100] [ALPM] upgraded jp2a (1.0.7-2 -> 1.0.9-1)
[2020-03-08T23:05:16+0100] [ALPM] upgraded libkeybinder3 (0.3.2-2 -> 0.3.2-3)
[2020-03-08T23:05:16+0100] [ALPM] upgraded libnma (1.8.24-1 -> 1.8.28-1)
[2020-03-08T23:05:43+0100] [ALPM] upgraded libreoffice-fresh (6.4.1-1 -> 6.4.1-3)
[2020-03-08T23:05:43+0100] [ALPM] upgraded moc (1:2.5.2-2 -> 1:2.5.2-3)
[2020-03-08T23:05:43+0100] [ALPM] upgraded neofetch (6.1.0-1 -> 7.0.0-1)
[2020-03-08T23:05:44+0100] [ALPM] upgraded nm-connection-editor (1.8.24-1 -> 1.16.0-1)
[2020-03-08T23:05:44+0100] [ALPM] upgraded network-manager-applet (1.8.24-1 -> 1.16.0-1)
[2020-03-08T23:05:45+0100] [ALPM] upgraded openmpi (4.0.2-3 -> 4.0.3-1)
[2020-03-08T23:05:48+0100] [ALPM] upgraded pandoc (2.9.2-35 -> 2.9.2-41)
[2020-03-08T23:05:49+0100] [ALPM] upgraded pari (2.11.3-1 -> 2.11.3-2)
[2020-03-08T23:05:49+0100] [ALPM] upgraded pdf2djvu (0.9.16-1 -> 0.9.17-1)
[2020-03-08T23:05:50+0100] [ALPM] upgraded pipewire (0.2.7-2 -> 0.3.1-1)
[2020-03-08T23:05:50+0100] [ALPM] upgraded poppler-qt5 (0.85.0-1 -> 0.86.1-1)
[2020-03-08T23:05:51+0100] [ALPM] upgraded ppp (2.4.7-6 -> 2.4.7-7)
[2020-03-08T23:05:51+0100] [ALPM] upgraded python-packaging (20.2-1 -> 20.3-1)
[2020-03-08T23:05:51+0100] [ALPM] upgraded python-setuptools (1:45.2.0-1 -> 1:45.3.0-1)
[2020-03-08T23:05:51+0100] [ALPM] upgraded python-pysol_cards (0.8.7-1 -> 0.8.8-1)
[2020-03-08T23:05:53+0100] [ALPM] upgraded pysolfc (2.8.0-1 -> 2.8.0-2)
[2020-03-08T23:05:53+0100] [ALPM] upgraded python-prompt_toolkit (3.0.3-1 -> 3.0.4-1)
[2020-03-08T23:05:54+0100] [ALPM] upgraded python-ropper (1.13.4-1 -> 1.13.5-1)
[2020-03-08T23:05:54+0100] [ALPM] upgraded python2-packaging (20.2-1 -> 20.3-1)
[2020-03-08T23:06:03+0100] [ALPM] upgraded qt5-webengine (5.14.1-1 -> 5.14.1-2)
[2020-03-08T23:06:03+0100] [ALPM] upgraded ropper (1.13.4-1 -> 1.13.5-1)
[2020-03-08T23:06:08+0100] [ALPM] upgraded texlive-bin (2019.51075-6 -> 2019.51075-7)
[2020-03-08T23:06:08+0100] [ALPM] upgraded vte-common (0.58.3-1 -> 0.60.0-1)
[2020-03-08T23:06:09+0100] [ALPM] upgraded vte3 (0.58.3-1 -> 0.60.0-1)
[2020-03-08T23:06:10+0100] [ALPM] upgraded xfburn (0.6.1-1 -> 0.6.2-1)
[2020-03-08T23:06:13+0100] [ALPM] upgraded youtube-dl (2020.03.06-1 -> 2020.03.08-1)
[2020-03-08T23:06:20+0100] [ALPM] transaction completed
[2020-03-08T23:06:23+0100] [ALPM] running '30-systemd-daemon-reload.hook'...
[2020-03-08T23:06:25+0100] [ALPM] running '30-systemd-tmpfiles.hook'...
[2020-03-08T23:06:25+0100] [ALPM] running '30-systemd-udev-reload.hook'...
[2020-03-08T23:06:25+0100] [ALPM] running '30-systemd-update.hook'...
[2020-03-08T23:06:25+0100] [ALPM] running 'detect-old-perl-modules.hook'...
[2020-03-08T23:06:25+0100] [ALPM] running 'gdk-pixbuf-query-loaders.hook'...
[2020-03-08T23:06:28+0100] [ALPM] running 'ghc-register.hook'...
[2020-03-08T23:06:33+0100] [ALPM] running 'gio-querymodules.hook'...
[2020-03-08T23:06:34+0100] [ALPM] running 'glib-compile-schemas.hook'...
[2020-03-08T23:06:34+0100] [ALPM] running 'gtk-update-icon-cache.hook'...
[2020-03-08T23:06:36+0100] [ALPM] running 'gvfsd.hook'...
[2020-03-08T23:06:36+0100] [ALPM] running 'texinfo-install.hook'...
[2020-03-08T23:06:36+0100] [ALPM] running 'update-ca-trust.hook'...
[2020-03-08T23:06:39+0100] [ALPM] running 'update-desktop-database.hook'...
[2020-03-08T23:06:41+0100] [ALPM] running 'update-mime-database.hook'...

I have similar installation on laptop and in lxterminal there is underscore with mouse highlighted links, but on desktop I have one update more and it don't work.
I have assumption of changed file in /etc/security/limits.d/10-gcr.conf which I update from pacnew.
Otherwise I have no idea what could change it.

Last edited by xerxes_ (2020-03-09 13:00:24)

Offline

#6 2020-03-09 13:12:18

merlock
Member
Registered: 2018-10-30
Posts: 63

Re: [SOLVED] Web links not recognized in text files in lxterminal

xerxes_ wrote:

I have assumption of changed file in /etc/security/limits.d/10-gcr.conf which I update from pacnew.

Didn't you check the pacnew file before you copied it over?  Wiki article.


It's a big club...and you ain't in it -- George Carlin
Eenie meenie, chili beanie, the spirits are about to speak -- Bullwinkle J. Moose
Registered Linux user #149839
perl -e 'print$i=pack(c5,(41*2),sqrt(7056),(unpack(c,H)-2),oct(115),10); '

Offline

#7 2020-03-09 13:35:27

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 22,779
Website

Re: [SOLVED] Web links not recognized in text files in lxterminal

"one update more" is not a package nor version number.  Please make some effort here.  And if you suspect that the named file is relevant, and you have one system that works and one that doesn't, check for differences in that file between the two systems.

I'd like to help, but you need to do your part.  You are far more capable than this thread would indicate.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#8 2020-03-09 13:36:09

xerxes_
Member
Registered: 2018-04-29
Posts: 253

Re: [SOLVED] Web links not recognized in text files in lxterminal

I checked contents of file /etc/security/limits.d/10-gcr.conf.pacnew and think it doesn't matter; it differed that it didn't had one line with vim:

# vim:set ft=limits:

with now I reverted and see it didn't change anything and it couldn't (line begins # and after it everything is comment).

Offline

#9 2020-03-10 10:26:28

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,805

Re: [SOLVED] Web links not recognized in text files in lxterminal

For clarity, you are using https://www.archlinux.org/packages/comm … xterminal/ ?

It has 1 makedepend and 1 depend, was either of them mentioned in the pacman log ?


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#10 2020-03-10 11:16:49

xerxes_
Member
Registered: 2018-04-29
Posts: 253

Re: [SOLVED] Web links not recognized in text files in lxterminal

Yes, vte3 was updated: upgraded vte3 (0.58.3-1 -> 0.60.0-1). And what now?

Offline

#11 2020-03-10 12:03:36

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 22,779
Website

Re: [SOLVED] Web links not recognized in text files in lxterminal

Really, you should know better than to need this level of spoon feeding.  At very least you should fully read and respond to the comments you've already received:

Trilby wrote:

Have you tried downgrading to confirm the problem is due to an upgrade?  If so, which package version have you traced it to?

As you have a second system with a similar set up, you could also check whether an upgrade to the same versions causes the same problem on that machine.

Last edited by Trilby (2020-03-10 12:05:19)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#12 2020-03-11 23:27:36

xerxes_
Member
Registered: 2018-04-29
Posts: 253

Re: [SOLVED] Web links not recognized in text files in lxterminal

Thanks for help. Update to newer package version (lxterminal-0.3.2-2-x86_64.pkg.tar.zst) solved problem.

Offline

#13 2020-03-12 11:37:22

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,805

Re: [SOLVED] Web links not recognized in text files in lxterminal

Looks like that was the result of other people investigating this and filing bug reports
https://bugs.archlinux.org/task/65772
https://bugs.archlinux.org/task/65783


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

Board footer

Powered by FluxBB