You are not logged in.

#1 2020-02-11 07:38:55

rgomes
Member
Registered: 2013-11-15
Posts: 43

x1 carbon 7th gen modesetting driver choppy terminal performance

I recently got an x1 carbon 7th gen, and I just finished installing arch on it, and started noticing an issue I haven't seen before.

When using the intel modesetting driver, I get really choppy output on terminals in X. It's hard to describe exactly, but it's as if the terminal display doesn't output the most recent frame every so often - for example, if I take an action, the result of that action is never displayed, unless something else happens in the terminal. When typing, this is really jarring, as sometimes it looks like the visual goes back in time for a moment, and it's like the cursor jumps around a bit.

I've only tried straight X / bspwm so far, but it reproduces on different terminals (urxvt and xterm both had the same issue). Turning on picom helped it a little, but if I plug in an external monitor, the issue comes back. If I change the resolution of the external monitor, however, the issue goes away completely, even with picom shutdown. I haven't figured out if there is a pattern / what that pattern is.

This only happens with the modesetting driver - if I run with xf86-video-intel, the terminal works well without this issue at all ... on the other hand, chromium isn't working with xf86-video-intel, unless I run with gpu disabled, which I'd rather not do.

This happens both with guc enabled/disabled - that made no difference.

I'm not entirely sure what my next steps are in diagnosing this issue:
- Has anyone seen this before?
- Is there any output I can collect to understand it better? I don't see any errors in the logs, but I can try to collect debug output.
- Is there a better way to describe this behavior? I feel like choppy terminal isn't very descriptive.

Thanks in advance!

Offline

#2 2020-02-11 18:15:08

kokoko3k
Member
Registered: 2008-11-14
Posts: 1,945

Re: x1 carbon 7th gen modesetting driver choppy terminal performance

I noticed a certain delay from the time i press the button to the time it is shown.
Under kde, since ages.
Turning on kwin compositor fixed it.
This is with Ivybridge, however.

Last edited by kokoko3k (2020-02-11 18:15:43)

Offline

#3 2020-03-07 14:14:44

shaoyu0209
Member
From: Taiwan
Registered: 2016-10-28
Posts: 40

Re: x1 carbon 7th gen modesetting driver choppy terminal performance

Have you checked your xorg sever logs or dmesg?

Offline

#4 2020-03-22 07:01:01

rgomes
Member
Registered: 2013-11-15
Posts: 43

Re: x1 carbon 7th gen modesetting driver choppy terminal performance

No delays on me, it just sometimes doesn't show up. And it's only on terminals.
xorg and dmesg have no interesting logs hmm nothing gets logged when the issue happens.

Offline

Board footer

Powered by FluxBB