You are not logged in.

#1 2020-03-08 14:01:54

gkun
Member
Registered: 2016-06-11
Posts: 72

Chromium won't start after re2 package upgrade

Today I tried to start chromium, it will not start with the following error:

/usr/lib/chromium/chromium: error while loading shared libraries: libre2.so.0: cannot open shared object file: No such file or directory

I managed to solve the problem after downgrading the re2 package from:

re2-1:20200303-1-x86_64.pkg.tar.zst

to

re2-1:20200101-1-x86_64.pkg.tar.zst

I am using chromium-vaapi-bin and I am not 100% sure this problem will occur with the latest build (which I am waiting for a while to install hoping the binary package will appear in the aur without using deprecated repositories).

Offline

#2 2020-03-08 14:13:29

hoomanist
Member
From: universe
Registered: 2020-03-08
Posts: 16

Re: Chromium won't start after re2 package upgrade

try:

sudo pacman -S re2

If you don't want chains on you hand and foot, your only escape is to switch to a free operating system
--richard stallman the great

Offline

#3 2020-03-08 14:24:21

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,520

Re: Chromium won't start after re2 package upgrade

Packages need rebuilt against new libs, that's totally normal. Anything outside the official repos isn't Arch's issue.

Offline

#4 2020-03-08 14:28:20

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,514
Website

Re: Chromium won't start after re2 package upgrade

Mod note: Moving to AUR Issues.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#5 2020-03-20 15:22:07

Rena
Member
From: Cambridge, Ontario, Canadia
Registered: 2015-05-08
Posts: 11
Website

Re: Chromium won't start after re2 package upgrade

I had to do: sudo ln -s /usr/lib/libre2.so /usr/lib/libre2.so.0
This is probably not the ideal solution, though.


All about me and my Arch boxen here.

Offline

#6 2020-03-20 15:40:54

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,520

Re: Chromium won't start after re2 package upgrade

Rena wrote:

I had to do: sudo ln -s /usr/lib/libre2.so /usr/lib/libre2.so.0
This is probably not the ideal solution, though.

It's far more than "not ideal", it's completely idiotic. Do NOT post things like this that may make people think this is an actual solution.

Offline

#7 2020-03-20 23:42:00

Rena
Member
From: Cambridge, Ontario, Canadia
Registered: 2015-05-08
Posts: 11
Website

Re: Chromium won't start after re2 package upgrade

Well, it got Chromium from "doesn't start at all" to "unstable but usable". If you have a proper fix, I'd love to hear it.


All about me and my Arch boxen here.

Offline

#8 2020-03-21 00:47:14

loqs
Member
Registered: 2014-03-06
Posts: 10,093

Re: Chromium won't start after re2 package upgrade

Rena wrote:

Well, it got Chromium from "doesn't start at all" to "unstable but usable". If you have a proper fix, I'd love to hear it.

Scimmia wrote:

Packages need rebuilt against new libs, that's totally normal. Anything outside the official repos isn't Arch's issue.

Library versions are changed to indicate the interface has changed in an incompatible way.  Symlinking to the old version ignores that change resulting in undefined behavior.
https://github.com/google/re2/issues/243

Last edited by loqs (2020-03-21 00:57:14)

Offline

#9 2020-03-22 15:24:01

Rena
Member
From: Cambridge, Ontario, Canadia
Registered: 2015-05-08
Posts: 11
Website

Re: Chromium won't start after re2 package upgrade

Right, and what do users need to do about that? That issue was closed 19 days ago but I don't see an update in pacman. Do I need to recompile something manually? Is there supposed to be an update and something's gone wrong on my end? Are we to just not use Chromium until the fix gets pushed?

To answer my own question without any name-calling, the package "ungoogled-chromium-bin" hasn't been updated, so I need to switch to "ungoogled-chromium" and spend 12 hours compiling it.


All about me and my Arch boxen here.

Offline

#10 2020-03-22 15:26:55

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,520

Re: Chromium won't start after re2 package upgrade

Update in pacman? You're not running Chromium from the Arch repos, it's YOUR responsibility.

Offline

#11 2020-03-22 17:24:31

teckk
Member
Registered: 2013-02-21
Posts: 360

Re: Chromium won't start after re2 package upgrade

so I need to switch to "ungoogled-chromium" and spend 12 hours compiling it.

I would not do that. Is there something ungoogled chromium does that one of these won't?
https://wiki.archlinux.org/index.php/Li … b_browsers

Or you could get a stand alone browser and use it until chromium is fixed.
https://linux.palemoon.org/

Offline

#12 2020-03-22 17:27:40

loqs
Member
Registered: 2014-03-06
Posts: 10,093

Re: Chromium won't start after re2 package upgrade

Rena wrote:

To answer my own question without any name-calling, the package "ungoogled-chromium-bin" hasn't been updated, so I need to switch to "ungoogled-chromium" and spend 12 hours compiling it.

The package was removed.  https://lists.archlinux.org/pipermail/a … 36088.html
https://software.opensuse.org//download … d-chromium

Last edited by loqs (2020-03-22 17:48:54)

Offline

Board footer

Powered by FluxBB