You are not logged in.

#1 2020-03-22 23:38:25

juanmeleiro
Member
From: São Paulo
Registered: 2020-03-22
Posts: 11
Website

Issues starting X server on Inspirion 5575 with Radeon Vega Mobile Gfx

Hi,

I've recently installed Arch on my Inspirion 5575. After following the steps on the wiki (or so I think), I can't get the X server started. I'm running an AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx (integrated graphics, I believe). Here's the log for `startx` (`/var/log/Xorg.0.log`): http://ix.io/2f2T. My .xinitrc contains the command `exec bspwm`, which I have indeed installed. A line from the log I came to believe is relevant:

[  6528.291] (EE) open /dev/dri/card0: No such file or directory

I've been searching the forums for three days. I must have read all of the top results for DuckDuckGo using all of the combinations of the keywords `arch`, `Xorg`, `amd`, `radeon` and the likes. My sanity is slowly fading away.

I'm posting this on the Newbie Corner because 1) I'm a newbie, as far as I'm aware, and most importantly 2) because I have no idea what logs, files or listings I need to provide.

Please, help me get it working.

Thanks.

Last edited by juanmeleiro (2020-03-23 13:24:52)


--
Juan

Offline

#2 2020-03-23 14:27:43

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,805

Re: Issues starting X server on Inspirion 5575 with Radeon Vega Mobile Gfx

Yup, that line is a big clue something is wrong.

[  6528.273] Kernel command line: BOOT_IMAGE=/vmlinuz-linux root=UUID=b1200630-7bb1-49c2-b015-4b7feb287c21 rw loglevel=3 quiet nomodeset

booting with nomodeset blocks all modern drivers, but I guess you didn't get any screen output without it ?


[  6528.288] (==) Matched ati as autoconfigured driver 0
[  6528.288] (==) Matched modesetting as autoconfigured driver 1
[  6528.288] (==) Matched fbdev as autoconfigured driver 2
[  6528.288] (==) Matched vesa as autoconfigured driver 3
[  6528.288] (==) Assigned the driver to the xf86ConfigLayout

The amd RX Vega cards are normally supported by the amdgpu kernel module and xf86-video-amdgpu .

All things combined suggest the problem originates long before X is started.

Please post full outputs of lspci -knn , dmesg and/or journalctl -b

Last edited by Lone_Wolf (2020-03-23 14:28:00)


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2020-03-23 15:30:38

juanmeleiro
Member
From: São Paulo
Registered: 2020-03-22
Posts: 11
Website

Re: Issues starting X server on Inspirion 5575 with Radeon Vega Mobile Gfx

booting with nomodeset blocks all modern drivers

I'd figured something like that was going on. Somewhere in the logs there was mention of "modesetting disabled". I tried to boot without it, but the system just hangs during boot. Note that, I believe, that loglevel means I'm just getting two lines of output during boot.

The outputs:
- lspci -knn: http://ix.io/2f3j
- dmesg: http://ix.io/2f3l
- journalctl: http://ix.io/2f3m


--
Juan

Offline

#4 2020-03-23 15:33:09

loqs
Member
Registered: 2014-03-06
Posts: 10,046

Re: Issues starting X server on Inspirion 5575 with Radeon Vega Mobile Gfx

Please post the kernel messages from a boot without nomodeset.

Offline

#5 2020-03-23 16:29:06

juanmeleiro
Member
From: São Paulo
Registered: 2020-03-22
Posts: 11
Website

Re: Issues starting X server on Inspirion 5575 with Radeon Vega Mobile Gfx

I rebooted, edited the Grub entry to remove the nomodeset keyword, and booted. As I said, the system hangs (it seems), so I had to kill it. I waited about thrice the time it normally takes to boot (a few seconds). If I should let it run for longer, let me know.

The logs: http://ix.io/2f3y


--
Juan

Offline

#6 2020-03-23 16:34:40

loqs
Member
Registered: 2014-03-06
Posts: 10,046

Re: Issues starting X server on Inspirion 5575 with Radeon Vega Mobile Gfx

Have you installed the linux-firmware package?

Offline

#7 2020-03-23 17:51:48

juanmeleiro
Member
From: São Paulo
Registered: 2020-03-22
Posts: 11
Website

Re: Issues starting X server on Inspirion 5575 with Radeon Vega Mobile Gfx

Yes.

$ pacman -Q linux-firmware
linux-firmware 20200224.efcfa03-1

--
Juan

Offline

#8 2020-03-23 18:01:26

loqs
Member
Registered: 2014-03-06
Posts: 10,046

Re: Issues starting X server on Inspirion 5575 with Radeon Vega Mobile Gfx

Offline

#9 2020-03-23 18:15:10

juanmeleiro
Member
From: São Paulo
Registered: 2020-03-22
Posts: 11
Website

Re: Issues starting X server on Inspirion 5575 with Radeon Vega Mobile Gfx

Doesn't look like it works. In the boot menu,

- If I set Boot > Boot List Option to UEFI, the Windows Boot Manager kicks in and hangs.
- If I set Boot > Boot List Option to Legacy but Boot > Attempt Legacy Boot to Disabled, and then remove the Grub nomodeset option, the system hangs during boot.

[EDIT]: Should I do a UEFI install?

[EDIT]: I don't understand how could I switch from Legacy to UEFI. Aren't those two completely separate ways of booting?

Last edited by juanmeleiro (2020-03-23 18:42:46)


--
Juan

Offline

#10 2020-03-24 12:43:14

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,805

Re: Issues starting X server on Inspirion 5575 with Radeon Vega Mobile Gfx

Let's verify what you're booting now.

$ ls -l /sys/firmware/efi/efivars

What does that output when booting with nomodeset and when you boot archlinux installation iso ?


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#11 2020-03-24 12:58:13

juanmeleiro
Member
From: São Paulo
Registered: 2020-03-22
Posts: 11
Website

Re: Issues starting X server on Inspirion 5575 with Radeon Vega Mobile Gfx

“No such file or directory”. There's no efi directory either.


--
Juan

Offline

#12 2020-03-24 13:37:23

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,805

Re: Issues starting X server on Inspirion 5575 with Radeon Vega Mobile Gfx

That indicates your efi firmware automatically switched to legacy mode when you booted the archlinux iso .
Many efi firmwares do that without asking the user.

You'll probably have to disable legacy / CSM mode completely in the firmware settings.
Unfortunately doing that may break your windows install also.

Is this your only system or do you have another working one ?


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#13 2020-03-24 14:10:55

juanmeleiro
Member
From: São Paulo
Registered: 2020-03-22
Posts: 11
Website

Re: Issues starting X server on Inspirion 5575 with Radeon Vega Mobile Gfx

I don't have a Windows install (I killed it as soon as I managed to). I do have another system working. As for the legacy settings: when I do disable that, the system hangs with a single line on the screen saying

Checking media_

that keeps blinking. Then, a “Dell SupportAssist” screen pops-up and starts “scanning the hardware”.


--
Juan

Offline

#14 2020-03-24 15:06:04

loqs
Member
Registered: 2014-03-06
Posts: 10,046

Re: Issues starting X server on Inspirion 5575 with Radeon Vega Mobile Gfx

Is secure boot disabled?

Offline

#15 2020-03-24 16:33:03

juanmeleiro
Member
From: São Paulo
Registered: 2020-03-22
Posts: 11
Website

Re: Issues starting X server on Inspirion 5575 with Radeon Vega Mobile Gfx

Yes. These are the options:

Secure Boot: Disabled
Legacy Option ROMs: Disabled
Boot List Option: UEFI
Attempt Legacy Boot: Disabled

I also tried

Secure Boot: Disabled
Legacy Option ROMs: Enabled
Boot List Option: UEFI
Attempt Legacy Boot: Disabled

And that gives the same result. The options

Secure Boot: Disabled
Legacy Option ROMs: Enabled
Boot List Option: UEFI
Attempt Legacy Boot: Enabled

show that string I mentioned, but eventually boot into Arch. No graphics.

And, finally,

Secure Boot: Disabled
Legacy Option ROMs: Enabled
Boot List Option: Legacy
Attempt Legacy Boot: Enabled

Just directly boots into Arch, without the message.

Last edited by juanmeleiro (2020-03-24 17:31:09)


--
Juan

Offline

#16 2020-03-25 13:55:00

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,805

Re: Issues starting X server on Inspirion 5575 with Radeon Vega Mobile Gfx

I felt that's not many options, but according to https://topics-cdn.dell.com/pdf/inspiro … _en-us.pdf ,  those are indeed the possibilities .

It does seem some users managed to get archlinux running on it, as the inspiron 5575 has a wiki-entry :
https://wiki.archlinux.org/index.php/Dell_Inspiron_5575

Did you try booting archlinux installation iso with the 2 first options (secure boot and legacy boot disabled ) ?

Last edited by Lone_Wolf (2020-03-25 13:55:19)


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#17 2020-03-25 15:57:27

juanmeleiro
Member
From: São Paulo
Registered: 2020-03-22
Posts: 11
Website

Re: Issues starting X server on Inspirion 5575 with Radeon Vega Mobile Gfx

Well, I did now. The options were

Secure Boot: Disabled
Legacy Option ROMs: Disabled
Boot List Option: UEFI
Attempt Legacy Boot: Disabled

(though I suspect the last option has no effect if a UEFI boots succeds)

Anyway, the Windows Boot Manager (so I think) kicks in and shows the message

Checking media_

. A menu pops-up and I'm able to boot into the ISO. Note that the menu is not graphical.

When booted from the ISO, I do

# mount /dev/sda3 /mnt # the root partition
# cd /mnt
# mount /dev/sda4 home # the... home partition
# mount /dev/sda1 boot # well, the boot partition
# arch-chroot /mnt
# startx

And... it fails. Here's the log: https://ix.io/2feY


--
Juan

Offline

#18 2020-03-25 16:31:31

loqs
Member
Registered: 2014-03-06
Posts: 10,046

Re: Issues starting X server on Inspirion 5575 with Radeon Vega Mobile Gfx

[   123.491] (II) Server terminated successfully (0). Closing log file.

Did the X server exit because there was an issue with xinitrc?

Offline

#19 2020-03-25 20:24:35

juanmeleiro
Member
From: São Paulo
Registered: 2020-03-22
Posts: 11
Website

Re: Issues starting X server on Inspirion 5575 with Radeon Vega Mobile Gfx

Ok. Sorry. I ran that as root. If after the

 arch-chroot

I do

su <user>; cd

and try to start X I get this log: https://ix.io/2fh4


--
Juan

Offline

#20 2020-03-25 20:26:10

loqs
Member
Registered: 2014-03-06
Posts: 10,046

Re: Issues starting X server on Inspirion 5575 with Radeon Vega Mobile Gfx

Shows the same result

[   146.191] (II) Server terminated successfully (0). Closing log file.

Edit:
Have you tried GRUB#Default/fallback_boot_path to resolve the EFI boot issue?

Last edited by loqs (2020-03-25 20:31:10)

Offline

#21 2020-03-25 20:34:44

juanmeleiro
Member
From: São Paulo
Registered: 2020-03-22
Posts: 11
Website

Re: Issues starting X server on Inspirion 5575 with Radeon Vega Mobile Gfx

So, I dug around the log and figured I'd check if xterm is installed. It wasn't. So I installed it and X started successfuly when run as root. It looked weird (several windows scattered around), but it did.

I guess that means I should do a UEFI install, right?


--
Juan

Offline

#22 2020-03-25 20:38:32

loqs
Member
Registered: 2014-03-06
Posts: 10,046

Re: Issues starting X server on Inspirion 5575 with Radeon Vega Mobile Gfx

Yes it appears to be a compatibility issue between EFI CSM and the amdgpu module.

Offline

Board footer

Powered by FluxBB