You are not logged in.

#1 2020-01-09 10:43:50

Registered: 2007-08-15
Posts: 82

Boot into hook resume -> can't start the system [SOLVED]

My laptop run Archlinux since 2012.
I have the bad habit of updating the system every 2-3 months.
So, last week I updated the system. apart from "Xorg cleanup requires manual intervention" I had no troubles at all. The previous updated has been probably done this summer or so.

Well, everything works fine except that on the 80% of time my laptop won't start.
I can see grub and then:

:: running early hook [udev]
Starting version 244.1-1-arch
:: running hook [udev]
:: Triggering uevents...
:: running hook [resume]
Waiting 10 seconds for device /dev/sda6 ...
ERROR: resume: hibernation device '/dev/sda6' not found
:: performing fsck on '/dev/sdb1'
:: mounting '/dev/sdb1' on real root
mount: /new_root: unknown filesystem type 'ntfs'
You are now being dropped into an emergency shell.
sh: can0t access tty: job control turned off
[rootfs ]# _

And I'm stucked here.

A few notes:

  • This happens even if I am not resuming an hibernation state (i.e. the laptop has been completely turned off)

  • It happens completely random. I just turn off the laptop and retry until the normal boot happens.

  • Hibernation used to work (I have not used it for a while..)

Fstab is:

# UUID=a242427b-6847-4adf-ae04-35181a9a4a49
/dev/sdb1           	/         	ext4      	rw,relatime,data=ordered	0 1

# UUID=1bbbf106-9254-4bd2-a048-ee8af001d4cc
/dev/sda5           	/boot     	ext2      	rw,relatime,stripe=4	0 2

# UUID=6891b7b0-a187-45c6-abab-bb148307b7f6
/dev/sda7           	/home     	ext4      	rw,relatime,data=ordered	0 2

/dev/sda6	swap	swap	defaults	0	0

I have already tried to update my system again. I saw the mkinitpcio run, but the problem is still here.
Already took a look at: … pio-hooks/
but it seems that no intervention is required.

Can you please help me? Any idea on what's happening here?

Last edited by MajinJoko (2020-03-25 23:58:34)


#2 2020-02-02 19:44:43

Registered: 2007-08-15
Posts: 82

Re: Boot into hook resume -> can't start the system [SOLVED]

Dear all,
I'm still suffering from this problem.
Already updated a few times my installation. Still, 8 times on 10, the system does not boot.

I could even completely disable the "resume" hook, since I never hibernate the system (sleep to disk). But, as per the Archlinux wiki, "resume" hook is required by "base" hook.

I'm on grub (once again, up to dated but quite old installation). Should I change bootloader?

Do you have any idea to help get this fixed?


#3 2020-02-02 19:54:39

Forum Moderator
Registered: 2012-10-16
Posts: 10,434

Re: Boot into hook resume -> can't start the system [SOLVED]

/dev/sdX aren't stable identifiers, there's no guarantee they will be the same across reboots regardless of hibernation or not, you should change all occurrences to more stable names: … ice_naming


#4 2020-03-24 18:42:19

Registered: 2007-08-15
Posts: 82

Re: Boot into hook resume -> can't start the system [SOLVED]

Dear all,
sorry for the long delay.

Following the V1del suggestion, I reconfigured my system using persistent names (UUID).

Still, from time to time I get the same error. The ramdisk tries to recover from hibernation. But it doesn't make sense, since the laptop wasn't put in hibernation.

How can I disable the "hibernation" stuff (which I don't even use). Do you think it is safe to remove the "resume" hook in mkinitcpio and then rebuild the initial ramdisk?


#5 2020-03-25 23:58:13

Registered: 2007-08-15
Posts: 82

Re: Boot into hook resume -> can't start the system [SOLVED]

Don't mind my last message.

I just forgot to double check Grub. Can't remember why but it was set to disable the UUID disk root directive.
Once I re-enable that, and rebuild the grub.cfg, it seems that has solved.

I was able to verify that, from time to time, my ssd (sda) and my hdd (sdb) where swapped at boot.

Thanks to V1del for the help!



Board footer

Powered by FluxBB