You are not logged in.

#1 2020-03-26 11:30:53

Thrash
Member
Registered: 2017-06-12
Posts: 7

Sage – Tab autocompletion not working anymore

The tab autocompletion is not working anymore. Instead I get the following message:

┌────────────────────────────────────────────────────────────────────┐
│ SageMath version 9.0, Release Date: 2020-01-01                     │
│ Using Python 3.8.2. Type "help()" for help.                        │
└────────────────────────────────────────────────────────────────────┘
/usr/lib/python3.8/site-packages/jedi/cache.py:111: DeprecationWarning: Deprecated since version 0.16.0. Use get_signatures()[...].params
  result = method(self, *args, **kwargs)

What can I do to solve the problem? It seems that Python 3.8.2 is not yet officially supported, see FrédéricC's comment here:
https://ask.sagemath.org/question/50341 … g-anymore/

Offline

#2 2020-03-26 13:44:43

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,673

Re: Sage – Tab autocompletion not working anymore

Should be fixed in 9.0-12, please test

Offline

#3 2020-03-28 11:23:20

Thrash
Member
Registered: 2017-06-12
Posts: 7

Re: Sage – Tab autocompletion not working anymore

It works now, thank you very much!

Offline

Board footer

Powered by FluxBB