You are not logged in.

#1 2020-04-06 07:20:17

jared
Member
From: Germany
Registered: 2012-01-16
Posts: 62

[SOLVED] python-flask-security-too and python-flask-security conflict

Hi everyone,

I ran into a conflict when trying to update:

:: Replace python-xdg with extra/python-pyxdg? [Y/n] y
resolving dependencies...
looking for conflicting packages...
:: python-flask-security-too and python-flask-security are in conflict. Remove python-flask-security? [y/N]

I was not able to find anything about this conflict, so I started investigating the packages:

$ pacman -Qi python-flask-security-too 
error: package 'python-flask-security-too' was not found
$ pacman -Qi python-flask-security
Name            : python-flask-security
Version         : 3.0.0-3
...

How can there be a conflict? What can I do to resolve this?
Thank you for your help.

Last edited by jared (2020-04-06 14:44:07)

Offline

#2 2020-04-06 07:53:35

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 15,033

Re: [SOLVED] python-flask-security-too and python-flask-security conflict

If I'm reading the package logs correctly python-flask-security-too is an updated fork of python-flask-security which was last updated in 2018.

So you will want to answer y here.

Technically a slight packaging bug, as python-flask-security-too should have a replaces directive to make the default choice Y

Offline

#3 2020-04-06 10:06:57

jared
Member
From: Germany
Registered: 2012-01-16
Posts: 62

Re: [SOLVED] python-flask-security-too and python-flask-security conflict

Thanks for the quick reply.

I've brought this to the attention of the pacman team: https://bugs.archlinux.org/task/66141

Last edited by jared (2020-04-06 10:17:18)

Offline

#4 2020-04-06 13:14:39

Scimmia
Fellow
Registered: 2012-09-01
Posts: 8,838

Re: [SOLVED] python-flask-security-too and python-flask-security conflict

Not a bug at all, if it were meant to replace the other package, it would have just been packaged with the same name.

Offline

#5 2020-04-06 13:59:58

jared
Member
From: Germany
Registered: 2012-01-16
Posts: 62

Re: [SOLVED] python-flask-security-too and python-flask-security conflict

What is a sensitive reaction to such cases? I am still unsure what to do. How should I proceed?

Offline

#6 2020-04-06 14:17:44

ayekat
Member
Registered: 2011-01-17
Posts: 1,485
Website

Re: [SOLVED] python-flask-security-too and python-flask-security conflict

Scimmia wrote:

[…] if it were meant to replace the other package, it would have just been packaged with the same name.

… or at least been given a `replaces`, and the old package would no longer be in the repos now.

jared: You'll notice that python-flask-security-too also provides python-flask-security. In some sense, the -too package thus provides all the functionality of python-flask-security, plus some more.
By replacing python-flask-security by python-flask-security-too, none of the dependencies are broken; the python-flask-security dependency is still fulfilled by the -too package.

It's a bit like installing either gvim or vim: With gvim, you get all the functionality of vim + some additional stuff (like X clipboard support). They conflict with each other, but gvim doesn't replace vim, because there are cases where you simply don't need all the functionality of gvim, you just want "a" vim.

Last edited by ayekat (2020-04-06 14:19:33)


{,META,RE}PKGBUILDSpacman-hacks (includes makemetapkg and remakepkg) │ dotfiles

Offline

#7 2020-04-06 14:43:35

jared
Member
From: Germany
Registered: 2012-01-16
Posts: 62

Re: [SOLVED] python-flask-security-too and python-flask-security conflict

@ayekat,
as a vim user, I thank you for the analogy and your answer to my questions in general.

Offline

Board footer

Powered by FluxBB