You are not logged in.

#1 2020-04-22 20:02:06

Registered: 2020-04-22
Posts: 2

[SOLVED] systemd-modules-load.service failed to start


When I try to boot my system it gets stuck and indicates a failure to 'Load Kernel Modules'. Here is the output of 'systemctl status':

● systemd-modules-load.service - Load Kernel Modules
     Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; vendor preset: disabled)
     Active: failed (Result: exit-code) since Wed 2020-04-22 21:04:43 CEST; 45s ago
       Docs: man:systemd-modules-load.service(8)
    Process: 418 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
   Main PID: 418 (code=exited, status=1/FAILURE)

Apr 22 21:04:43 lambda systemd[1]: Starting Load Kernel Modules...
Apr 22 21:04:43 lambda systemd-modules-load[418]: Failed to look up module alias 'crypto_user': Function not implemented
Apr 22 21:04:43 lambda systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
Apr 22 21:04:43 lambda systemd[1]: systemd-modules-load.service: Failed with result 'exit-code'.
Apr 22 21:04:43 lambda systemd[1]: Failed to start Load Kernel Modules.

Edit: I have pasted the text output now, for future search. Previously I had a photo of the output, since NetworkManager failed to connect to the internet and my USB devices did not get detected.

Some context:

- I noticed my SD card was detected, but could no longer be mounted because the system failed to use 'exfat'. Same with my external hard-drive, which showed the same error for 'ntfs'. Both worked flawlessly before. I installed exfat-utils and fuse-exfat in order to try fixing it.
- I recently installed fuse, but I don't know if it has something to do with that. I also did 'pacman -Syu' recently right before it failed to boot.
- There are probably obvious solutions to all of this, but I made several stupid mistakes. The main one: this was my first time installing any Linux distribution. It took me about two or three days and multiple tries to set up a dual boot system with Windows 10 and I was really proud and confident and really enjoyed using Arch Linux over the past two weeks. But I am beginning to doubt that I was ready for it. Generally, my approach to this has been really careless, trial and error.

I will gladly provide additional information given the right pointers. If I can somehow get a few of my files off the linux partition, that would probably be enough for me. Then I can just start from scratch.

Thank you very much for your time!

Last edited by lambda11 (2020-04-22 23:15:32)


#2 2020-04-22 20:18:12

From: .nz
Registered: 2009-05-09
Posts: 30,057

Re: [SOLVED] systemd-modules-load.service failed to start

Please edit your title and remove the redundant noob stuff: … ow_to_post

Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438


#3 2020-04-22 20:21:26

Forum Moderator
Registered: 2012-10-16
Posts: 16,444

Re: [SOLVED] systemd-modules-load.service failed to start

That usually happens because the modules of the running kernel do not match the modules of the installed kernel (outputs of

pacman -Q linux
uname -a

should show the same version number. That usually happens if you installed in UEFI mode, configured the ESP as your boot partition but didn't have it mounted during the time of the update.

Most straightforward fix would be to use the live disk/usb you used to install the system mount the partitions correctly under /mnt (and not forgetting about the ESP on /mnt/boot this time (even before that you might want to remove the wrongly created /boot directory)), arch-chrooting into the system, and running

pacman -Syu linux

so that the kernel get's properly reinstalled and rebuilt.

If any of this is unclear, boot the live disk mount the partitions and post

lsblk -f

and your fstab via … in_clients

Last edited by V1del (2020-04-22 20:23:14)


#4 2020-04-22 21:17:41

Registered: 2020-04-22
Posts: 2

Re: [SOLVED] systemd-modules-load.service failed to start

Yes, the version numbers were different and its exactly how you said. I forgot I had to mount /boot for the updates. I did what you said and everything is back to normal now, thank you so much! I was about to give up on it all.

I also forgot that I could simply use the boot USB to connect to the internet. This will definitely reduce my stress levels in the future when something like this happens again.


#5 2020-04-23 11:08:49

From: London
Registered: 2014-02-20
Posts: 6,391

Re: [SOLVED] systemd-modules-load.service failed to start

lambda11 wrote:

I forgot I had to mount /boot for the updates

If you don't want to keep the EFI system partition mounted at all times then either move /boot to the root partition (GRUB supports this just fine, just remember to run the grub-install command again afterwards to update core.img) or use systemd-boot, that will mount /boot automatically on demand.


Board footer

Powered by FluxBB