You are not logged in.

#1 2020-05-18 15:43:12

caldog20
Member
From: Birmingham,AL
Registered: 2015-01-26
Posts: 2

Requesting help with updating old PKGBUILD on AUR

Hi guys,

I am having a few issues with a certain application that has an old PKGBUILD on the aur. I want to update the PKGBUILD but it seems the newer version of the application may have some dependencies that are a little older than the current arch versions.. I am trying to figure out the best way to get this updated so it will work properly via a makepkg install but that may not be possible.

Here is a link to the old PKGBUILD: https://aur.archlinux.org/packages/scrt/

The new version of the application seems to depend on libicuio.so.63 and a few others .63 version. The new versions of the package is on my git github.com/caldog20/scrt, one is for Ubuntu 19.x and other is for Ubuntu 18.04LTS. I didn't see a big deps difference between them.

I would like to get some input on if this is possible to PKGBUILD again and how the dependencies would work..

Offline

#2 2020-05-18 15:50:29

loqs
Member
Registered: 2014-03-06
Posts: 10,578

Re: Requesting help with updating old PKGBUILD on AUR

https://aur.archlinux.org/packages/icu63 will provide

icu63 /usr/lib/libicudata.so.63
icu63 /usr/lib/libicudata.so.63.2
icu63 /usr/lib/libicui18n.so.63
icu63 /usr/lib/libicui18n.so.63.2
icu63 /usr/lib/libicuio.so.63
icu63 /usr/lib/libicuio.so.63.2
icu63 /usr/lib/libicutest.so.63
icu63 /usr/lib/libicutest.so.63.2
icu63 /usr/lib/libicutu.so.63
icu63 /usr/lib/libicutu.so.63.2
icu63 /usr/lib/libicuuc.so.63
icu63 /usr/lib/libicuuc.so.63.2

Offline

Board footer

Powered by FluxBB