You are not logged in.

#1 2020-05-19 16:32:51

Ayush1325
Member
From: India
Registered: 2019-09-23
Posts: 6

Not Able to login to Eve Online launcher

So, I just switched from Gnome to a window manager(qtile) and thought to reinstall arch coz gnome left a lot of junk behind. Anyway, when I installed Eve Online in lutris, I just can't login.
To elaborate, I installed it from this lutris script: [link] (https://lutris.net/games/eve-online/).
Installed wine, wine-mono and other stuff from standard repos + multilib. So it installs just fine. On first start up, it shows up an update to launcher. After updating, well, it downloads the game but gets stuck at loading screen in the launcher and doesn't show any login button. If I go to settings, it shows the login button but as soon as I click it, it goes back to loading. It also shows an error: "ServerCertificate is invalid" for some fonts. That error seems to be fine as it occurred for some people back in 2018 and it should be safe to just ignore it.
If I cancel the update, it installs and shows the login button shows up but when I click it, the login screen is just white, I can view source and it's just fine but the actual screen stays white.
Also, even though I installed wine-mono, it still shows the wine-mono is not installed when installing the game, while it does detect wine-gecko.
I also can't ping through the wine console from lutris although I never tried in my gnome setup so don't know if it worked in the either.
I also switched to NetworkManager from netctl because I thought it might be an issue with dns or something and NetworkManager seems to better handle dynamic stuff, but it didn't really help. So it would be great if someone can help or point to some sources that might help?

This is the wine log:

Running /home/ayush/.local/share/lutris/runners/wine/lutris-5.6-2-x86_64/bin/wine /home/ayush/Games/eve-online/drive_c/EVE/eve.exe
Initial process has started with pid 96304
Game is considered started.
esync: up and running.
Initial process has exited.
info:  Game: evelauncher.exe
info:  DXVK: v1.6.1+
info:  Built-in extension providers:
info:    Win32 WSI
info:    OpenVR
warn:  OpenVR: Failed to locate module
info:  Enabled instance extensions:
info:    VK_KHR_get_surface_capabilities2
info:    VK_KHR_surface
info:    VK_KHR_win32_surface
warn:  D3D9: VK_FORMAT_D16_UNORM_S8_UINT -> VK_FORMAT_D24_UNORM_S8_UINT
info:  GeForce GTX 1050 Ti:
info:    Driver: 440.82.0
info:    Vulkan: 1.1.119
info:    Memory Heap[0]: 
info:      Size: 4096 MiB
info:      Flags: 0x1
info:      Memory Type[7]: Property Flags = 0x1
info:      Memory Type[8]: Property Flags = 0x1
info:    Memory Heap[1]: 
info:      Size: 12015 MiB
info:      Flags: 0x0
info:      Memory Type[0]: Property Flags = 0x0
info:      Memory Type[1]: Property Flags = 0x0
info:      Memory Type[2]: Property Flags = 0x0
info:      Memory Type[3]: Property Flags = 0x0
info:      Memory Type[4]: Property Flags = 0x0
info:      Memory Type[5]: Property Flags = 0x0
info:      Memory Type[6]: Property Flags = 0x0
info:      Memory Type[9]: Property Flags = 0x6
info:      Memory Type[10]: Property Flags = 0xe
info:  Process set as DPI aware
[44:45:0519/215239.987:ERROR:network_change_notifier_win.cc(157)] WSALookupServiceBegin failed with: 8
wine: Unhandled exception 0x80000003 in thread 99 at address 027C3CC5 (thread 0099), starting debugger...
0x027c3cc5 EntryPoint+0xffffffff in qt5webenginecore: int	$3
Modules:
Module	Address			Debug info	Name (80 modules)
PE	  330000-  343000	Deferred        vcruntime140
PE	  350000-  369000	Deferred        qt5webchannel
PE	  370000-  3b2000	Deferred        qt5positioning
PE	  400000-  408000	Export          qtwebengineprocess
PE	  410000- 3dc0000	Export          qt5webenginecore
PE	 3dc0000- 40d1000	Deferred        qt5quick
PE	 40e0000- 4605000	Deferred        qt5gui
PE	10000000-1006f000	Deferred        msvcp140
PE	62440000-62700000	Deferred        d3d9
PE	64000000-64103000	Deferred        qt5network
PE	66000000-66347000	Deferred        qt5qml
PE	67000000-674e3000	Deferred        qt5core
PE	6a540000-6a842000	Deferred        d3d11
PE	7a840000-7a849000	Deferred        opengl32
PE	7b020000-7b03c000	Deferred        kernelbase
PE	7b420000-7b5f1000	Deferred        kernel32
PE	7bc30000-7bc47000	Deferred        ntdll
PE	7bda0000-7bda4000	Deferred        kerberos
PE	7bde0000-7bde4000	Deferred        api-ms-win-core-fibers-l1-1-1
PE	7bdf0000-7bdf4000	Deferred        api-ms-win-core-synch-l1-2-0
PE	7be10000-7be16000	Deferred        uxtheme
PE	7c820000-7c825000	Deferred        winex11
PE	7c8d0000-7c8d4000	Deferred        dxva2
PE	7c900000-7c923000	Deferred        wininet
PE	7c990000-7c9a4000	Deferred        urlmon
PE	7ca30000-7ca35000	Deferred        hid
PE	7ca70000-7ca85000	Deferred        msvcrt
PE	7cb30000-7cb38000	Deferred        winevulkan
PE	7cb70000-7cb78000	Deferred        vulkan-1
PE	7cbc0000-7cbca000	Deferred        wined3d
PE	7cd20000-7cf25000	Deferred        dxgi
PE	7cd20000-7cf25000	Deferred        msdmo
PE	7cd20000-7cf25000	Deferred        dwmapi
PE	7cd20000-7cf25000	Deferred        dwrite
PE	7cd20000-7cf25000	Deferred        winhttp
PE	7cd20000-7cf25000	Deferred        jsproxy
PE	7cd20000-7cf25000	Deferred        secur32
PE	7cd20000-7cf25000	Deferred        ncrypt
PE	7cd20000-7cf25000	Deferred        dhcpcsvc
PE	7cd20000-7cf25000	Deferred        psapi
PE	7cf30000-7cf3e000	Deferred        oleaut32
PE	7d050000-7d057000	Deferred        dbghelp
PE	7d0d0000-7d0de000	Deferred        winspool
PE	7d130000-7d1dd000	Deferred        comdlg32
PE	7d230000-7d235000	Deferred        bcrypt
PE	7d260000-7d2a8000	Deferred        crypt32
PE	7d340000-7d344000	Deferred        api-ms-win-crt-utility-l1-1-0
PE	7d360000-7d364000	Deferred        api-ms-win-crt-environment-l1-1-0
PE	7d370000-7d374000	Deferred        api-ms-win-crt-time-l1-1-0
PE	7d380000-7d384000	Deferred        api-ms-win-crt-filesystem-l1-1-0
PE	7d390000-7d397000	Deferred        api-ms-win-crt-math-l1-1-0
PE	7d3b0000-7d3b4000	Deferred        api-ms-win-crt-locale-l1-1-0
PE	7d3c0000-7d3c5000	Deferred        api-ms-win-crt-convert-l1-1-0
PE	7d3d0000-7d3d6000	Deferred        api-ms-win-crt-stdio-l1-1-0
PE	7d3f0000-7d3f6000	Deferred        api-ms-win-crt-string-l1-1-0
PE	7d400000-7d404000	Deferred        api-ms-win-crt-heap-l1-1-0
PE	7d410000-7d415000	Deferred        api-ms-win-crt-runtime-l1-1-0
PE	7d430000-7d4b0000	Deferred        winmm
PE	7d500000-7d506000	Deferred        imm32
PE	7d520000-7d524000	Deferred        usp10
PE	7d580000-7d5d6000	Deferred        comctl32
PE	7d6c0000-7d6ca000	Deferred        aclui
PE	7d700000-7d72d000	Deferred        ole32
PE	7d840000-7d846000	Deferred        shcore
PE	7d870000-7d882000	Deferred        shlwapi
PE	7d900000-7e1fc000	Deferred        shell32
PE	7e300000-7e304000	Deferred        userenv
PE	7e330000-7e337000	Deferred        dnsapi
PE	7e360000-7e367000	Deferred        ws2_32
PE	7e3a0000-7e3a7000	Deferred        iphlpapi
PE	7e3d0000-7e3d8000	Deferred        netapi32
PE	7e420000-7e42e000	Deferred        gdi32
PE	7e580000-7e58d000	Deferred        rpcrt4
PE	7e600000-7e60d000	Deferred        advapi32
PE	7e6b0000-7e6d8000	Deferred        ucrtbase
PE	7e790000-7e795000	Deferred        version
PE	7e7c0000-7e7d9000	Deferred        setupapi
PE	7e860000-7e954000	Deferred        user32
PE	7ea70000-7ea7d000	Deferred        mpr
PE	7eaa0000-7eaa3000	Deferred        wow64cpu
Threads:
process  tid      prio (all id:s are in hex)
0000000e services.exe
	00000025    0
	00000022    0
	0000001d    0
	0000001a    0
	00000013    0
	00000010    0
	0000000f    0
00000011 plugplay.exe
	00000017    0
	00000016    0
	00000012    0
00000018 winedevice.exe
	0000001f    0
	0000001e    0
	0000001c    0
	0000001b    0
	00000019    0
00000020 winedevice.exe
	00000026    0
	00000024    0
	00000023    0
	00000021    0
00000027 explorer.exe
	0000002b    0
	0000002a    0
	00000029    0
	00000028    0
00000098 (D) C:\EVE\Launcher\QtWebEngineProcess.exe
	["C:\EVE\Launcher\QtWebEngineProcess.exe" --type=renderer --no-sandbox --disable-gpu-memory-buffer-video-frames --enable-threaded-compositing --enable-features=AllowContentInitiatedDataUrlNavigations --disable-features=MojoVideoCapture,SurfaceSynchronization,UseModernMediaControls,UseVideoCaptureApiForDevToolsSnapshots --disable-gpu-compositing --service-pipe-token=5606845546139437318 --lang=en-IN --webengine-schemes=qrc:sLV --device-scale-factor=1 --num-raster-threads=4 --enable-main-frame-before-activation --service-request-channel-token=5606845546139437318 --renderer-client-id=3 --mojo-platform-channel-handle=1752 /prefetch:1]
	00000142    0
	00000112    0
	0000010e    0
	000000e3    0
	000000a9   -2
	000000a8    0
	000000a7    0
	000000a6    0
	000000a5    0
	000000a4    0
	000000a3    0
	000000a2    0
	000000a1    0
	000000a0    0
	0000009f   -2
	0000009e   -2
	0000009d    0
	0000009c    0
	0000009b    0
	0000009a    0
	00000099    0 <==
System information:
    Wine build: wine-5.6.1.r0.g4c160ec8 ( TkG Staging Esync Fsync Vkd3d DXVK-Compatible )
    Platform: i386 (WOW64)
    Version: Windows 8
    Host system: Linux
    Host version: 5.6.13-arch1-1
Game is considered exited.
All monitored processes have exited.
Exit with returncode 0

Last edited by Ayush1325 (2020-05-19 16:48:37)

Offline

#2 2020-05-19 16:36:20

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,856
Website

Re: Not Able to login to Eve Online launcher

Please use code tags, rather than quote tags, for terminal output.

https://wiki.archlinux.org/index.php/Co … s_and_code


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#3 2020-05-20 05:48:09

rowdog
Member
From: East Texas
Registered: 2009-08-19
Posts: 101

Re: Not Able to login to Eve Online launcher

I "won" Eve Online a while ago but I don't remember having any problems with the unofficial Linux launcher. The only downside to CCP's launcher is that it installs a separate version of wine. The upside is, that's the version of wine that the launcher was coded to.

You might want to check out the official Eve forum for Linux.
https://forums.eveonline.com/c/technolo … h/linux/77

Good luck and fly dangerous! o7

Offline

Board footer

Powered by FluxBB