You are not logged in.

#1 2020-05-10 19:22:40

Registered: 2020-05-10
Posts: 2

Thunderbolt 3 USB-C to HDMI adapter is not working. Please help.

Hi. I hope everyone is doing well. I have a Lenovo Yoga C940 which has a USB-C port and is thunderbolt compatible. I got a USB-C to HDMI adapter and while it works on other Windows computers ( I know its not a hard ware problem ), it is finicky on arch Linux.

When it is plugged in and an HDMI cable is connected during boot, it works however, if it is plugged in after boot it does not. However, if I unplug and re plug the HDMI cable attached to the adapter after two or three times, the monitor turns on and every thing works flawlessly. In addition, when the adapter is unplugged, as expected, arch switches to the laptop monitor.

When I ran udevadm monitor, I nothing is detected when the adapter is plugged in. In addition, xrandr does not seem to show the external monitor when I run xrandr -q.

I don't know if its related but every time a unplug and re plug the HDMI cable and run xrandr -q, the monitor has a new name. At first ( after reboot ), it is XWAYLAND0, then XWAYLAND1, XWAYLAND2, etc.

Does anyone have any questions, or tips to help me? Thanks for your time.


When I ran dmesg, I saw the following error:
[11061.218710] usb usb2-port1: Cannot enable. Maybe the USB cable is bad?

I have also confirmed that it is not a USB autosuspend problem because I turned that off for those ports yet the problem persists.

It seems that the error is not with udev or xrandr or something but instead maybe with the USB drivers.

Last edited by brandonf (2020-05-11 01:22:23)


#2 2020-05-21 11:13:47

Registered: 2013-05-16
Posts: 154

Re: Thunderbolt 3 USB-C to HDMI adapter is not working. Please help.


I have a comparable machine, the Yoga S940 IWL; I experimented a lot recently with thunderbolt on it in order to get my lenovo thunderbolt dock running.
Though it is probably unrelated: as it complains about usb, you could try to compile thunderbolt support into the kernel (CONFIG_USB4=y) and see if this changes anything.


Board footer

Powered by FluxBB