You are not logged in.

#1 2020-05-21 19:33:27

Coleim
Member
Registered: 2020-05-21
Posts: 1

ath10k_pci firmware crashed

Hello,

I have a brand new install of archlinux, and I got issues with the wifi disconnecting suddently.

It seems to occurs when I used "too much" bandwith or downloading "too much" data.
(For example `yaourt -S firefox` make it crash. Or a simple npm install)
It also occurs when browsing simple websites.

I looked at dmesg, and sometimes I got this error:

[  206.344550] ath10k_pci 0000:3a:00.0: firmware crashed! (guid ed77719a-878f-4751-a741-dadc4d015d25)
[  206.344565] ath10k_pci 0000:3a:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 1a56:1535
[  206.344571] ath10k_pci 0000:3a:00.0: kconfig debug 1 debugfs 1 tracing 1 dfs 0 testmode 0
[  206.346795] ath10k_pci 0000:3a:00.0: firmware ver WLAN.RM.4.4.1-00140-QCARMSWPZ-1 api 6 features wowlan,ignore-otp,mfp crc32 29eb8ca1
[  206.348594] ath10k_pci 0000:3a:00.0: board_file api 2 bmi_id N/A crc32 4ac0889b
[  206.348602] ath10k_pci 0000:3a:00.0: htt-ver 3.60 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[  206.348746] ath10k_pci 0000:3a:00.0: firmware register dump:
[  206.348753] ath10k_pci 0000:3a:00.0: [00]: 0x05030000 0x00000000 0x009F3A44 0x00000000
[  206.348758] ath10k_pci 0000:3a:00.0: [04]: 0x009F3A44 0x00060130 0x0000001F 0x00000000
[  206.348763] ath10k_pci 0000:3a:00.0: [08]: 0x00000000 0x00404090 0x00000000 0x00400000
[  206.348768] ath10k_pci 0000:3a:00.0: [12]: 0x00000000 0xFFFFFFFF 0x00952CD0 0x00952CE6
[  206.348773] ath10k_pci 0000:3a:00.0: [16]: 0x00000000 0x00000001 0x00035C00 0x00034828
[  206.348777] ath10k_pci 0000:3a:00.0: [20]: 0x00404010 0x00932EB8 0x00404084 0x0040A054
[  206.348781] ath10k_pci 0000:3a:00.0: [24]: 0x80911154 0x0040EB28 0x00400000 0x00000000
[  206.348785] ath10k_pci 0000:3a:00.0: [28]: 0x00000001 0x00000001 0x00032A44 0x004040F4
[  206.348790] ath10k_pci 0000:3a:00.0: [32]: 0x004042FC 0x0040AB98 0x00032A44 0x00429B6C
[  206.348794] ath10k_pci 0000:3a:00.0: [36]: 0x00429BD8 0x00429D28 0x00000006 0x00000000
[  206.348798] ath10k_pci 0000:3a:00.0: [40]: 0x80911154 0x0040EB28 0x00400000 0x00000000
[  206.348802] ath10k_pci 0000:3a:00.0: [44]: 0x00084008 0x00400000 0x00000008 0x00429CB0
[  206.348806] ath10k_pci 0000:3a:00.0: [48]: 0x8091122D 0x0040EB48 0x00000000 0x00400600
[  206.348811] ath10k_pci 0000:3a:00.0: [52]: 0x00401E20 0x00000001 0x00404BDC 0x00400000
[  206.348815] ath10k_pci 0000:3a:00.0: [56]: 0x40910024 0x0040EB78 0x0040AB98 0x0040AB98
[  206.348818] ath10k_pci 0000:3a:00.0: Copy Engine register dump:
[  206.348833] ath10k_pci 0000:3a:00.0: [00]: 0x00034400  11  11   3   3
[  206.348847] ath10k_pci 0000:3a:00.0: [01]: 0x00034800   0   0  13  14
[  206.348860] ath10k_pci 0000:3a:00.0: [02]: 0x00034c00   9   9  72  73
[  206.348873] ath10k_pci 0000:3a:00.0: [03]: 0x00035000   7   7   9   7
[  206.348887] ath10k_pci 0000:3a:00.0: [04]: 0x00035400 3269 3265 162  98
[  206.348900] ath10k_pci 0000:3a:00.0: [05]: 0x00035800   0   0  64   0
[  206.348913] ath10k_pci 0000:3a:00.0: [06]: 0x00035c00  25  25  10  10
[  206.348926] ath10k_pci 0000:3a:00.0: [07]: 0x00036000   0   0   0   0
[  206.453068] ieee80211 phy0: Hardware restart was requested
[  206.783783] ath10k_pci 0000:3a:00.0: device successfully recovered

Sometimes, this one:

AER: Corrected error received: 0000:00:1c.4
AER: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Transmitter ID)
AER:   device [8086:9d14] error status/mask=00001000/00002000
[12] Timeout

And sometimes, no error at all, but still the wifi does not work.

I found 2 bug reports for that:
https://bugs.archlinux.org/task/55096?s … &closedto=
and
https://bugs.archlinux.org/task/64739?s … &closedto=

But I don't get how to solve it.

I tried to downgrade the firmware. It seems to works for a small time, then it fails again with the same issue.

Just for info, I have this laptop with archlinux since few years now, and the issue seems to occurs since only few months ago.

Any help would be appreciated.

Thanks a lot !

Offline

#2 2020-05-26 09:30:29

Malvineous
Member
From: Brisbane, Australia
Registered: 2011-02-03
Posts: 158
Website

Re: ath10k_pci firmware crashed

Generally only the firmware and the kernel will cause this sort of problem.  If you have downgraded to the firmware you were using when it was last working, and this didn't fix the issue, then downgrading the kernel as well is probably the only other thing you can try.

Offline

Board footer

Powered by FluxBB