You are not logged in.

#1 2020-05-26 19:40:26

artiljerija1914
Member
Registered: 2019-01-06
Posts: 20

assistance with installing Eclipse

I downloaded the package eclipse-java from the AUR. For some reason, the package comes with all the eclipse versions, eclipse-jee, eclipse-cpp, eclipse-php etc. The problem is that these packages seem to be conflicting.

I run makepkg -si

The package gets built successfully.

It gets to the installation part and this is the error message:

==> Installing eclipse package group with pacman -U...
[sudo] password for redacted:
loading packages...
resolving dependencies...
looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: eclipse-java and eclipse-jee are in conflict
==> WARNING: Failed to install built package(s).

I tried messing around with it, but to no avail. Can someone help?

Last edited by artiljerija1914 (2020-05-27 07:30:55)

Offline

#2 2020-05-26 19:50:27

d_fajardo
Member
Registered: 2017-07-28
Posts: 691

Re: assistance with installing Eclipse

Read the comments on the AUR page. Someone has the same issue and there and had the solution of updating the release number in the PKGBUILD.

Offline

#3 2020-05-26 20:08:31

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,799
Website

Re: assistance with installing Eclipse

Please remove the redundant call for help from your topic title: https://wiki.archlinux.org/index.php/Co … ow_to_post

Mod note: moving to AUR Issues


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#4 2020-05-26 20:22:27

artiljerija1914
Member
Registered: 2019-01-06
Posts: 20

Re: assistance with installing Eclipse

d_fajardo wrote:

Read the comments on the AUR page. Someone has the same issue and there and had the solution of updating the release number in the PKGBUILD.

you mean this comment?

jghodd commented on 2020-05-12 16:25   
I'm getting an install conflict between eclipse-java and eclipse-jee. This shouldn;t be happening:
error: unresolvable package conflicts detected error: failed to prepare transaction (conflicting dependencies) :: eclipse-java and eclipse-jee are in conflict
Edit: nevermind. fished out the last PKGBUILD, changed the release number and rebuilt. so, resolved for now.

Could you elaborate on that fix? I am sorry but I have no idea how these packages work.

Offline

#5 2020-05-26 20:36:28

loqs
Member
Registered: 2014-03-06
Posts: 10,991

Re: assistance with installing Eclipse

What pkgver of eclipse-java and eclipse-jee?  What is the output of `pacman -Qip` for those two package archives.

Offline

#6 2020-05-26 21:39:41

artiljerija1914
Member
Registered: 2019-01-06
Posts: 20

Re: assistance with installing Eclipse

loqs wrote:

What pkgver of eclipse-java and eclipse-jee?  What is the output of `pacman -Qip` for those two package archives.

$ pacman -Qip eclipse-java eclipse-jee
error: could not load package 'eclipse-java': could not find or read package
error: could not load package 'eclipse-jee': could not find or read package

Offline

#7 2020-05-26 21:41:28

artiljerija1914
Member
Registered: 2019-01-06
Posts: 20

Re: assistance with installing Eclipse

loqs wrote:

What pkgver of eclipse-java and eclipse-jee?  What is the output of `pacman -Qip` for those two package archives.

There is only one PKGBUILD file
pkgver=4.15

Offline

#8 2020-05-26 21:55:15

loqs
Member
Registered: 2014-03-06
Posts: 10,991

Re: assistance with installing Eclipse

What pkgrel?  Also the output of `pacman -Qip package-archive-list` where package-archive-list is the list of built packages you passed to pacman -U.

Offline

#9 2020-05-26 22:37:44

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,799
Website

Re: assistance with installing Eclipse

WorMzy wrote:

Please remove the redundant call for help from your topic title: https://wiki.archlinux.org/index.php/Co … ow_to_post


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#10 2020-05-27 07:09:36

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 9,991

Re: assistance with installing Eclipse

You should be able to just pick the implementation/bundle you want and simply install that single package. The approach of attempting to allow installation of all of them seems to have lead to issues

Offline

#11 2020-05-27 07:41:43

artiljerija1914
Member
Registered: 2019-01-06
Posts: 20

Re: assistance with installing Eclipse

loqs wrote:

What pkgrel?  Also the output of `pacman -Qip package-archive-list` where package-archive-list is the list of built packages you passed to pacman -U.

pkgrel=6
I didn't run pacman -U, I just ran makepkg -si. I tried just running pacman -U eclipse-java but it doesn't work. I can run the command over the packages the PKGBUILD installs... so this is what I got:
$ pacman -Qip eclipse-java eclipse-jee eclipse-cpp eclipse-php eclipse-rust eclipse-javascript eclipse-common
error: could not load package 'eclipse-java': could not find or read package
error: could not load package 'eclipse-jee': could not find or read package
error: could not load package 'eclipse-cpp': could not find or read package
error: could not load package 'eclipse-php': could not find or read package
error: could not load package 'eclipse-rust': could not find or read package
error: could not load package 'eclipse-javascript': could not find or read package
error: could not load package 'eclipse-common': could not find or read package

I was reading through the PKGBUILD trying to make some sense of what was happening, and found this block of code, seems to imply some choice?
15 _package() {
14   local variant i
13
12   case ${1#eclipse-} in
11     java      ) variant=Java; replaces=(eclipse) ;;
10     jee       ) variant=JEE ;;
  9     cpp       ) variant=C++; replaces=(eclipse-cdt) ;;
  8     php       ) variant=PHP ;;
  7     javascript) variant=JavaScript ;;
  6     rust      ) variant=Rust ;;
  5     *         ) return 1 ;;
  4   esac

Offline

#12 2020-05-27 07:48:17

artiljerija1914
Member
Registered: 2019-01-06
Posts: 20

Re: assistance with installing Eclipse

this is all very convoluted. if it is possible to only install one release of the program, why does the package download all of the releases? I suggest you try to install it yourself, and see for yourself how broken it is.

Offline

#13 2020-05-27 07:48:56

d_fajardo
Member
Registered: 2017-07-28
Posts: 691

Re: assistance with installing Eclipse

Like Videl said, I think it's best to decide which version you're intending to use and just install that. That package attempts to install all versions and that seems to be troublesome.

Last edited by d_fajardo (2020-05-27 07:49:41)

Offline

#14 2020-05-27 07:50:16

artiljerija1914
Member
Registered: 2019-01-06
Posts: 20

Re: assistance with installing Eclipse

V1del wrote:

You should be able to just pick the implementation/bundle you want and simply install that single package. The approach of attempting to allow installation of all of them seems to have lead to issues

d_fajardo wrote:

Like Videl said, I think it's best to decide which version you're intending to use and just install that. That package attempts to install all versions and that seems to be troublesome.

how do I do it? there's only one PKGBUILD, I run makepkg -si over it and it downloads all of the releases, which are conflicting. Then it attempts to install them and fails because obviously eclipse-java and eclipse-jee are conflicting. Why are these all not in different packages?

Last edited by artiljerija1914 (2020-05-27 07:51:19)

Offline

#15 2020-05-27 07:58:21

d_fajardo
Member
Registered: 2017-07-28
Posts: 691

Re: assistance with installing Eclipse

Yes you're right. The packager of eclipse-java is attempting to put all of them in together. Perhaps you can take another from here other than that and just add the java plugin.
One could bring this issue up with the packager.

Offline

#16 2020-05-27 08:11:02

artiljerija1914
Member
Registered: 2019-01-06
Posts: 20

Re: assistance with installing Eclipse

d_fajardo wrote:

Yes you're right. The packager of eclipse-java is attempting to put all of them in together. Perhaps you can take another from here other than that and just add the java plugin.
One could bring this issue up with the packager.

Well I originally posted this thread on the Newbie Corner for a reason. I have no idea how these packages work. As far as I understand, all of the eclipse packages link to one repository called eclipse.git, and it's all the same PKGBUILD, which doesn't work.

A guy in the AUR comments mentions doing the following fix:
fished out the last PKGBUILD, changed the release number and rebuilt

What does fishing out the last PKGBUILD mean?

Offline

#17 2020-05-27 08:42:07

artiljerija1914
Member
Registered: 2019-01-06
Posts: 20

Re: assistance with installing Eclipse

I've come to a working solution. The current version of this package (commit from 2020-05-11) doesn't work, but the last one does. My exact steps:

git reset --hard HEAD~1
makepkg -si

Last edited by artiljerija1914 (2020-05-27 08:43:00)

Offline

#18 2020-05-27 08:56:57

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 9,991

Re: assistance with installing Eclipse

That uses the approach that has apparently lead to issues.

What I meant you should do is simply run makepkg -s and then

pacman -U $relevanteclipse.pkg.tar.zst

(I faintly remember that there should be a possibility to just execute a particular split-package function to get a distinct release, not certain on the syntax though)

Offline

#19 2020-05-27 09:12:12

artiljerija1914
Member
Registered: 2019-01-06
Posts: 20

Re: assistance with installing Eclipse

V1del wrote:

That uses the approach that has apparently lead to issues.

What I meant you should do is simply run makepkg -s and then

pacman -U $relevanteclipse.pkg.tar.zst

(I faintly remember that there should be a possibility to just execute a particular split-package function to get a distinct release, not certain on the syntax though)

This is what I was asking for! Thank you.
Issues are bound to appear because eclipse-java and eclipse-jee should be conflicting packages, because they do conflict. I uninstalled all the other packages as I only need eclipse-java, I should probably be fine.

Offline

Board footer

Powered by FluxBB