You are not logged in.

#1 2020-05-26 16:44:53

potuz
Member
Registered: 2009-10-23
Posts: 31

no usb wifi after kernel upgrade

I updated yesterday to

$ uname -a
Linux vertex 5.6.13-arch1-1 #1 SMP PREEMPT Thu, 14 May 2020 06:52:53 +0000 x86_64 GNU/Linux

The same day, but before rebooting, problems started.
I own a TP-link usb wifi card

$ lsusb -s1:2
Bus 001 Device 002: ID 148f:5572 Ralink Technology, Corp. RT5572 Wireless Adapter

If I plug the same card in the usb bus 5 in the back of this Desktop (USB 3.1) I see these messages:

...
May 25 09:55:22 vertex kernel: rt2800usb_tx_sta_fifo_read_completed: 14001 callbacks suppressed
May 25 09:55:22 vertex kernel: ieee80211 phy0: rt2800usb_tx_sta_fifo_read_completed: Warning - TX status read failed -71
May 25 09:55:22 vertex kernel: ieee80211 phy0: rt2800usb_tx_sta_fifo_read_completed: Warning - TX status read failed -71
May 25 09:55:22 vertex kernel: ieee80211 phy0: rt2800usb_tx_sta_fifo_read_completed: Warning - TX status read failed -71
...

And the card does not even scan for networks. If I plug it in the front Bus 1 (USB 2.0) I can connect. The bus in the back holds also my keyboard and mouse.

Now one would think that this is a problem with the usb bus, but the thing is that on my laptop (which unfortunately was also upgraded yesterday) I see the same TX status read errors.

And now is where things get weirder: booting on and older Kernel 5.5 from a usb-pen I see the same issues (connection on the front bus and not in the back).  At this point I think that there must be a problem with the wifi card, but I don't know how to diagnose this. I am very puzzled cause

I can't say that it's a problem with the usb kernel driver since it behaves now the same with the old boot cd image
I can't say that it's a problem with the wifi driver for the same reason
I can imagine that it's a faulty wifi card, that happened to fail precisely after an update (coincidences happen) but then again, why would it work on one usb hub?
I can't say that it's a faulty usb hub (hardware) cause I see the same messages on my laptop!

The output for both usb root hubs are (wifi connected )

$ sudo lsusb -s1:1 -v

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            9 Hub
  bDeviceSubClass         0 
  bDeviceProtocol         1 Single TT
  bMaxPacketSize0        64
  idVendor           0x1d6b Linux Foundation
  idProduct          0x0002 2.0 root hub
  bcdDevice            5.06
  iManufacturer           3 Linux 5.6.13-arch1-1 xhci-hcd
  iProduct                2 xHCI Host Controller
  iSerial                 1 0000:01:00.0
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength       0x0019
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xe0
      Self Powered
      Remote Wakeup
    MaxPower                0mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         9 Hub
      bInterfaceSubClass      0 
      bInterfaceProtocol      0 Full speed (or root) hub
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0004  1x 4 bytes
        bInterval              12
Hub Descriptor:
  bLength              11
  bDescriptorType      41
  nNbrPorts            10
  wHubCharacteristic 0x000a
    No power switching (usb 1.0)
    Per-port overcurrent protection
    TT think time 8 FS bits
  bPwrOn2PwrGood       10 * 2 milli seconds
  bHubContrCurrent      0 milli Ampere
  DeviceRemovable    0x00 0x00
  PortPwrCtrlMask    0xff 0xff
 Hub Port Status:
   Port 1: 0000.0100 power
   Port 2: 0000.0100 power
   Port 3: 0000.0100 power
   Port 4: 0000.0100 power
   Port 5: 0000.0100 power
   Port 6: 0000.0100 power
   Port 7: 0000.0100 power
   Port 8: 0000.0503 highspeed power enable connect
   Port 9: 0000.0100 power
   Port 10: 0000.0100 power
can't get device qualifier: Resource temporarily unavailable
can't get debug descriptor: Resource temporarily unavailable
Device Status:     0x0001
  Self Powered

And the back bus

$ sudo lsusb -s5:1 -v

Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            9 Hub
  bDeviceSubClass         0 
  bDeviceProtocol         1 Single TT
  bMaxPacketSize0        64
  idVendor           0x1d6b Linux Foundation
  idProduct          0x0002 2.0 root hub
  bcdDevice            5.06
  iManufacturer           3 Linux 5.6.13-arch1-1 xhci-hcd
  iProduct                2 xHCI Host Controller
  iSerial                 1 0000:08:00.3
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength       0x0019
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xe0
      Self Powered
      Remote Wakeup
    MaxPower                0mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         9 Hub
      bInterfaceSubClass      0 
      bInterfaceProtocol      0 Full speed (or root) hub
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0004  1x 4 bytes
        bInterval              12
Hub Descriptor:
  bLength               9
  bDescriptorType      41
  nNbrPorts             4
  wHubCharacteristic 0x000a
    No power switching (usb 1.0)
    Per-port overcurrent protection
    TT think time 8 FS bits
  bPwrOn2PwrGood       10 * 2 milli seconds
  bHubContrCurrent      0 milli Ampere
  DeviceRemovable    0x00
  PortPwrCtrlMask    0xff
 Hub Port Status:
   Port 1: 0000.0303 lowspeed power enable connect
   Port 2: 0000.0100 power
   Port 3: 0000.0303 lowspeed power enable connect
   Port 4: 0000.0100 power
can't get device qualifier: Resource temporarily unavailable
can't get debug descriptor: Resource temporarily unavailable
Device Status:     0x0001
  Self Powered

I'll appreciate any help.

Last edited by potuz (2020-05-26 17:53:45)

Offline

#2 2020-05-26 20:50:37

seth
Member
Registered: 2012-09-03
Posts: 15,399

Re: no usb wifi after kernel upgrade

The warnings are not necessarily a problem.
a) do you also get them on the front bus?
b) can you use the wifi-dongle on your notebook?
c) was linux-firmware among the updates?

Edit, see https://bugzilla.kernel.org/show_bug.cgi?id=202541#c53

Last edited by seth (2020-05-26 20:52:47)

Offline

#3 2020-05-26 23:02:34

potuz
Member
Registered: 2009-10-23
Posts: 31

Re: no usb wifi after kernel upgrade

Thanks for getting back to me

seth wrote:

The warnings are not necessarily a problem.
a) do you also get them on the front bus?

no

seth wrote:

b) can you use the wifi-dongle on your notebook?

no, I cannot use it on any USB 3.1 on any system at home. Unfortunately all of them use Arch and have been updated the same day, so I'll have to go to work (which is unlikely these days) to try this on a different system, or should downgrade the kernel, but I think the experiment with the pendrive already does this.

seth wrote:

c) was linux-firmware among the updates?

No.

Thanks, I hadn't seen that one, I'll have to go through that report carefully, it seems to match some reports there but not others.

So far I am leaning towards some weird malfunction on my wifi-dongle that prevents it from working on USB-3.1. Something I do not know: is 3.1 (or more power) needed for 5GHz? cause I realized that the card cannot connect to 5GHz networks now.

Offline

#4 2020-05-27 06:40:30

seth
Member
Registered: 2012-09-03
Posts: 15,399

Re: no usb wifi after kernel upgrade

is 3.1 (or more power) needed for 5GHz?

Not inherently and the dongle is probably USB 2.0 anyway?
But 5GHz is easier blocked than 2.4GHz - maybe the orientation on your desktop matters.
Does it find 5GHz networks in scans?

Offline

#5 2020-05-27 12:37:18

potuz
Member
Registered: 2009-10-23
Posts: 31

Re: no usb wifi after kernel upgrade

seth wrote:

is 3.1 (or more power) needed for 5GHz?

Not inherently and the dongle is probably USB 2.0 anyway?

Good point

But 5GHz is easier blocked than 2.4GHz - maybe the orientation on your desktop matters.
Does it find 5GHz networks in scans?

No, but it connected fine to 5GHz up until a couple of days ago from this same desktop, to the point that I removed the entries for the 2.4 network in my wpa_supplicant.conf.

Offline

#6 2020-05-27 13:55:38

seth
Member
Registered: 2012-09-03
Posts: 15,399

Re: no usb wifi after kernel upgrade

Let's see what else got updated yesterday (maybe some powermanagement tool?) - post your pacman log.

Offline

#7 2020-05-27 16:43:34

potuz
Member
Registered: 2009-10-23
Posts: 31

Re: no usb wifi after kernel upgrade

seth wrote:

Let's see what else got updated yesterday (maybe some powermanagement tool?) - post your pacman log.

These are the packages that have changed

 upgraded gcc-libs (9.3.0-1 -> 10.1.0-1)
  upgraded aspell (0.60.8-1 -> 0.60.8-2)
  upgraded atkmm (2.28.0-1 -> 2.28.0-2)
  upgraded libunwind (1.3.1-1 -> 1.3.1-2)
  upgraded libxau (1.0.9-2 -> 1.0.9-3)
  upgraded libxdmcp (1.1.3-2 -> 1.1.3-3)
  upgraded libx11 (1.6.9-6 -> 1.6.9-7)
  upgraded libxext (1.3.4-2 -> 1.3.4-3)
  upgraded libxxf86vm (1.1.4-3 -> 1.1.4-4)
  upgraded libxfixes (5.0.3-3 -> 5.0.3-4)
  upgraded libxdamage (1.1.5-2 -> 1.1.5-3)
  upgraded libomxil-bellagio (0.9.3-2 -> 0.9.3-3)
  upgraded llvm-libs (10.0.0-1 -> 10.0.0-2)
  upgraded lm_sensors (3.6.0-1 -> 3.6.0-2)
  upgraded libp11-kit (0.23.20-4 -> 0.23.20-5)
  upgraded p11-kit (0.23.20-4 -> 0.23.20-5)
  upgraded libsasl (2.1.27-2 -> 2.1.27-3)
  upgraded ca-certificates-mozilla (3.52-1 -> 3.52.1-2)
  upgraded libpciaccess (0.16-1 -> 0.16-2)
  upgraded eglexternalplatform (1.1-1 -> 1.1-2)
  upgraded egl-wayland (1.1.4-2 -> 1.1.4-3)
  upgraded libepoxy (1.5.4-1 -> 1.5.4-2)
  upgraded libpng (1.6.37-1 -> 1.6.37-2)
  upgraded harfbuzz (2.6.5-2 -> 2.6.6-1)
  upgraded freetype2 (2.10.1-2 -> 2.10.2-1)
  upgraded libfontenc (1.1.4-1 -> 1.1.4-2)
  upgraded libxfont2 (2.0.4-2 -> 2.0.4-3)
  upgraded pcre2 (10.34-3 -> 10.35-1)
  upgraded libnfnetlink (1.0.1-3 -> 1.0.1-4)
  upgraded xf86-input-libinput (0.29.0-2 -> 0.30.0-1)
  upgraded libxkbfile (1.1.0-1 -> 1.1.0-2)
  upgraded xorg-setxkbmap (1.3.2-1 -> 1.3.2-2)
  upgraded mesa (20.0.6-2 -> 20.0.7-2)
  upgraded libxrender (0.9.10-3 -> 0.9.10-4)
  upgraded libxi (1.7.10-2 -> 1.7.10-3)
  upgraded shared-mime-info (2.0+1+g6bf9e4f-1 -> 2.0+1+g6bf9e4f-2)
  upgraded libtiff (4.1.0-1 -> 4.1.0-2)
  upgraded libdaemon (0.14-4 -> 0.14-5)
  upgraded xorg-xprop (1.2.4-1 -> 1.2.4-2)
  upgraded libice (1.0.10-2 -> 1.0.10-3)
  upgraded libxt (1.2.0-1 -> 1.2.0-2)
  upgraded libxmu (1.1.3-1 -> 1.1.3-2)
  upgraded attica (5.69.0-1 -> 5.70.0-1)
  upgraded libmad (0.15.1b-8 -> 0.15.1b-9)
  upgraded gstreamer (1.16.2-1 -> 1.16.2-2)
  upgraded orc (0.4.31-1 -> 0.4.31-2)
  upgraded libxv (1.0.11-3 -> 1.0.11-4)
  upgraded iso-codes (4.4-1 -> 4.4-2)
  upgraded gst-plugins-base-libs (1.16.2-1 -> 1.16.2-2)
  upgraded wxgtk-common (3.0.5-1 -> 3.0.5.1-1)
  upgraded cairo (1.17.2+17+g52a7c79fd-2 -> 1.17.2+25+gaee96d175-1)
  upgraded json-glib (1.4.4-1 -> 1.4.4-2)
 upgraded libxcomposite (0.4.5-2 -> 0.4.5-3)
  upgraded libxcursor (1.2.0-1 -> 1.2.0-2)
  upgraded libxinerama (1.1.4-2 -> 1.1.4-3)
  upgraded libxrandr (1.5.2-2 -> 1.5.2-3)
  upgraded libdatrie (0.2.12-1 -> 0.2.12-2)
  upgraded libthai (0.1.28-1 -> 0.1.28-2)
  upgraded libxft (2.3.3-1 -> 2.3.3-2)
  upgraded libtool (2.4.6+42+gb88cebd5-12 -> 2.4.6+42+gb88cebd5-13)
  upgraded sound-theme-freedesktop (0.8-3 -> 0.8-4)
  upgraded hicolor-icon-theme (0.17-1 -> 0.17-2)
  upgraded libxtst (1.2.3-3 -> 1.2.3-4)
  upgraded lcms2 (2.9-2 -> 2.9-3)
  upgraded wxgtk3 (3.0.5-1 -> 3.0.5.1-1)
  upgraded libid3tag (0.15.1b-9 -> 0.15.1b-11)
  upgraded vamp-plugin-sdk (2.9.0-1 -> 2.10.0-1)
  upgraded portsmf (234-1 -> 234-2)
  upgraded zita-alsa-pcmi (0.3.2-2 -> 0.3.2-3)
  upgraded zita-resampler (1.6.2-2 -> 1.6.2-3)
  upgraded audacity (1:2.3.3-2 -> 1:2.4.0-1)
  upgraded bash-completion (2.10-1 -> 2.10-2)
  upgraded binutils (2.34-2 -> 2.34-3)
  upgraded bison (3.5.4-1 -> 3.6.2-1)
  upgraded blas (3.9.0-2 -> 3.9.0-3)
  upgraded breeze-icons (5.69.0-1 -> 5.70.0-1)
  upgraded btrfs-progs (5.6-1 -> 5.6.1-2)
  upgraded c-ares (1.16.0-1 -> 1.16.1-1)
  upgraded cairomm (1.12.2-3 -> 1.12.2-4)
  upgraded cblas (3.9.0-2 -> 3.9.0-3)
  upgraded cdparanoia (10.2-7 -> 10.2-8)
  upgraded nss (3.52-1 -> 3.52.1-2)
  upgraded libxss (1.2.3-2 -> 1.2.3-3)
  upgraded libvpx (1.8.2-1 -> 1.8.2-2)
  upgraded libass (0.14.0-1 -> 0.14.0-2)
  upgraded libraw1394 (2.1.2-2 -> 2.1.2-3)
  upgraded libavc1394 (0.5.4-3 -> 0.5.4-4)
  upgraded libiec61883 (1.2.0-5 -> 1.2.0-6)
  upgraded libmodplug (0.8.9.0-2 -> 0.8.9.0-3)
  upgraded libvdpau (1.3-1 -> 1.4-1)
  upgraded vid.stab (1.1-2 -> 1.1-3)
  upgraded xvidcore (1.3.7-1 -> 1.3.7-2)
  upgraded opencore-amr (0.1.5-3 -> 0.1.5-4)
  upgraded openjpeg2 (2.3.1-1 -> 2.3.1-2)
  upgraded speex (1.2.0-2 -> 1.2.0-3)
  upgraded srt (1.4.1-1 -> 1.4.1-2)
  installed vmaf (1.5.1-1)
  upgraded vulkan-icd-loader (1.2.137-1 -> 1.2.140-1)
  upgraded libibus (1.5.22-1 -> 1.5.22+8+gf591381e-1)
  upgraded l-smash (2.14.5-1 -> 2.14.5-2)
  upgraded ffmpeg (1:4.2.2-6 -> 1:4.2.2-8)
  upgraded libxslt (1.1.34-2 -> 1.1.34-3)
  upgraded chromium (81.0.4044.138-2 -> 83.0.4103.61-1)
  upgraded clucene (2.3.3.4-10 -> 2.3.3.4-11)
  upgraded openexr (2.4.1-2 -> 2.5.1-1)
  upgraded lensfun (0.3.95-1 -> 0.3.95-2)
  upgraded gst-plugins-base (1.16.2-1 -> 1.16.2-2)
  upgraded lapack (3.9.0-2 -> 3.9.0-3)
  upgraded libxpm (3.5.13-1 -> 3.5.13-2)
  upgraded opencv (4.3.0-4 -> 4.3.0-7)
  upgraded fftw (3.3.8-2 -> 3.3.8-3)
  upgraded gmic (2.9.0-3 -> 2.9.0-10)
  upgraded darktable (2:3.0.2-2 -> 2:3.0.2-5)
  upgraded dbus-glib (0.110-1 -> 0.110-2)
  upgraded djvulibre (3.5.27-5 -> 3.5.27-6)
  upgraded ethtool (1:5.4-1 -> 1:5.6-1)
  upgraded startup-notification (0.12-6 -> 0.12-7)
  upgraded exo (0.12.11-1 -> 0.12.11-2)
  upgraded fuse2 (2.9.9-3 -> 2.9.9-4)
  upgraded gc (8.0.4-3 -> 8.0.4-4)
  upgraded gcc (9.3.0-1 -> 10.1.0-1)
  upgraded gcc-fortran (9.3.0-1 -> 10.1.0-1)
  upgraded libspiro (1:20190731-1 -> 1:20200505-1)
  upgraded gegl (0.4.22-1 -> 0.4.22-3)
  upgraded libmng (2.0.3-2 -> 2.0.3-3)
  upgraded gsfonts (20180524-2 -> 20180524-3)
  upgraded libwmf (0.2.12-1 -> 0.2.12-2)
  upgraded gimp (2.10.18-6 -> 2.10.18-8)
  upgraded gtkmm3 (3.24.2-1 -> 3.24.2-2)
  upgraded harfbuzz-icu (2.6.5-2 -> 2.6.6-1)
  upgraded net-snmp (5.8-4 -> 5.8-5)
  upgraded ijs (0.35-2 -> 0.35-3)
  upgraded liblqr (0.4.2-2 -> 0.4.2-3)
  upgraded imagemagick (7.0.10.10-2 -> 7.0.10.13-1)
  upgraded perl-xml-namespacesupport (1.12-3 -> 1.12-4)
  upgraded perl-capture-tiny (0.48-2 -> 0.48-3)
  upgraded perl-ffi-checklib (0.26-1 -> 0.27-1)
  upgraded perl-file-which (1.23-2 -> 1.23-3)
  upgraded perl-alien-build (2.22-1 -> 2.23-1)
  upgraded perl-xml-sax-base (1.09-3 -> 1.09-4)
  upgraded libidn (1.35-2 -> 1.35-3)
  upgraded python (3.8.2-2 -> 3.8.3-1)
  upgraded python-appdirs (1.4.3-5 -> 1.4.4-1)
  upgraded python-packaging (20.3-1 -> 20.4-1)
  upgraded python-ordered-set (3.1.1-1 -> 3.1.1-2)
  upgraded python-setuptools (1:46.1.3-1 -> 1:46.4.0-1)
  upgraded hplip (1:3.20.3-2 -> 1:3.20.5-2)
  upgraded hyphen (2.8.8-2 -> 2.8.8-3)
  upgraded imlib2 (1.6.1-1 -> 1.6.1-2)
  upgraded perl-timedate (2.32-1 -> 2.33-1)
  upgraded perl-http-date (6.05-1 -> 6.05-2)
  upgraded perl-lwp-mediatypes (6.02-6 -> 6.02-7)
  upgraded perl-http-message (6.22-1 -> 6.24-1)
  upgraded perl-http-cookies (6.08-1 -> 6.08-2)
  upgraded perl-try-tiny (0.30-3 -> 0.30-4)
  upgraded perl-www-robotrules (6.02-6 -> 6.02-7)
  upgraded intltool (0.51.0-4 -> 0.51.0-5)
  upgraded jansson (2.12-2 -> 2.13.1-1)
  upgraded media-player-info (24-1 -> 24-2)
  upgraded libatasmart (0.19-4 -> 0.19-5)
  upgraded volume_key (0.3.12-2 -> 0.3.12-3)
  upgraded libblockdev (2.23-3 -> 2.23-4)
  upgraded libplist (2.1.0-2 -> 2.1.0-3)
  upgraded libimobiledevice (1.2.0+87+g92c5462-6 -> 1.2.0+87+g92c5462-7)
  upgraded solid (5.69.0-1 -> 5.70.0-1)
  upgraded kcoreaddons (5.69.0-1 -> 5.70.0-1)
 upgraded kjobwidgets (5.69.0-1 -> 5.70.0-1)
  upgraded kdbusaddons (5.69.0-1 -> 5.70.0-1)
  upgraded kconfig (5.69.0-1 -> 5.70.0-1)
  upgraded kwindowsystem (5.69.0-1 -> 5.70.0-1)
  upgraded kcrash (5.69.0-1 -> 5.70.0-1)
  upgraded kglobalaccel (5.69.0-1 -> 5.70.0-1)
  upgraded kauth (5.69.0-1 -> 5.70.0-1)
  upgraded kcodecs (5.69.0-1 -> 5.70.0-1)
  upgraded kguiaddons (5.69.0-1 -> 5.70.0-1)
  upgraded ki18n (5.69.0-1 -> 5.70.0-1)
  upgraded kconfigwidgets (5.69.0-1 -> 5.70.0-1)
  upgraded kitemviews (5.69.0-1 -> 5.70.0-1)
  upgraded karchive (5.69.0-1 -> 5.70.0-1)
  upgraded kiconthemes (5.69.0-1 -> 5.70.0-1)
  upgraded kxmlgui (5.69.0-1 -> 5.70.0-1)
  upgraded kbookmarks (5.69.0-2 -> 5.70.0-1)
  upgraded knotifications (5.69.0-1 -> 5.70.0-1)
  upgraded kservice (5.69.0-1 -> 5.70.0-1)
  upgraded kwallet (5.69.0-1 -> 5.70.0-1)
  upgraded kcompletion (5.69.0-1 -> 5.70.0-1)
  upgraded sonnet (5.69.0-1 -> 5.70.0-1)
  upgraded ktextwidgets (5.69.0-1 -> 5.70.0-1)
  installed kded (5.70.0-1)
  upgraded kio (5.69.0-1 -> 5.70.1-1)
  upgraded kpackage (5.69.0-1 -> 5.70.0-1)
  upgraded kdeclarative (5.69.0-1 -> 5.70.0-1)
  upgraded kcmutils (5.69.0-1 -> 5.70.0-1)
  upgraded signond (8.60-1 -> 8.60-2)
  upgraded signon-kwallet-extension (20.04.0-1 -> 20.04.1-1)
  upgraded signon-plugin-oauth2 (0.24-2 -> 0.24-3)
  upgraded xorg-fonts-encodings (1.0.5-1 -> 1.0.5-2)
  upgraded kaccounts-integration (20.04.0-1 -> 20.04.1-1)
  upgraded kactivities (5.69.0-1 -> 5.70.0-1)
  upgraded kirigami2 (5.69.0-1 -> 5.70.0-1)
  upgraded kjs (5.69.0-1 -> 5.70.0-1)
  upgraded kparts (5.69.0-1 -> 5.70.0-1)
  upgraded kpty (5.69.0-1 -> 5.70.0-1)
  upgraded librevenge (0.0.4-2 -> 0.0.4-3)
  upgraded libabw (0.1.3-1 -> 0.1.3-2)
  upgraded libbsd (0.10.0-1 -> 0.10.0-2)
  upgraded libcaca (0.99.beta19-2 -> 0.99.beta19-3)
  upgraded libcddb (1.3.2-5 -> 1.3.2-6)
  upgraded libcdio-paranoia (10.2+2.0.1-1 -> 10.2+2.0.1-2)
  upgraded libepubgen (0.1.1-1 -> 0.1.1-2)
  upgraded libfreehand (0.1.2-2 -> 0.1.2-3)
  upgraded libieee1284 (0.2.11-8 -> 0.2.11-9)
  upgraded libkexiv2 (20.04.0-1 -> 20.04.1-1)
  upgraded liblangtag (0.6.3-1 -> 0.6.3-2)
  upgraded libnumbertext (1.0.5-1 -> 1.0.5-2)
  upgraded libwpd (0.10.3-1 -> 0.10.3-2)
  upgraded libodfgen (0.1.7-1 -> 0.1.7-2)
  upgraded libvoikko (4.3-1 -> 4.3-2)
  upgraded libwpg (0.3.3-1 -> 0.3.3-2)
  upgraded libxaw (1.0.13-2 -> 1.0.13-3)
  upgraded libxml++2.6 (2.40.1-3 -> 2.40.1-4)
  upgraded linux (5.6.11.arch1-1 -> 5.6.13.arch1-1)
  upgraded linux-headers (5.6.11.arch1-1 -> 5.6.13.arch1-1)
  upgraded lpsolve (5.5.2.5-3 -> 5.5.2.5-4)
  upgraded mujs (1.0.6-1 -> 1.0.7-1)
  upgraded mutt (1.14.0-1 -> 1.14.1-1)
  upgraded nvidia (440.82-12 -> 440.82-16)
  upgraded ocl-icd (2.2.12-3 -> 2.2.12-4)
  upgraded threadweaver (5.69.0-1 -> 5.70.0-1)
  upgraded purpose (5.69.0-1 -> 5.70.0-1)
  upgraded okular (20.04.0-1 -> 20.04.1-1)
  upgraded potrace (1.16-1 -> 1.16-2)
  upgraded python-chardet (3.0.4-4 -> 3.0.4-5)
  upgraded python-click (7.1.1-1 -> 7.1.2-1)
  upgraded python-retrying (1.3.3-6 -> 1.3.3-7)
  upgraded python-toml (0.10.0-3 -> 0.10.1-1)
  upgraded python-tzlocal (2.0.0-3 -> 2.1-1)
  upgraded python-unidecode (1.1.1-3 -> 1.1.1-4)
  upgraded python2-appdirs (1.4.3-5 -> 1.4.4-1)
  upgraded python2-defusedxml (0.6.0-3 -> 0.6.0-4)
  upgraded python2-ipaddress (1.0.23-1 -> 1.0.23-2)
  upgraded python2-ordered-set (3.1.1-1 -> 3.1.1-2)
  upgraded python2-packaging (20.3-1 -> 20.4-1)
  upgraded python2-ply (3.11-4 -> 3.11-5)
  upgraded python2-pyopenssl (19.1.0-1 -> 19.1.0-2)
  upgraded redland (1:1.0.17-7 -> 1:1.0.17-8)
  upgraded sane (1.0.29-1 -> 1.0.30-1)
  upgraded sbc (1.4-1 -> 1.4-2)
  upgraded sgml-common (0.6.3-6 -> 0.6.3-7)
  upgraded t1lib (5.1.2-7 -> 5.1.2-8)
  upgraded talloc (2.3.1-1 -> 2.3.1-2)
  upgraded tcl (8.6.10-1 -> 8.6.10-2)
  upgraded tk (8.6.10-1 -> 8.6.10-2)
  upgraded unison (2.51.2-7 -> 2.51.2-8)
  upgraded vdpauinfo (1.3-1 -> 1.4-1)
  upgraded vim-runtime (8.2.0510-2 -> 8.2.0717-2)
  upgraded vim (8.2.0510-2 -> 8.2.0717-2)
  upgraded vpnc (1:0.5.3.r462.r78-1 -> 1:0.5.3.r468.r81-1)
  upgraded w3m (0.5.3.git20190105-1 -> 0.5.3.git20200507-1)
  upgraded webrtc-audio-processing (0.3.1-1 -> 0.3.1-2)
  upgraded xorg-font-util (1.3.2-1 -> 1.3.2-2)
  upgraded xorg-font-utils (7.6-5 -> 7.6-6)
  upgraded xorg-xauth (1.1-1 -> 1.1-2)
  upgraded xorg-xrandr (1.5.1-1 -> 1.5.1-2)
  upgraded xorg-xrdb (1.2.0-1 -> 1.2.0-2)
  upgraded xsane (0.999-3 -> 0.999-4)
  upgraded yajl (2.1.0-2 -> 2.1.0-3)

Offline

#8 2020-05-27 20:32:22

seth
Member
Registered: 2012-09-03
Posts: 15,399

Re: no usb wifi after kernel upgrade

So everything, but nothing that really sticks out as possible offender.
Do you scan using iw or some GUI frontend to networkmanager/whatever?

Last edited by seth (2020-05-27 20:32:34)

Offline

#9 2020-05-27 21:59:31

potuz
Member
Registered: 2009-10-23
Posts: 31

Re: no usb wifi after kernel upgrade

wpa_cli --> scan

But in the laptop that has networkmanager nmtui shows the same

Offline

Board footer

Powered by FluxBB