You are not logged in.

#1 2020-06-02 19:01:07

stueja
Member
Registered: 2015-10-18
Posts: 44

[SOLVED]: Kernel Panic, maybe since last update

Hello all,

I am -- yes, indeed -- experiencing a kernel panic the first time ever since using Arch Linux. The said system has been installed in like 2016, been updated regularly and running ever since. Now, since May 30th, the day of my latest update, the system gets unresponsive irregularly. I looked through pacman's log to see whether I could identify a culprit from there, but I can't seem to find one.

So I brought the system to my desk and hooked it up a monitor and keyboard to see what's happening on the console. Unfortunately, netconsole seems not supported by my driver, so the only information to the panic I can give is this "screenshot".

I'd be happy for any help pushing me into a direction which allows me to solve these intermittent panics.

https://i.imgur.com/eSPbScN.jpg


moderator edit -- replaced oversized image with link.
Pasting pictures and code

Last edited by stueja (2020-06-04 19:26:07)

Offline

#2 2020-06-02 22:44:44

d_fajardo
Member
Registered: 2017-07-28
Posts: 936

Re: [SOLVED]: Kernel Panic, maybe since last update

Looks like hardware to me - exceptions in some hardware interrupt - possibly your network card? Are you wired with your network?
You can test by disabling networking in BIOS and see if you still get panic.

Offline

#3 2020-06-03 14:33:47

T4cC0re
Member
From: Germany
Registered: 2018-06-22
Posts: 3
Website

Re: [SOLVED]: Kernel Panic, maybe since last update

You should try to run your system with the linux-lts kernel (depending on your GPU and other out-of-tree drivers you might need to install other packages as well to boot successfully). 
It might be a bug introduced in a patch to the Realtek network driver that might have caused this panic. At least it is referenced in the trace. If this does not happen with the LTS kernel, it is pretty likely this is a newly introduced issue.

In general, I recommend having the linux-lts kernel installed in case something like this happens to quickly debug whether an issue is due to hardware or the kernel.


|_|0|_|
|_|_|0|
|0|0|0|

Offline

#4 2020-06-03 14:44:09

loqs
Member
Registered: 2014-03-06
Posts: 11,825

Re: [SOLVED]: Kernel Panic, maybe since last update

Please post the contents of pacman.log from the bad update onward.

Offline

#5 2020-06-03 15:19:05

stueja
Member
Registered: 2015-10-18
Posts: 44

Re: [SOLVED]: Kernel Panic, maybe since last update

loqs wrote:

Please post the contents of pacman.log from the bad update onward.

Please see here:

[2020-05-30T17:43:49+0200] [PACMAN] Running 'pacman -Syu'
[2020-05-30T17:43:49+0200] [PACMAN] synchronizing package lists
[2020-05-30T17:43:50+0200] [PACMAN] starting full system upgrade
[2020-05-30T17:44:21+0200] [PACMAN] Running 'pacman -Syu'
[2020-05-30T17:44:21+0200] [PACMAN] synchronizing package lists
[2020-05-30T17:44:21+0200] [PACMAN] starting full system upgrade
[2020-05-30T17:46:50+0200] [ALPM] running '60-mkinitcpio-remove.hook'...
[2020-05-30T17:46:50+0200] [ALPM] transaction started
[2020-05-30T17:46:50+0200] [ALPM] upgraded iana-etc (20200428-1 -> 20200511-1)
[2020-05-30T17:46:52+0200] [ALPM] upgraded filesystem (2020.05.07-1 -> 2020.05.20-1)
[2020-05-30T17:47:00+0200] [ALPM] upgraded glibc (2.31-3 -> 2.31-5)
[2020-05-30T17:47:01+0200] [ALPM-SCRIPTLET] Generating locales...
[2020-05-30T17:47:16+0200] [ALPM-SCRIPTLET]   de_DE.UTF-8... done
[2020-05-30T17:47:31+0200] [ALPM-SCRIPTLET]   en_US.UTF-8... done
[2020-05-30T17:47:31+0200] [ALPM-SCRIPTLET] Generation complete.
[2020-05-30T17:47:46+0200] [ALPM] upgraded gcc-libs (10.1.0-1 -> 10.1.0-2)
[2020-05-30T17:47:46+0200] [ALPM] upgraded flac (1.3.3-1 -> 1.3.3-2)
[2020-05-30T17:47:47+0200] [ALPM] upgraded audiofile (0.3.6-5 -> 0.3.6-6)
[2020-05-30T17:47:47+0200] [ALPM] upgraded bash (5.0.016-1 -> 5.0.017-1)
[2020-05-30T17:47:48+0200] [ALPM] upgraded bash-completion (2.10-1 -> 2.10-2)
[2020-05-30T17:47:48+0200] [ALPM] upgraded bat (0.15.0-1 -> 0.15.4-1)
[2020-05-30T17:47:48+0200] [ALPM] upgraded libcap (2.33-1 -> 2.34-1)
[2020-05-30T17:47:48+0200] [ALPM] upgraded libutil-linux (2.35.1-2 -> 2.35.2-1)
[2020-05-30T17:47:55+0200] [ALPM] upgraded openssl (1.1.1.g-1 -> 1.1.1.g-2)
[2020-05-30T17:47:55+0200] [ALPM] upgraded krb5 (1.18-1 -> 1.18.1-1)
[2020-05-30T17:48:07+0200] [ALPM] upgraded python (3.8.2-2 -> 3.8.3-1)
[2020-05-30T17:48:07+0200] [ALPM] upgraded python-ply (3.11-4 -> 3.11-5)
[2020-05-30T17:48:08+0200] [ALPM] upgraded bind-tools (9.16.2-2 -> 9.16.3-1)
[2020-05-30T17:48:09+0200] [ALPM] upgraded sqlite (3.31.1-1 -> 3.32.1-1)
[2020-05-30T17:48:09+0200] [ALPM] upgraded zstd (1.4.4-1 -> 1.4.5-1)
[2020-05-30T17:48:09+0200] [ALPM] upgraded libarchive (3.4.2-1 -> 3.4.3-1)
[2020-05-30T17:48:09+0200] [ALPM] upgraded ca-certificates-mozilla (3.52-1 -> 3.52.1-2)
[2020-05-30T17:48:10+0200] [ALPM] upgraded libelf (0.178-2 -> 0.179-1)
[2020-05-30T17:48:10+0200] [ALPM] upgraded elfutils (0.178-2 -> 0.179-1)
[2020-05-30T17:48:13+0200] [ALPM] upgraded binutils (2.34-3 -> 2.34-5)
[2020-05-30T17:48:13+0200] [ALPM] upgraded blas (3.9.0-2 -> 3.9.0-3)
[2020-05-30T17:48:13+0200] [ALPM] upgraded c-client (2007f-10 -> 2007f-11)
[2020-05-30T17:48:13+0200] [ALPM] upgraded cblas (3.9.0-2 -> 3.9.0-3)
[2020-05-30T17:48:13+0200] [ALPM] upgraded cdparanoia (10.2-7 -> 10.2-8)
[2020-05-30T17:48:13+0200] [ALPM] upgraded rhash (1.3.9-1 -> 1.3.9-2)
[2020-05-30T17:48:14+0200] [ALPM] upgraded glib2 (2.64.2-1 -> 2.64.3-2)
[2020-05-30T17:48:21+0200] [ALPM] upgraded cmake (3.17.2-2 -> 3.17.3-1)
[2020-05-30T17:48:21+0200] [ALPM] upgraded cryptsetup (2.3.2-2 -> 2.3.3-1)
[2020-05-30T17:48:21+0200] [ALPM] upgraded dav1d (0.6.0-1 -> 0.7.0-1)
[2020-05-30T17:48:21+0200] [ALPM] upgraded dmidecode (3.2-1 -> 3.2-2)
[2020-05-30T17:48:21+0200] [ALPM] upgraded libnfnetlink (1.0.1-3 -> 1.0.1-4)
[2020-05-30T17:48:45+0200] [ALPM] upgraded docker (1:19.03.8-2 -> 1:19.03.10-1)
[2020-05-30T17:48:46+0200] [ALPM] upgraded pcre2 (10.34-3 -> 10.35-1)
[2020-05-30T17:48:49+0200] [ALPM] warning: directory permissions differ on /etc/webapps/dokuwiki/
filesystem: 755  package: 775
[2020-05-30T17:48:53+0200] [ALPM] upgraded dokuwiki (20180422_b-1 -> 20180422_c-1)
[2020-05-30T17:48:53+0200] [ALPM] upgraded java-runtime-common (3-2 -> 3-3)
[2020-05-30T17:48:54+0200] [ALPM] upgraded nss (3.52-1 -> 3.52.1-2)
[2020-05-30T17:49:02+0200] [ALPM] upgraded jre8-openjdk-headless (8.u242-1 -> 8.u252-1)
[2020-05-30T17:49:04+0200] [ALPM] upgraded util-linux (2.35.1-2 -> 2.35.2-1)
[2020-05-30T17:49:13+0200] [ALPM] upgraded elasticsearch (7.6.2-1 -> 7.7.0-2)
[2020-05-30T17:49:13+0200] [ALPM] upgraded exempi (2.5.1-1 -> 2.5.1-2)
[2020-05-30T17:49:13+0200] [ALPM] upgraded gnupg (2.2.20-1 -> 2.2.20-2)
[2020-05-30T17:49:14+0200] [ALPM] upgraded gpgme (1.13.1-5 -> 1.13.1-7)
[2020-05-30T17:49:14+0200] [ALPM] upgraded pacman (5.2.1-5 -> 5.2.1-6)
[2020-05-30T17:49:14+0200] [ALPM] upgraded expac (10-1 -> 10-2)
[2020-05-30T17:49:14+0200] [ALPM] upgraded f2fs-tools (1.13.0-1 -> 1.13.0-2)
[2020-05-30T17:49:14+0200] [ALPM] upgraded lame (3.100-2 -> 3.100-3)
[2020-05-30T17:49:14+0200] [ALPM] upgraded libpciaccess (0.16-1 -> 0.16-2)
[2020-05-30T17:49:14+0200] [ALPM] upgraded libdrm (2.4.101-1 -> 2.4.102-1)
[2020-05-30T17:49:14+0200] [ALPM] upgraded libraw1394 (2.1.2-2 -> 2.1.2-3)
[2020-05-30T17:49:14+0200] [ALPM] upgraded libiec61883 (1.2.0-5 -> 1.2.0-6)
[2020-05-30T17:49:14+0200] [ALPM] upgraded libmodplug (0.8.9.0-2 -> 0.8.9.0-3)
[2020-05-30T17:49:15+0200] [ALPM] upgraded libomxil-bellagio (0.9.3-2 -> 0.9.3-3)
[2020-05-30T17:49:15+0200] [ALPM] upgraded libtheora (1.1.1-4 -> 1.1.1-5)
[2020-05-30T17:49:15+0200] [ALPM] upgraded vid.stab (1.1-2 -> 1.1-3)
[2020-05-30T17:49:15+0200] [ALPM] upgraded libvorbis (1.3.6-1 -> 1.3.6-2)
[2020-05-30T17:49:15+0200] [ALPM] upgraded libvpx (1.8.2-1 -> 1.8.2-2)
[2020-05-30T17:49:16+0200] [ALPM] upgraded libxau (1.0.9-2 -> 1.0.9-3)
[2020-05-30T17:49:16+0200] [ALPM] upgraded libxdmcp (1.1.3-2 -> 1.1.3-3)
[2020-05-30T17:49:17+0200] [ALPM] upgraded libx11 (1.6.9-6 -> 1.6.9-7)
[2020-05-30T17:49:17+0200] [ALPM] upgraded libxext (1.3.4-2 -> 1.3.4-3)
[2020-05-30T17:49:17+0200] [ALPM] upgraded libxv (1.0.11-3 -> 1.0.11-4)
[2020-05-30T17:49:17+0200] [ALPM] upgraded xvidcore (1.3.7-1 -> 1.3.7-2)
[2020-05-30T17:49:17+0200] [ALPM] upgraded opencore-amr (0.1.5-3 -> 0.1.5-4)
[2020-05-30T17:49:17+0200] [ALPM] upgraded libpng (1.6.37-1 -> 1.6.37-2)
[2020-05-30T17:49:17+0200] [ALPM] upgraded libtiff (4.1.0-1 -> 4.1.0-2)
[2020-05-30T17:49:17+0200] [ALPM] upgraded lcms2 (2.9-2 -> 2.9-3)
[2020-05-30T17:49:17+0200] [ALPM] upgraded openjpeg2 (2.3.1-1 -> 2.3.1-2)
[2020-05-30T17:49:18+0200] [ALPM] upgraded opus (1.3.1-1 -> 1.3.1-2)
[2020-05-30T17:49:18+0200] [ALPM] upgraded speexdsp (1.2.0-1 -> 1.2.0-2)
[2020-05-30T17:49:18+0200] [ALPM] upgraded speex (1.2.0-2 -> 1.2.0-3)
[2020-05-30T17:49:18+0200] [ALPM] upgraded srt (1.4.1-1 -> 1.4.1-2)
[2020-05-30T17:49:18+0200] [ALPM] upgraded libasyncns (0.8+3+g68cd5af-2 -> 0.8+3+g68cd5af-3)
[2020-05-30T17:49:18+0200] [ALPM] upgraded libxfixes (5.0.3-3 -> 5.0.3-4)
[2020-05-30T17:49:18+0200] [ALPM] upgraded libxi (1.7.10-2 -> 1.7.10-3)
[2020-05-30T17:49:18+0200] [ALPM] upgraded libxtst (1.2.3-3 -> 1.2.3-4)
[2020-05-30T17:49:18+0200] [ALPM] upgraded libice (1.0.10-2 -> 1.0.10-3)
[2020-05-30T17:49:19+0200] [ALPM] upgraded libunwind (1.3.1-1 -> 1.3.1-2)
[2020-05-30T17:49:19+0200] [ALPM] upgraded libxdamage (1.1.5-2 -> 1.1.5-3)
[2020-05-30T17:49:19+0200] [ALPM] upgraded libxxf86vm (1.1.4-3 -> 1.1.4-4)
[2020-05-30T17:49:19+0200] [ALPM] upgraded lm_sensors (3.6.0-1 -> 3.6.0-2)
[2020-05-30T17:49:24+0200] [ALPM] upgraded mesa (20.0.7-2 -> 20.0.7-3)
[2020-05-30T17:49:24+0200] [ALPM] upgraded giflib (5.2.1-1 -> 5.2.1-2)
[2020-05-30T17:49:28+0200] [ALPM] upgraded libibus (1.5.22-1 -> 1.5.22+8+gf591381e-1)
[2020-05-30T17:49:28+0200] [ALPM] upgraded libxrender (0.9.10-3 -> 0.9.10-4)
[2020-05-30T17:49:28+0200] [ALPM] upgraded libxcursor (1.2.0-1 -> 1.2.0-2)
[2020-05-30T17:49:30+0200] [ALPM] upgraded ffmpeg (1:4.2.2-8 -> 1:4.2.3-2)
[2020-05-30T17:49:30+0200] [ALPM] upgraded libinstpatch (1.1.4-1 -> 1.1.5-1)
[2020-05-30T17:49:31+0200] [ALPM] upgraded fluidsynth (2.1.2-1 -> 2.1.3-1)
[2020-05-30T17:49:36+0200] [ALPM] upgraded foomatic-db (3:20200428-1 -> 3:20200529-1)
[2020-05-30T17:49:45+0200] [ALPM] upgraded foomatic-db-ppds (3:20200428-1 -> 3:20200529-1)
[2020-05-30T17:49:45+0200] [ALPM] upgraded fuse2 (2.9.9-3 -> 2.9.9-4)
[2020-05-30T17:49:46+0200] [ALPM] upgraded gc (8.0.4-3 -> 8.0.4-4)
[2020-05-30T17:49:57+0200] [ALPM] upgraded gcc (10.1.0-1 -> 10.1.0-2)
[2020-05-30T17:49:57+0200] [ALPM] upgraded geoip-database (20200507-2 -> 20200519-1)
[2020-05-30T17:49:57+0200] [ALPM] upgraded geoip (1.6.12-1 -> 1.6.12-2)
[2020-05-30T17:49:57+0200] [ALPM] upgraded glu (9.0.1-1 -> 9.0.1-2)
[2020-05-30T17:49:57+0200] [ALPM] upgraded gnu-netcat (0.7.1-7 -> 0.7.1-8)
[2020-05-30T17:49:57+0200] [ALPM] upgraded gperf (3.1-2 -> 3.1-3)
[2020-05-30T17:49:57+0200] [ALPM] upgraded graphene (1.10.0-1 -> 1.10.0-2)
[2020-05-30T17:49:57+0200] [ALPM] upgraded gsfonts (20180524-2 -> 20180524-3)
[2020-05-30T17:49:57+0200] [ALPM] upgraded haveged (1.9.8-1 -> 1.9.8-2)
[2020-05-30T17:49:57+0200] [ALPM] upgraded ijs (0.35-2 -> 0.35-3)
[2020-05-30T17:49:57+0200] [ALPM] upgraded liblqr (0.4.2-2 -> 0.4.2-3)
[2020-05-30T17:49:57+0200] [ALPM] upgraded libraqm (0.7.0-1 -> 0.7.0-2)
[2020-05-30T17:49:58+0200] [ALPM] upgraded imagemagick (7.0.10.13-1 -> 7.0.10.15-1)
[2020-05-30T17:49:58+0200] [ALPM] upgraded incron (0.5.12-3 -> 0.5.12-4)
[2020-05-30T17:49:58+0200] [ALPM] upgraded intel-ucode (20200508-1 -> 20200520-1)
[2020-05-30T17:50:01+0200] [ALPM] upgraded iso-codes (4.4-1 -> 4.4-2)
[2020-05-30T17:50:01+0200] [ALPM] upgraded jasper (2.0.16-1 -> 2.0.16-2)
[2020-05-30T17:50:01+0200] [ALPM] upgraded jemalloc (1:5.2.1-1 -> 1:5.2.1-2)
[2020-05-30T17:50:01+0200] [ALPM] upgraded lapack (3.9.0-2 -> 3.9.0-3)
[2020-05-30T17:50:01+0200] [ALPM] upgraded talloc (2.3.1-1 -> 2.3.1-2)
[2020-05-30T17:50:02+0200] [ALPM] upgraded ldb (1:2.1.2-1 -> 1:2.1.3-1)
[2020-05-30T17:50:03+0200] [ALPM] upgraded lib32-glibc (2.31-3 -> 2.31-5)
[2020-05-30T17:50:03+0200] [ALPM] upgraded libatomic_ops (7.6.10-1 -> 7.6.10-2)
[2020-05-30T17:50:04+0200] [ALPM] upgraded libbsd (0.10.0-1 -> 0.10.0-2)
[2020-05-30T17:50:04+0200] [ALPM] upgraded libcdio (2.1.0-1 -> 2.1.0-2)
[2020-05-30T17:50:04+0200] [ALPM] upgraded libcdio-paranoia (10.2+2.0.1-1 -> 10.2+2.0.1-2)
[2020-05-30T17:50:04+0200] [ALPM] upgraded libcroco (0.6.13-1 -> 0.6.13-2)
[2020-05-30T17:50:04+0200] [ALPM] upgraded libdaemon (0.14-4 -> 0.14-5)
[2020-05-30T17:50:04+0200] [ALPM] upgraded libdatrie (0.2.12-1 -> 0.2.12-2)
[2020-05-30T17:50:04+0200] [ALPM] upgraded libdc1394 (2.2.6-1 -> 2.2.6-2)
[2020-05-30T17:50:04+0200] [ALPM] upgraded libexif (0.6.21-3 -> 0.6.21-4)
[2020-05-30T17:50:04+0200] [ALPM] upgraded libfontenc (1.1.4-1 -> 1.1.4-2)
[2020-05-30T17:50:04+0200] [ALPM] upgraded libgme (0.6.2-1 -> 0.6.3-1)
[2020-05-30T17:50:05+0200] [ALPM] upgraded libxt (1.2.0-1 -> 1.2.0-2)
[2020-05-30T17:50:05+0200] [ALPM] upgraded libxpm (3.5.13-1 -> 3.5.13-2)
[2020-05-30T17:50:06+0200] [ALPM] upgraded libgphoto2 (2.5.24-1 -> 2.5.25-1)
[2020-05-30T17:50:06+0200] [ALPM] upgraded libgudev (233-1 -> 233-2)
[2020-05-30T17:50:07+0200] [ALPM] upgraded libidn (1.35-2 -> 1.35-3)
[2020-05-30T17:50:07+0200] [ALPM] upgraded libieee1284 (0.2.11-8 -> 0.2.11-9)
[2020-05-30T17:50:07+0200] [ALPM] upgraded libmad (0.15.1b-8 -> 0.15.1b-9)
[2020-05-30T17:50:07+0200] [ALPM] upgraded libmpcdec (1:0.1+r475-2 -> 1:0.1+r475-3)
[2020-05-30T17:50:07+0200] [ALPM] upgraded libmspack (1:0.10.1alpha-2 -> 1:0.10.1alpha-3)
[2020-05-30T17:50:07+0200] [ALPM] upgraded libthai (0.1.28-1 -> 0.1.28-2)
[2020-05-30T17:50:07+0200] [ALPM] upgraded libxft (2.3.3-1 -> 2.3.3-2)
[2020-05-30T17:50:08+0200] [ALPM] upgraded librsvg (2:2.48.4-1 -> 2:2.48.5-1)
[2020-05-30T17:50:08+0200] [ALPM] upgraded libshout (1:2.4.3-2 -> 1:2.4.3-3)
[2020-05-30T17:50:08+0200] [ALPM] upgraded libupnp (1.6.25-1 -> 1.6.25-2)
[2020-05-30T17:50:08+0200] [ALPM] upgraded libxcomposite (0.4.5-2 -> 0.4.5-3)
[2020-05-30T17:50:08+0200] [ALPM] upgraded libxinerama (1.1.4-2 -> 1.1.4-3)
[2020-05-30T17:50:08+0200] [ALPM] upgraded libxmu (1.1.3-1 -> 1.1.3-2)
[2020-05-30T17:50:08+0200] [ALPM] upgraded libxrandr (1.5.2-2 -> 1.5.2-3)
[2020-05-30T17:50:08+0200] [ALPM] upgraded libxslt (1.1.34-2 -> 1.1.34-3)
[2020-05-30T17:50:08+0200] [ALPM] upgraded libxvmc (1.0.12-2 -> 1.0.12-3)
[2020-05-30T17:50:20+0200] [ALPM] upgraded linux (5.6.13.arch1-1 -> 5.6.15.arch1-1)
[2020-05-30T17:50:47+0200] [ALPM] upgraded linux-firmware (20200421.78c0348-1 -> 20200519.8ba6fa6-1)
[2020-05-30T17:50:47+0200] [ALPM] upgraded lsof (4.93.2-1 -> 4.93.2-2)
[2020-05-30T17:50:47+0200] [ALPM] upgraded metalog (20181125-1 -> 20181125-2)
[2020-05-30T17:50:48+0200] [ALPM] upgraded mpg123 (1.25.13-1 -> 1.25.13-2)
[2020-05-30T17:50:48+0200] [ALPM] upgraded nano (4.9.2-1 -> 4.9.3-1)
[2020-05-30T17:50:49+0200] [ALPM] upgraded net-snmp (5.8-4 -> 5.8-5)
[2020-05-30T17:50:52+0200] [ALPM] upgraded nodejs (14.2.0-1 -> 14.3.0-1)
[2020-05-30T17:50:52+0200] [ALPM] upgraded ocl-icd (2.2.12-3 -> 2.2.12-4)
[2020-05-30T17:50:53+0200] [ALPM] upgraded openssh (8.2p1-3 -> 8.3p1-1)
[2020-05-30T17:50:53+0200] [ALPM] upgraded orc (0.4.31-1 -> 0.4.31-2)
[2020-05-30T17:50:53+0200] [ALPM] upgraded p7zip (16.02-5 -> 16.02-6)
[2020-05-30T17:50:53+0200] [ALPM] upgraded perl-convert-binhex (1.125-5 -> 1.125-6)
[2020-05-30T17:50:53+0200] [ALPM-SCRIPTLET] module test... pass.
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-crypt-openssl-bignum (0.09-3 -> 0.09-4)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-crypt-openssl-random (0.15-4 -> 0.15-5)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-crypt-openssl-rsa (0.31-3 -> 0.31-4)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-uri (1.76-2 -> 1.76-3)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-io-socket-ssl (2.066-1 -> 2.066-2)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-net-http (6.19-2 -> 6.19-3)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-try-tiny (0.30-3 -> 0.30-4)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-encode-locale (1.05-5 -> 1.05-6)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-timedate (2.32-1 -> 2.33-1)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-http-date (6.05-1 -> 6.05-2)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-file-listing (6.04-6 -> 6.04-7)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-html-tagset (3.20-8 -> 3.20-9)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-html-parser (3.72-8 -> 3.72-9)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-io-html (1.001-5 -> 1.001-6)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-lwp-mediatypes (6.02-6 -> 6.02-7)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-http-cookies (6.08-1 -> 6.08-2)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-http-negotiate (6.01-6 -> 6.01-7)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-www-robotrules (6.02-6 -> 6.02-7)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-lwp-protocol-https (6.07-3 -> 6.07-4)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-crypt-ssleay (0.73_04-11 -> 0.73_04-12)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-dbd-mysql (4.050-4 -> 4.050-5)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-digest-sha1 (2.13-13 -> 2.13-14)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-digest-hmac (1.03-7 -> 1.03-8)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-digest-nilsimsa (0.06-18 -> 0.06-19)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-fcgi (0.79-1 -> 0.79-2)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-file-basedir (0.08-3 -> 0.08-4)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-file-desktopentry (0.22-5 -> 0.22-6)
[2020-05-30T17:50:54+0200] [ALPM] upgraded perl-file-mimeinfo (0.29-2 -> 0.29-3)
[2020-05-30T17:50:56+0200] [ALPM] upgraded perl-image-exiftool (11.85-1 -> 11.85-2)
[2020-05-30T17:50:56+0200] [ALPM] upgraded perl-socket6 (0.29-3 -> 0.29-4)
[2020-05-30T17:50:56+0200] [ALPM] upgraded perl-io-socket-inet6 (2.72-5 -> 2.72-6)
[2020-05-30T17:50:56+0200] [ALPM] upgraded perl-json (2.97001-1 -> 2.97001-2)
[2020-05-30T17:50:56+0200] [ALPM] upgraded perl-mail-authenticationresults (1.20200108-1 -> 1.20200108-2)
[2020-05-30T17:50:56+0200] [ALPM] upgraded perl-mailtools (2.21-2 -> 2.21-3)
[2020-05-30T17:50:56+0200] [ALPM] upgraded perl-net-ip (1.26-6 -> 1.26-7)
[2020-05-30T17:50:56+0200] [ALPM] upgraded perl-net-dns (1.23-1 -> 1.24-1)
[2020-05-30T17:50:56+0200] [ALPM] upgraded perl-net-dns-resolver-mock (1.20200215-1 -> 1.20200215-2)
[2020-05-30T17:50:56+0200] [ALPM] upgraded perl-mail-dkim (0.58-1 -> 0.58-2)
[2020-05-30T17:50:57+0200] [ALPM] upgraded perl-netaddr-ip (4.079-8 -> 4.079-9)
[2020-05-30T17:50:57+0200] [ALPM] upgraded perl-mail-spf (2.9.0-5 -> 2.9.0-6)
[2020-05-30T17:50:57+0200] [ALPM] upgraded perl-net-server (2.009-4 -> 2.009-5)
[2020-05-30T17:50:57+0200] [ALPM] upgraded perl-parse-recdescent (1.967015-1 -> 1.967015-2)
[2020-05-30T17:50:57+0200] [ALPM] upgraded perl-term-readkey (2.38-3 -> 2.38-4)
[2020-05-30T17:50:57+0200] [ALPM] upgraded perl-tree-dag-node (1.31-1 -> 1.31-2)
[2020-05-30T17:50:57+0200] [ALPM] upgraded php-apcu (5.1.18-2 -> 5.1.18-3)
[2020-05-30T17:50:57+0200] [ALPM] upgraded pigz (2.4-1 -> 2.4-2)
[2020-05-30T17:50:57+0200] [ALPM] upgraded procps-ng (3.3.16-1 -> 3.3.16-2)
[2020-05-30T17:50:57+0200] [ALPM] upgraded python-six (1.14.0-1 -> 1.15.0-1)
[2020-05-30T17:50:57+0200] [ALPM] upgraded python-packaging (20.3-1 -> 20.4-1)
[2020-05-30T17:50:57+0200] [ALPM] upgraded python-ordered-set (3.1.1-1 -> 3.1.1-2)
[2020-05-30T17:50:57+0200] [ALPM] upgraded python-setuptools (1:46.4.0-1 -> 1:47.1.1-1)
[2020-05-30T17:50:58+0200] [ALPM] upgraded python-chardet (3.0.4-4 -> 3.0.4-5)
[2020-05-30T17:50:58+0200] [ALPM] upgraded python-defusedxml (0.6.0-3 -> 0.6.0-4)
[2020-05-30T17:50:58+0200] [ALPM] upgraded python-sgmllib (5.2.1-5 -> 5.2.1-6)
[2020-05-30T17:50:58+0200] [ALPM] upgraded python-feedparser (5.2.1-5 -> 5.2.1-6)
[2020-05-30T17:50:58+0200] [ALPM] upgraded python-importlib-metadata (1.5.2-1 -> 1.6.0-1)
[2020-05-30T17:50:58+0200] [ALPM] upgraded python-lxml (4.5.0-1 -> 4.5.1-1)
[2020-05-30T17:50:58+0200] [ALPM] upgraded python-markupsafe (1.1.1-3 -> 1.1.1-4)
[2020-05-30T17:50:58+0200] [ALPM] upgraded python-more-itertools (8.2.0-1 -> 8.3.0-1)
[2020-05-30T17:50:59+0200] [ALPM] upgraded python-pbr (5.4.4-2 -> 5.4.5-1)
[2020-05-30T17:50:59+0200] [ALPM] upgraded python-pyopenssl (19.1.0-1 -> 19.1.0-2)
[2020-05-30T17:50:59+0200] [ALPM] upgraded python-sh (1.12.14-5 -> 1.13.1-1)
[2020-05-30T17:50:59+0200] [ALPM] upgraded python2-backports (1.0-2 -> 1.0-3)
[2020-05-30T17:50:59+0200] [ALPM] upgraded python2-configparser (4.0.2-1 -> 4.0.2-2)
[2020-05-30T17:50:59+0200] [ALPM] upgraded python2-six (1.14.0-1 -> 1.15.0-1)
[2020-05-30T17:50:59+0200] [ALPM] upgraded python2-importlib-metadata (1.5.2-1 -> 1.6.0-1)
[2020-05-30T17:50:59+0200] [ALPM] upgraded python2-ordered-set (3.1.1-1 -> 3.1.1-2)
[2020-05-30T17:50:59+0200] [ALPM] upgraded python2-packaging (20.3-1 -> 20.4-1)
[2020-05-30T17:50:59+0200] [ALPM] upgraded razor (2.85-13 -> 2.85-14)
[2020-05-30T17:50:59+0200] [ALPM] upgraded re2c (1.3-1 -> 1.3-2)
[2020-05-30T17:50:59+0200] [ALPM] warning: /etc/redis.conf installed as /etc/redis.conf.pacnew
[2020-05-30T17:50:59+0200] [ALPM] upgraded redis (6.0.3-1 -> 6.0.4-1)
[2020-05-30T17:50:59+0200] [ALPM] upgraded rpmextract (1.0-8 -> 1.0-9)
[2020-05-30T17:51:00+0200] [ALPM] upgraded rubygems (3.1.2-4 -> 3.1.2-5)
[2020-05-30T17:51:02+0200] [ALPM] upgraded smbclient (4.12.2-3 -> 4.12.3-1)
[2020-05-30T17:51:07+0200] [ALPM] warning: directory permissions differ on /var/lib/samba/private/
filesystem: 755  package: 700
[2020-05-30T17:51:07+0200] [ALPM] upgraded samba (4.12.2-3 -> 4.12.3-1)
[2020-05-30T17:51:09+0200] [ALPM] upgraded sane (1.0.29-1 -> 1.0.30-1)
[2020-05-30T17:51:09+0200] [ALPM] upgraded schroedinger (1.0.11-5 -> 1.0.11-6)
[2020-05-30T17:51:10+0200] [ALPM] upgraded spamassassin (3.4.4-1 -> 3.4.4-2)
[2020-05-30T17:51:10+0200] [ALPM-SCRIPTLET] Detected compiled rules, running sa-compile...
[2020-05-30T17:51:55+0200] [ALPM] upgraded sudo (1.8.31.p1-1 -> 1.9.0-1)
[2020-05-30T17:51:55+0200] [ALPM] upgraded tinycdb (0.78-3 -> 0.78-4)
[2020-05-30T17:51:56+0200] [ALPM] upgraded vim-runtime (8.2.0717-2 -> 8.2.0814-2)
[2020-05-30T17:51:56+0200] [ALPM] upgraded vim (8.2.0717-2 -> 8.2.0814-2)
[2020-05-30T17:51:56+0200] [ALPM] upgraded wavpack (5.2.0-1 -> 5.3.0-1)
[2020-05-30T17:51:56+0200] [ALPM] upgraded wildmidi (0.4.3-1 -> 0.4.3-2)
[2020-05-30T17:51:56+0200] [ALPM] upgraded xorg-fonts-encodings (1.0.5-1 -> 1.0.5-2)
[2020-05-30T17:51:56+0200] [ALPM] upgraded yajl (2.1.0-2 -> 2.1.0-3)
[2020-05-30T17:51:57+0200] [ALPM] transaction completed
[2020-05-30T17:51:59+0200] [ALPM] running '20-systemd-sysusers.hook'...
[2020-05-30T17:52:00+0200] [ALPM] running '30-systemd-daemon-reload.hook'...
[2020-05-30T17:52:00+0200] [ALPM] running '30-systemd-hwdb.hook'...
[2020-05-30T17:52:01+0200] [ALPM] running '30-systemd-sysctl.hook'...
[2020-05-30T17:52:01+0200] [ALPM] running '30-systemd-tmpfiles.hook'...
[2020-05-30T17:52:02+0200] [ALPM] running '30-systemd-udev-reload.hook'...
[2020-05-30T17:52:02+0200] [ALPM] running '30-systemd-update.hook'...
[2020-05-30T17:52:02+0200] [ALPM] running '60-depmod.hook'...
[2020-05-30T17:52:16+0200] [ALPM] running '80-atd.hook'...
[2020-05-30T17:52:16+0200] [ALPM] running '90-mkinitcpio-install.hook'...
[2020-05-30T17:52:16+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2020-05-30T17:52:16+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2020-05-30T17:52:16+0200] [ALPM-SCRIPTLET] ==> Starting build: 5.6.15-arch1-1
[2020-05-30T17:52:16+0200] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2020-05-30T17:52:17+0200] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2020-05-30T17:52:18+0200] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2020-05-30T17:52:18+0200] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2020-05-30T17:52:18+0200] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2020-05-30T17:52:20+0200] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2020-05-30T17:52:20+0200] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2020-05-30T17:52:21+0200] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2020-05-30T17:52:21+0200] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2020-05-30T17:52:21+0200] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
[2020-05-30T17:52:24+0200] [ALPM-SCRIPTLET] ==> Image generation successful
[2020-05-30T17:52:24+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2020-05-30T17:52:24+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2020-05-30T17:52:24+0200] [ALPM-SCRIPTLET] ==> Starting build: 5.6.15-arch1-1
[2020-05-30T17:52:24+0200] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2020-05-30T17:52:25+0200] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2020-05-30T17:52:26+0200] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2020-05-30T17:52:26+0200] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2020-05-30T17:52:28+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2020-05-30T17:52:31+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2020-05-30T17:52:37+0200] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2020-05-30T17:52:40+0200] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2020-05-30T17:52:44+0200] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2020-05-30T17:52:47+0200] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2020-05-30T17:52:48+0200] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
[2020-05-30T17:52:59+0200] [ALPM-SCRIPTLET] ==> Image generation successful
[2020-05-30T17:52:59+0200] [ALPM] running 'detect-old-perl-modules.hook'...
[2020-05-30T17:52:59+0200] [ALPM] running 'fontconfig.hook'...
[2020-05-30T17:53:00+0200] [ALPM] running 'gdk-pixbuf-query-loaders.hook'...
[2020-05-30T17:53:00+0200] [ALPM] running 'gtk-update-icon-cache.hook'...
[2020-05-30T17:53:00+0200] [ALPM] running 'texinfo-install.hook'...
[2020-05-30T17:53:05+0200] [ALPM] running 'update-ca-trust.hook'...
[2020-05-30T17:53:08+0200] [ALPM] running 'update-desktop-database.hook'...
[2020-05-30T17:53:08+0200] [ALPM] running 'update-mime-database.hook'...
[2020-05-30T17:53:10+0200] [ALPM] running 'xorg-mkfontscale.hook'...
[2020-05-30T18:31:38+0200] [PACMAN] Running 'pacman -U --noconfirm --config /etc/pacman.conf -- /home/jan/.cache/yay/python-ruffus/python-ruffus-2.8.4-1-any.pkg.tar.xz'
[2020-05-30T18:31:38+0200] [ALPM] transaction started
[2020-05-30T18:31:39+0200] [ALPM] upgraded python-ruffus (2.8.3-1 -> 2.8.4-1)
[2020-05-30T18:31:39+0200] [ALPM] transaction completed
[2020-05-30T18:31:39+0200] [ALPM] running '30-systemd-update.hook'...
[2020-06-01T16:05:25+0200] [PACMAN] Running 'pacman -Syu'
[2020-06-01T16:05:25+0200] [PACMAN] synchronizing package lists
[2020-06-01T16:05:26+0200] [PACMAN] starting full system upgrade
[2020-06-01T16:05:50+0200] [ALPM] transaction started
[2020-06-01T16:05:50+0200] [ALPM] upgraded libgpg-error (1.37-1 -> 1.38-1)
[2020-06-01T16:05:50+0200] [ALPM] upgraded ca-certificates-mozilla (3.52.1-2 -> 3.53-1)
[2020-06-01T16:05:51+0200] [ALPM] upgraded imagemagick (7.0.10.15-1 -> 7.0.10.16-2)
[2020-06-01T16:05:51+0200] [ALPM] upgraded libzen (0.4.37-2 -> 0.4.38-2)
[2020-06-01T16:05:51+0200] [ALPM] upgraded libmediainfo (19.09-1 -> 20.03-1)
[2020-06-01T16:05:51+0200] [ALPM] upgraded mediainfo (19.09-1 -> 20.03-1)
[2020-06-01T16:05:51+0200] [ALPM] upgraded nss (3.52.1-2 -> 3.53-1)
[2020-06-01T16:05:51+0200] [ALPM] upgraded python-cffi (1.14.0-2 -> 1.14.0-3)
[2020-06-01T16:05:53+0200] [ALPM] upgraded python-django (3.0.6-1 -> 3.0.6-2)
[2020-06-01T16:05:54+0200] [ALPM] upgraded python-parsedatetime (2.5-1 -> 2.6-1)
[2020-06-01T16:05:54+0200] [ALPM] upgraded python2-zipp (1:1.1.0-1 -> 1:1.1.1-1)
[2020-06-01T16:05:54+0200] [ALPM] upgraded ripgrep (12.1.0-1 -> 12.1.1-1)
[2020-06-01T16:05:54+0200] [ALPM] upgraded vulkan-icd-loader (1.2.140-1 -> 1.2.141-1)
[2020-06-01T16:05:54+0200] [ALPM] transaction completed
[2020-06-01T16:05:54+0200] [ALPM] running '30-systemd-update.hook'...
[2020-06-01T16:05:54+0200] [ALPM] running 'detect-old-perl-modules.hook'...
[2020-06-01T16:05:55+0200] [ALPM] running 'texinfo-install.hook'...
[2020-06-01T16:05:55+0200] [ALPM] running 'update-ca-trust.hook'...
[2020-06-01T16:08:11+0200] [PACMAN] Running 'pacman -Syu'
[2020-06-01T16:08:11+0200] [PACMAN] synchronizing package lists
[2020-06-01T16:08:11+0200] [PACMAN] starting full system upgrade
[2020-06-01T17:27:28+0200] [PACMAN] Running 'pacman -Rsn dhcpcd'
[2020-06-01T17:27:30+0200] [ALPM] transaction started
[2020-06-01T17:27:31+0200] [ALPM] removed dhcpcd (9.0.2-1)
[2020-06-01T17:27:31+0200] [ALPM] transaction completed
[2020-06-01T17:27:31+0200] [ALPM] running '30-systemd-daemon-reload.hook'...
[2020-06-01T17:27:32+0200] [ALPM] running '30-systemd-update.hook'...
[2020-06-01T17:56:59+0200] [PACMAN] Running 'pacman -U --noconfirm --config /etc/pacman.conf -- /home/jan/.cache/yay/piwigo/piwigo-2.10.2-1-any.pkg.tar.xz'
[2020-06-01T18:06:26+0200] [PACMAN] Running 'pacman -U --noconfirm --config /etc/pacman.conf -- /home/jan/.cache/yay/plex-media-server/plex-media-server-1.19.3.2852-1-x86_64.pkg.tar.xz'
[2020-06-01T18:06:26+0200] [ALPM] transaction started
[2020-06-01T18:06:40+0200] [ALPM] upgraded plex-media-server (1.19.3.2764-1 -> 1.19.3.2852-1)
[2020-06-01T18:06:40+0200] [ALPM] transaction completed
[2020-06-01T18:06:40+0200] [ALPM] running '20-systemd-sysusers.hook'...
[2020-06-01T18:06:40+0200] [ALPM] running '30-systemd-daemon-reload.hook'...
[2020-06-01T18:06:41+0200] [ALPM] running '30-systemd-tmpfiles.hook'...
[2020-06-01T18:06:41+0200] [ALPM] running '30-systemd-update.hook'...
[2020-06-01T18:07:04+0200] [PACMAN] Running 'pacman -U --noconfirm --config /etc/pacman.conf -- /home/jan/.cache/yay/python-django-cors-headers/python-django-cors-headers-3.3.0-1-any.pkg.tar.xz'
[2020-06-01T18:07:05+0200] [ALPM] transaction started
[2020-06-01T18:07:05+0200] [ALPM] upgraded python-django-cors-headers (3.2.1-1 -> 3.3.0-1)
[2020-06-01T18:07:05+0200] [ALPM] transaction completed
[2020-06-01T18:07:05+0200] [ALPM] running '30-systemd-update.hook'...
[2020-06-02T19:55:12+0200] [PACMAN] Running 'pacman -Syu'
[2020-06-02T19:55:12+0200] [PACMAN] synchronizing package lists
[2020-06-02T19:55:13+0200] [PACMAN] starting full system upgrade
[2020-06-02T20:01:18+0200] [PACMAN] Running 'pacman -Rns postfix'
[2020-06-02T20:01:24+0200] [ALPM] transaction started
[2020-06-02T20:01:24+0200] [ALPM] removed postfix (3.5.2-1)
[2020-06-02T20:01:24+0200] [ALPM] removed tinycdb (0.78-4)
[2020-06-02T20:01:24+0200] [ALPM] transaction completed
[2020-06-02T20:01:25+0200] [ALPM] running '30-systemd-daemon-reload.hook'...
[2020-06-02T20:01:25+0200] [ALPM] running '30-systemd-update.hook'...
[2020-06-02T20:01:34+0200] [PACMAN] Running 'pacman -Rns postfixadmin s-nail'
[2020-06-02T20:01:35+0200] [ALPM] transaction started
[2020-06-02T20:01:35+0200] [ALPM] removed s-nail (14.9.19-1)
[2020-06-02T20:01:35+0200] [ALPM] removed postfixadmin (3.2.4-1)
[2020-06-02T20:01:35+0200] [ALPM] transaction completed
[2020-06-02T20:01:36+0200] [ALPM] running '30-systemd-update.hook'...
[2020-06-02T20:02:00+0200] [PACMAN] Running 'pacman -Rns razor'
[2020-06-02T20:02:01+0200] [ALPM] transaction started
[2020-06-02T20:02:02+0200] [ALPM] removed razor (2.85-14)
[2020-06-02T20:02:02+0200] [ALPM] removed perl-digest-nilsimsa (0.06-19)
[2020-06-02T20:02:02+0200] [ALPM] transaction completed
[2020-06-02T20:02:02+0200] [ALPM] running '30-systemd-update.hook'...
[2020-06-02T20:02:08+0200] [PACMAN] Running 'pacman -Rns pyzor'
[2020-06-02T20:02:08+0200] [ALPM] transaction started
[2020-06-02T20:02:09+0200] [ALPM] removed pyzor (1.0.0-1)
[2020-06-02T20:02:09+0200] [ALPM] transaction completed
[2020-06-02T20:02:09+0200] [ALPM] running '30-systemd-update.hook'...
[2020-06-02T20:02:18+0200] [PACMAN] Running 'pacman -Rns spamassassin'
[2020-06-02T20:02:21+0200] [ALPM] transaction started
[2020-06-02T20:02:22+0200] [ALPM] removed spamassassin (3.4.4-2)
[2020-06-02T20:02:22+0200] [ALPM] removed re2c (1.3-2)
[2020-06-02T20:02:22+0200] [ALPM] removed perl-mail-spf (2.9.0-6)
[2020-06-02T20:02:22+0200] [ALPM] removed perl-netaddr-ip (4.079-9)
[2020-06-02T20:02:22+0200] [ALPM] removed perl-crypt-ssleay (0.73_04-12)
[2020-06-02T20:02:22+0200] [ALPM] removed perl-path-class (0.37-5)
[2020-06-02T20:02:22+0200] [ALPM] transaction completed
[2020-06-02T20:02:22+0200] [ALPM] running '30-systemd-daemon-reload.hook'...
[2020-06-02T20:02:23+0200] [ALPM] running '30-systemd-update.hook'...
[2020-06-03T17:06:13+0200] [PACMAN] Running 'pacman -Syu'
[2020-06-03T17:06:13+0200] [PACMAN] synchronizing package lists
[2020-06-03T17:06:14+0200] [PACMAN] starting full system upgrade
[2020-06-03T17:07:34+0200] [ALPM] transaction started
[2020-06-03T17:07:34+0200] [ALPM] upgraded python-acme (1.4.0-1 -> 1.5.0-1)
[2020-06-03T17:07:34+0200] [ALPM] upgraded systemd-libs (245.5-2 -> 245.6-1)
[2020-06-03T17:07:34+0200] [ALPM] upgraded certbot (1.4.0-1 -> 1.5.0-1)
[2020-06-03T17:07:34+0200] [ALPM] upgraded certbot-nginx (1.4.0-1 -> 1.5.0-1)
[2020-06-03T17:07:34+0200] [ALPM] upgraded device-mapper (2.02.187-2 -> 2.02.187-3)
[2020-06-03T17:07:36+0200] [ALPM] upgraded docker (1:19.03.10-1 -> 1:19.03.11-1)
[2020-06-03T17:07:37+0200] [ALPM] upgraded git (2.26.2-1 -> 2.27.0-1)
[2020-06-03T17:07:50+0200] [ALPM] upgraded go (2:1.14.3-1 -> 2:1.14.4-1)
[2020-06-03T17:07:50+0200] [ALPM] upgraded harfbuzz (2.6.6-1 -> 2.6.7-1)
[2020-06-03T17:07:50+0200] [ALPM] upgraded lcms2 (2.9-3 -> 2.10-1)
[2020-06-03T17:07:50+0200] [ALPM] upgraded libheif (1.6.2-2 -> 1.7.0-1)
[2020-06-03T17:07:50+0200] [ALPM] upgraded librsvg (2:2.48.5-1 -> 2:2.48.6-1)
[2020-06-03T17:07:51+0200] [ALPM] upgraded lvm2 (2.02.187-2 -> 2.02.187-3)
[2020-06-03T17:07:52+0200] [ALPM] upgraded percona-toolkit (3.2.0-1 -> 3.2.0-2)
[2020-06-03T17:07:52+0200] [ALPM] upgraded portaudio (1:19.6.0-6 -> 1:19.6.0-7)
[2020-06-03T17:07:52+0200] [ALPM] upgraded python-docker (4.2.0-1 -> 4.2.1-1)
[2020-06-03T17:07:53+0200] [ALPM] upgraded python-pytest (5.4.2-1 -> 5.4.3-1)
[2020-06-03T17:07:53+0200] [ALPM] upgraded rubygems (3.1.2-5 -> 3.1.3-1)
[2020-06-03T17:07:53+0200] [ALPM] upgraded strace (5.6-1 -> 5.7-1)
[2020-06-03T17:07:55+0200] [ALPM] upgraded systemd (245.5-2 -> 245.6-1)
[2020-06-03T17:07:56+0200] [ALPM] upgraded systemd-sysvcompat (245.5-2 -> 245.6-1)
[2020-06-03T17:07:57+0200] [ALPM] transaction completed
[2020-06-03T17:07:57+0200] [ALPM] running '20-systemd-sysusers.hook'...
[2020-06-03T17:07:57+0200] [ALPM] running '30-systemd-catalog.hook'...
[2020-06-03T17:07:57+0200] [ALPM] running '30-systemd-daemon-reload.hook'...
[2020-06-03T17:07:58+0200] [ALPM] running '30-systemd-hwdb.hook'...
[2020-06-03T17:07:59+0200] [ALPM] running '30-systemd-sysctl.hook'...
[2020-06-03T17:07:59+0200] [ALPM] running '30-systemd-tmpfiles.hook'...
[2020-06-03T17:07:59+0200] [ALPM] running '30-systemd-udev-reload.hook'...
[2020-06-03T17:07:59+0200] [ALPM] running '30-systemd-update.hook'...
[2020-06-03T17:07:59+0200] [ALPM] running '90-mkinitcpio-install.hook'...
[2020-06-03T17:07:59+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2020-06-03T17:07:59+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2020-06-03T17:08:00+0200] [ALPM-SCRIPTLET] ==> Starting build: 5.6.15-arch1-1
[2020-06-03T17:08:00+0200] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2020-06-03T17:08:01+0200] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2020-06-03T17:08:02+0200] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2020-06-03T17:08:02+0200] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2020-06-03T17:08:02+0200] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2020-06-03T17:08:05+0200] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2020-06-03T17:08:05+0200] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2020-06-03T17:08:06+0200] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2020-06-03T17:08:06+0200] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2020-06-03T17:08:06+0200] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
[2020-06-03T17:08:09+0200] [ALPM-SCRIPTLET] ==> Image generation successful
[2020-06-03T17:08:09+0200] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2020-06-03T17:08:09+0200] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2020-06-03T17:08:09+0200] [ALPM-SCRIPTLET] ==> Starting build: 5.6.15-arch1-1
[2020-06-03T17:08:09+0200] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2020-06-03T17:08:11+0200] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2020-06-03T17:08:11+0200] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2020-06-03T17:08:11+0200] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2020-06-03T17:08:14+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2020-06-03T17:08:18+0200] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2020-06-03T17:08:25+0200] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2020-06-03T17:08:29+0200] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2020-06-03T17:08:34+0200] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2020-06-03T17:08:38+0200] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2020-06-03T17:08:38+0200] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
[2020-06-03T17:08:50+0200] [ALPM-SCRIPTLET] ==> Image generation successful
[2020-06-03T17:08:50+0200] [ALPM] running 'dbus-reload.hook'...
[2020-06-03T17:08:50+0200] [ALPM] running 'gdk-pixbuf-query-loaders.hook'...
[2020-06-03T17:08:50+0200] [ALPM] running 'update-mime-database.hook'...
[2020-06-03T17:09:29+0200] [PACMAN] Running 'pacman -Rns go'
[2020-06-03T17:09:38+0200] [ALPM] transaction started
[2020-06-03T17:09:41+0200] [ALPM] removed go (2:1.14.4-1)
[2020-06-03T17:09:41+0200] [ALPM] transaction completed
[2020-06-03T17:09:41+0200] [ALPM] running '30-systemd-update.hook'...

T4cC0re, thanks alot, I am not aware of any Realtek driver changes; but I might do so if nothing else helps.

d_fajardo, thanks alot, I will try that; or take the SSD out and into an identical system to test.

Offline

#6 2020-06-03 15:56:02

loqs
Member
Registered: 2014-03-06
Posts: 11,825

Re: [SOLVED]: Kernel Panic, maybe since last update

5.6.14 included https://git.kernel.org/pub/scm/linux/ke … 2f5aad9f67
If you downgrade the kernel back to 5.6.13 does the issue stop occurring?

Offline

#7 2020-06-03 18:07:06

stueja
Member
Registered: 2015-10-18
Posts: 44

Re: [SOLVED]: Kernel Panic, maybe since last update

loqs wrote:

5.6.14 included https://git.kernel.org/pub/scm/linux/ke … 2f5aad9f67
If you downgrade the kernel back to 5.6.13 does the issue stop occurring?

Uh, good find, thank you very much.
Downgraded the kernel -- will report back smile

Edit:
Until now, it looks good.
If it stays like that, what is the correct procedure to make my kernel panics known to the people who made the change?

Last edited by stueja (2020-06-03 21:22:28)

Offline

#8 2020-06-04 19:28:28

stueja
Member
Registered: 2015-10-18
Posts: 44

Re: [SOLVED]: Kernel Panic, maybe since last update

More than 24h without kernel panic, I think that was it.
But -- how and when can I update my kernel again?

Offline

#9 2020-06-04 20:15:08

loqs
Member
Registered: 2014-03-06
Posts: 11,825

Re: [SOLVED]: Kernel Panic, maybe since last update

Try building 5.6.15 with 17f291f373d9c78a04e3dc43f3dce92f5aad9f67 reverted
Arch_Build_System#Retrieve_PKGBUILD_source_using_Git

asp export core/linux
cd linux

Edit the prepare function in the PKGBUILD adding the git revert so it becomes

prepare() {
  cd $_srcname

  echo "Setting version..."
  scripts/setlocalversion --save-scmversion
  echo "-$pkgrel" > localversion.10-pkgrel
  echo "${pkgbase#linux}" > localversion.20-pkgname

  git revert -n 17f291f373d9c78a04e3dc43f3dce92f5aad9f67

  local src
  for src in "${source[@]}"; do
    src="${src%%::*}"
    src="${src##*/}"
    [[ $src = *.patch ]] || continue
    echo "Applying patch $src..."
    patch -Np1 < "../$src"
  done

  echo "Setting config..."
  cp ../config .config
  make olddefconfig

  make -s kernelrelease > version
  echo "Prepared $pkgbase version $(<version)"
}

Build and test the package to see if that change was the cause.

Offline

#10 2020-06-04 21:09:04

stueja
Member
Registered: 2015-10-18
Posts: 44

Re: [SOLVED]: Kernel Panic, maybe since last update

OK... but I assume that this can take a couple days on that Intel(R) Celeron(R) CPU  N3150  @ 1.60GHz... wink will report back.

Offline

#11 2020-06-04 23:42:42

zafayar
Member
Registered: 2020-06-04
Posts: 3

Re: [SOLVED]: Kernel Panic, maybe since last update

I have the exact same panics.  About once every 12 hours or so. However, my hardware and conditions are completely different.

Mine is Ryzen 2 CPU, mainly used as Docker Host and ZFS NAS.  I have two network cards, both Intel but one using e1000 driver and other one igb (Intel  I210/I211).  Only one is active at a time, and I get the same crash on both drivers.  I get e100_pool or igb_pool in the crash line.  The original poster also has the same line but with realtek driver.

This is what I have done:
1.  Mem Test.  Ran the full Memtest no issues
2.  Installed LTS Kernel.  I did not see any change in behavior.  I am retesting this now.
3.  Changed docker config to use proxy application.  My reasoning was that the __cgroup_bpf_run_filter_skb call might be related to docker using cgroup based routing.  This was just a wild guess, but I did change that config just before I started getting the crash.

I have screenshot of the crash if anyone is interested in looking at them.

Offline

#12 2020-06-04 23:50:30

loqs
Member
Registered: 2014-03-06
Posts: 11,825

Re: [SOLVED]: Kernel Panic, maybe since last update

Offline

#13 2020-06-04 23:59:35

zafayar
Member
Registered: 2020-06-04
Posts: 3

Re: [SOLVED]: Kernel Panic, maybe since last update

loqs wrote:

That does look like the bug.  I will try and follow the bug.

Thanks a lot of quick reply.

Offline

#14 2020-06-05 00:05:30

loqs
Member
Registered: 2014-03-06
Posts: 11,825

Re: [SOLVED]: Kernel Panic, maybe since last update

You could try bisectiing between 5.6.13 and 5.6.14 or test 5.7,  another test would be booting 5.6.15 with the systemd.unified_cgroup_hierarchy which would switch all cgroup use to v2.
https://cdn.kernel.org/pub/linux/kernel … Log-5.6.14

Offline

#15 2020-06-05 01:06:31

zafayar
Member
Registered: 2020-06-04
Posts: 3

Re: [SOLVED]: Kernel Panic, maybe since last update

loqs wrote:

You could try bisectiing between 5.6.13 and 5.6.14 or test 5.7,  another test would be booting 5.6.15 with the systemd.unified_cgroup_hierarchy which would switch all cgroup use to v2.
https://cdn.kernel.org/pub/linux/kernel … Log-5.6.14

Using systemd.unified_cgroup_hierarchy broke Docker. sad

I will try your other solution.

Offline

#16 2020-06-05 02:17:53

loqs
Member
Registered: 2014-03-06
Posts: 11,825

Re: [SOLVED]: Kernel Panic, maybe since last update

Looks to be this upstream issue https://www.spinics.net/lists/netdev/msg658503.html
Edit:
https://git.kernel.org/pub/scm/linux/ke … 74717f2a2c ?

Last edited by loqs (2020-06-05 02:33:14)

Offline

#17 2020-06-05 21:31:28

stueja
Member
Registered: 2015-10-18
Posts: 44

Re: [SOLVED]: Kernel Panic, maybe since last update

loqs wrote:

Try building 5.6.15 with 17f291f373d9c78a04e3dc43f3dce92f5aad9f67 reverted
...
Build and test the package to see if that change was the cause.

Did that, installed the kernel with pacman -U, and had a kernel panic within 2 hours again sad

Offline

#18 2020-06-05 21:45:04

loqs
Member
Registered: 2014-03-06
Posts: 11,825

Re: [SOLVED]: Kernel Panic, maybe since last update

cd src/archlinux-linux
git revert -n e2d928d5ee43f372618a9f98b0c73674717f2a2c
cd ../..
makepkg -efi
# pacman -U ....

Revert another commit (this one cgroup related),  rebuild using the existing source tree and overwrite the already produced package.  This build should be much quicker.

Offline

#19 2020-06-07 09:20:46

stueja
Member
Registered: 2015-10-18
Posts: 44

Re: [SOLVED]: Kernel Panic, maybe since last update

Did that, and 24hours later it still looks good without kernel panic. So thank you very much for your guidance!
A question remains — will the next pacman -Syu install a newer kernel with the same behaviour? How can I avoid that? Or will the changes we reverted also be reverted upstream?

Offline

#20 2020-06-07 12:46:17

loqs
Member
Registered: 2014-03-06
Posts: 11,825

Re: [SOLVED]: Kernel Panic, maybe since last update

Pacman#Skip_package_from_being_upgraded.  You need to add the kernel package(s) to the IgnorePkg entry.
No new postings on the upstream mailing list I linked in post 16.  You could report your findings there and on https://bugs.archlinux.org/task/66824
Edit:
Referenced this thread on https://bugs.archlinux.org/task/66824#comment190094

Last edited by loqs (2020-06-07 14:40:09)

Offline

#21 2020-06-07 18:28:14

stueja
Member
Registered: 2015-10-18
Posts: 44

Re: [SOLVED]: Kernel Panic, maybe since last update

loqs, thank you very much. I will check back the bug tracker frequently to see when I can take linux off the IgnorePkg list again.

Offline

#22 2020-06-08 19:15:52

zoe1337
Member
Registered: 2020-06-08
Posts: 2

Re: [SOLVED]: Kernel Panic, maybe since last update

I ran into the same issue. Looks like a kernel bug. There is a bugzilla open at https://bugzilla.kernel.org/show_bug.cgi?id=208003

As recommended in the linked thread, I tried a workaround:

cd /usr/lib/systemd/system
sed -i.bak 's/^IPAddressDeny/#IPAddressDeny/g' *.service

will report back if this did not work.

Offline

#23 2020-06-08 19:26:57

loqs
Member
Registered: 2014-03-06
Posts: 11,825

Re: [SOLVED]: Kernel Panic, maybe since last update

Even if the workaround is successful,  I would suggest testing the revert and if that works you could report it upstream.

Offline

#24 2020-06-12 14:12:30

zoe1337
Member
Registered: 2020-06-08
Posts: 2

Re: [SOLVED]: Kernel Panic, maybe since last update

zoe1337 wrote:

will report back if this did not work.

today it crashed on me, exactly while updating the kernel, which left me in an unbootable state... hmm 
archiso saved the day.

Offline

#25 2020-07-22 08:26:30

kubax
Member
Registered: 2014-10-22
Posts: 15

Re: [SOLVED]: Kernel Panic, maybe since last update

Today i learned that my crashes are not related to a failing CPU oder Motherboard, but seem to be related to the Kernel and Docker combination.. (unless yesterday i did not get a Kernel Dump)

For now i installed 5.6.13, but it seems like 5.7.10 is out since this morning, and containing the patch to fix this issue.

https://cdn.kernel.org/pub/linux/kernel … Log-5.7.10  ->  26d0bcfcf7150bc7c115f2d3f2f1459e64029b98

Offline

Board footer

Powered by FluxBB