You are not logged in.

#1 2020-06-18 06:03:55

regularuser123
Member
Registered: 2020-06-18
Posts: 6

anki is not properly displaying the GUI in latest releases

The problem

The "anki" program is displaying windows with messed up buttons (see image below)
The following screenshot shows the complete window that is shown the first time the "anki" program is opened (this screenshot was taken in the "2.1.15" version)
https://i.ibb.co/jM1jLRq/2020-06-18-00-49-39.png
The following screenshot shows the complete window that is shown the first time the "anki" program is opened (this screenshot was taken in the "2.1.26" version, the latest release)
https://i.ibb.co/92yQDYR/2020-06-18-00-50-07.png
The following gif shows how other windows of the "anki" program behaves
https://i.stack.imgur.com/Ikqmh.gif

What I've tried
  1. Download and install the latest beta
    I downloaded the latest beta (i.e. "anki-2.1.28alpha3-816cec4a-linux-amd64.tar.bz2") from this website.
    This page is referenced by the documentation on beta releases.

  2. Download and install previous releases
    I downloaded the following releases from the official remote repository and install them in order to check whether this issue was because of an update but the issue was not solved.

    • "2.1.15" (issue was not present)

    • "2.1.20" (issue present)

    • "2.1.21" (issue present)

    • "2.1.24" (issue present)

    • "2.1.25" (issue present)

    • "2.1.26" (issue present)

  3. Create a post in other forums.
    This is the post I created in the Unix Stack Exchange forum but didn't get any meaningful answer.

The current workaround

For the time being, I'll be using the "2.1.15" version. However, I would like to use the latest release since, according to the remote repository, the "2.1.15" version is 2268 commits to the "master" branch.
To sum up, I need help to identify the factor that might be making the latest versions of "anki" to display the GUI incorrectly.

Relevant links

Mod edit: Replaced oversized links -- V1del

Last edited by V1del (2020-06-18 06:59:15)

Offline

#2 2020-06-18 07:05:54

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 17,669

Re: anki is not properly displaying the GUI in latest releases

Please don't embed huge images directly: https://wiki.archlinux.org/index.php/Co … s_and_code

Is this limited to anki or are other qt5 programs affected? What qt5 theme have you configured? This eyeballs like a standard/gtk2 style which is known to be broken with qt 5.15 if you configure one of the "known" themes as listed in: https://wiki.archlinux.org/index.php/Qt#Qt5 does it work?

See https://wiki.archlinux.org/index.php/Qt … KDE_Plasma as well.

Which graphics driver do you use? If intel, and xf86-video-intel at that, try removing xf86-video-intel.

Last edited by V1del (2020-06-18 07:07:18)

Offline

#3 2020-06-18 10:46:21

regularuser123
Member
Registered: 2020-06-18
Posts: 6

Re: anki is not properly displaying the GUI in latest releases

Is this limited to anki or are other qt5 programs affected?

After looking for Qt5 applications in the list of applications form the Arch Wiki, I downloaded the following applications:

  • "transmission-qt" (Fast, easy, and free BitTorrent client (Qt GUI)

  • "x2goclient" (a graphical client (Qt5) for the X2Go system)

  • "qutebrowser" (A keyboard-driven, vim-like browser based on PyQt5)

and opened them which didn't result in any undesired behavior (see this gif: https://s7.gifyu.com/images/2020_06_18__05_39_04.gif)

What qt5 theme have you configured?

I've never configured `qt5` in a such a way that it doesn't use the default theme. I tried setting the "QT_STYLE_OVERRIDE" environment variable to "Windows" and "Fusion" but it didn't solve the issue. However, the theme indeed changed. I can confirm this because I noticed the change when I opened "transmission-qt". However, when I opened "x2goclient", there was no change in the theme (the issue didn't occur in this application). It is important to point out that all these three programs were run in the same shell in which the "QT_STYLE_OVERRIDE" environment variable was set).

I installed the "oxygen" theme (one of the themes listed in the "Appearance" section of the "Qt" article in the Arch Wiki). It changed the theme of "anki" but it didn't solve the issue either.

Regarding the article on "Configuration of Qt5 apps under environments other than KDE Plasma", I tried the following steps

  1. Install the "qt5ct" package.

  2. Install oxygen (the "oxygen", "oxygen-icons" packages) (

  3. Set the "QT_QPA_PLATFORMTHEME" environment variable to "qt5ct".

  4. Run "qt5ct".

  5. Set the "oxygen" icon theme in the "Icon theme" label of the "qt5ct" program.

  6. Run "anki"

The problem was not solved.

Which graphics driver do you use?

I'm using "nvidia" drivers (see below)

$ lspci -nnk | grep -i 'vga'
26:00.0 VGA compatible controller [0300]: NVIDIA Corporation TU104 [GeForce RTX 2070 SUPER] [10de:1e84] (rev a1)

Offline

#4 2020-06-21 01:07:12

regularuser123
Member
Registered: 2020-06-18
Posts: 6

Re: anki is not properly displaying the GUI in latest releases

I was helped in the Anki forums after creating a post
I solved the issue by executing

$ ANKI_NOHIGHDPI=1 anki

You can find further information on this issue in the related links that were posted by "addons_zz" in his reply to my post in the Anki forum.
Thanks for the help and advices though, V1del.

Last edited by regularuser123 (2020-06-21 01:10:58)

Offline

Board footer

Powered by FluxBB