You are not logged in.

#1 2020-06-19 11:43:39

floreal
Member
Registered: 2020-06-19
Posts: 2

rd.luks.* parameter seems to be broken with kernel 5.7.3

After Kernel update 5.7.3, I was unable de boot because I had no prompt for my passphrase.
I had to downgrade to previous linux and linux-headers version in order to be able to boot again.
I use systemd boot manager (with EFI).
I tried this on a Lenovo Thinkpad E-595 with a nvm ssd.
I'll try to reproduce that in a VM when I get some spare time to try to see whether it's a kernel change / bug or if it's my hardware configuration

Edit: Here is my bootloader entry (forgot to mention it):

title   Arch Linux
linux   /vmlinuz-linux
initrd  /amd-ucode.img
initrd  /initramfs-linux.img
options rd.luks.uuid=4480588e-1ec1-4cd4-ac3e-422ab58fc582 rd.luks.name=4480588e-1ec1-4cd4-ac3e-422ab58fc582=c_ROOT rd.luks.options=discard root="LABEL=ROOT" rw quiet splash loglevel=3 rd.udev.log_priority=3 vt.global_cursor_default=0

Last edited by floreal (2020-06-19 20:04:38)

Offline

#2 2020-06-19 18:15:04

thongil
Member
Registered: 2013-07-04
Posts: 13

Re: rd.luks.* parameter seems to be broken with kernel 5.7.3

Strange ,

GRUB_CMDLINE_LINUX="rd.luks.name=---=system"

I'm using this format and so far no issues with 5.7.2 5.7.3 and 5.7.4

Offline

#3 2020-06-19 18:51:28

latalante1
Member
Registered: 2018-08-30
Posts: 75

Re: rd.luks.* parameter seems to be broken with kernel 5.7.3

rd.luks.* are not kernel parameters.

Don't confuse them with the initrd, initramfs parameters.

Offline

#4 2020-06-19 20:08:20

floreal
Member
Registered: 2020-06-19
Posts: 2

Re: rd.luks.* parameter seems to be broken with kernel 5.7.3

Ok, problem fixed with Kernel 5.7.4. This is strange.

Offline

#5 2020-06-19 20:23:38

neutrix
Member
From: Bristol, UK
Registered: 2009-08-29
Posts: 64
Website

Re: rd.luks.* parameter seems to be broken with kernel 5.7.3

I can confirm I had the same problem with 5.7 3, but I don't think I use rd.luks

Offline

Board footer

Powered by FluxBB