You are not logged in.

#1 2020-06-19 17:08:09

Registered: 2020-06-19
Posts: 4

[solved] Arch only boots in initramfs-fallback, failed to mount /boot

Have not used - and updated - my Arch system in  while, now there have been some bugs, most fixed by now.
One problem now came up: I can't boot into my normal Arch system, just into 'initramfs-fallback'.
If I try booting into my normal Arch installation, it says in multiply lines: failed to mount /boot and Failed to start Load Kernel Module.
If I boot into 'initramfs-fallback', everything just works fine.
I've tried running mkinitcpio -p linux when booted into the initramfs-fallback image, doesn't change anything.

In /etc/mkinitcpio.conf no customization was done. This config is used both as default and fallback in /etc/mkinitcpio.d/linux-prese. Hooks used are: base udev autodetect modconf block filesystems keyboard fsck,
I've read somewhere that a problem in this config may make the normal installation unbootable, just initramfs-fallback However, the problem there wasn't that /boot couldn't be mounted.
The bootloader I use is GRUB.
I'm quite new to Arch, so I haven't found anything else to try out.
I'd highly appreciate any help.

Last edited by David_Tirol (2020-06-20 21:38:08)


#2 2020-06-19 17:15:39

From: London
Registered: 2014-02-20
Posts: 5,523

Re: [solved] Arch only boots in initramfs-fallback, failed to mount /boot

Does the running kernel version match the installed package?

uname -a
pacman -Q linux

It sounds like your /boot partition wasn't mounted correctly during a kernel upgrade.


#3 2020-06-19 17:15:46

Registered: 2014-03-06
Posts: 11,601

Re: [solved] Arch only boots in initramfs-fallback, failed to mount /boot

What is the output of

uname -a
pacman -Q linux

Beaten by Head_on_a_Stick

Last edited by loqs (2020-06-19 17:16:09)


#4 2020-06-20 10:09:15

From: Liège, Belgium
Registered: 2010-03-14
Posts: 151

Re: [solved] Arch only boots in initramfs-fallback, failed to mount /boot

I had same problem, but symply re-install kernel solved the issue:

sudo pacman -Suy kernel kernel-headers

KF5 & Plasma5 (git versions) - Awesome WM
ASUS Sabertooth 990FX - AMD FX8350 - ATI Radeon HD 7970
[testing] repo


#5 2020-06-20 12:59:07

Registered: 2020-06-15
Posts: 44

Re: [solved] Arch only boots in initramfs-fallback, failed to mount /boot


Would it be feasible to provide details of your newly used kernel version and drm/gpu? Specific : are you using i915 with kernel 5.7.x?? If yes, please try installing linux-lts kernel and share your observations.


#6 2020-06-20 21:37:19

Registered: 2020-06-19
Posts: 4

Re: [solved] Arch only boots in initramfs-fallback, failed to mount /boot

@ loqs, qHead_on_a_Stick,
thank you for your fast replies!!!!
it says linux 5.7.4.arch1-1 on both commands.

@ desparecido
with this command I get the error "Ziel nicht gefunden" (target not found)
strange ...

I'm using a GeForce GTX 970 graphics card.


says Driver Version: 440.82
Upon installation linux-lts gave me warnings "possibly missing firmware for module" for aic94xx and wd719x do I need to worry?

However, while trying out your help, I've found cause of the problem. The issue is with my grub configuration. My first menuentry should point to the current default arch installation. Next there's a submenu with automatically generated copies of the last stable image, the one before the last stable one the current default image and the initramfs-fallback image. The problem was, the main menu entry for the default image was pointing towards the "stable" image which is broken. If I select the default image from the submenu, everything works just fine.

Still I wanna thank you for trying to help me. As a newbi, I'm really glad for the Archlinux community wink


Board footer

Powered by FluxBB