You are not logged in.

#1 2020-06-22 20:14:30

davidstein
Member
Registered: 2020-06-22
Posts: 21

[SOLVED] Rstudio-desktop-bin cursor skips ahead of text

I installed https://aur.archlinux.org/packages/rstudio-desktop-bin/ and built it with makepkg -si.

It seems to work fine, however, the cursor jumps several spaces ahead of the text. Deleting the seemingly empty spaces deletes the text behind it. Has anyone run into this issue?

Also, I'm very new to Arch so if this is posted in the wrong place let me know

Last edited by davidstein (2020-06-23 14:58:38)

Offline

#2 2020-06-23 12:16:33

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 8,197

Re: [SOLVED] Rstudio-desktop-bin cursor skips ahead of text

That package seems to use bundled QT libraries .
Did you put R_LIBS_USER in a .Renviron file as described in the configuration section of The R page in archwiki[1] ?

If correct configuration is present or doesn't solve this :
Your description sounds very much like an issue QT programs (like konsole) had in the past with monospace fonts .

Post the output of

$ fc-match Monospace


[1]
https://wiki.archlinux.org/index.php/R


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2020-06-23 13:49:22

davidstein
Member
Registered: 2020-06-22
Posts: 21

Re: [SOLVED] Rstudio-desktop-bin cursor skips ahead of text

Hi this is my .Renviron file

R_HOME_USER = ${HOME}/R
R_LIBS_USER = ${HOME}/R/x86_64-pc-linux-gnu-library/4.0/
R_PROFILE_USER = ${HOME}/.config/r/.Rprofile
R_HISTFILE = ${HOME}/.cache/.Rhistory

and this is the

fc-match Monospace

output

NotoSans-Regular.ttf: "Noto Sans" "Regular"

Offline

#4 2020-06-23 14:50:46

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 8,197

Re: [SOLVED] Rstudio-desktop-bin cursor skips ahead of text

Did some testing and it looks like that font should work.

Check which font Rstudio desktop is using now . DDG search suggest you want to look at Global Options -->Appearance --> Editor Fonts


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#5 2020-06-23 14:58:23

davidstein
Member
Registered: 2020-06-22
Posts: 21

Re: [SOLVED] Rstudio-desktop-bin cursor skips ahead of text

Ahh yes thank you! I switched the font in the Global Options -->Appearance --> Editor Fonts from monospace to Source Code Pro and now its working

Offline

Board footer

Powered by FluxBB