You are not logged in.

#1 2019-03-14 09:17:32

bgth
Member
Registered: 2018-05-21
Posts: 27

Bluetooth-Error: RFCOMM Server Adresse already in use

Hello together,

I have Problem with my T480s and the Bluetooth stack. I coupled the Laptop with my phone and now I get always on startup of the Laptop the following error message in the Systemlog:

bluetoothd
RFCOMM server failed for :1.159/Profile/HSPHSProfile/00001108-0000-1000-8000-00805f9b34fb: rfcomm_bind: Address already in use (98)
RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address already in use (98)

I'm running Arch with the latest LTS-Kernel and bluez. Has anyone of you an idea what is going wrong here or where do look for more information?
Thank you in advance.

Offline

#2 2019-03-21 10:50:47

bgth
Member
Registered: 2018-05-21
Posts: 27

Re: Bluetooth-Error: RFCOMM Server Adresse already in use

Nobody?

Offline

#3 2019-03-21 14:06:51

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,275

Re: Bluetooth-Error: RFCOMM Server Adresse already in use

Please, do not bump.  It is a sure sign you have not provided enough information. https://wiki.archlinux.org/index.php/Co … ct#Bumping
The correct thing to do is provide more information, or tell us what you have tried, read and learned in the time since the original post.

For example, how are you staring the stack?  Did you enable a system service, or are you using a desktop environment in which Bluetooth is integrated so that things happen automatically?
Any chance you have both?  This would mean you have more than one thing trying to control the Bluetooth system.
Have you tried poking around with bluetoothctl to see what is connected?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#4 2019-03-22 08:11:54

bgth
Member
Registered: 2018-05-21
Posts: 27

Re: Bluetooth-Error: RFCOMM Server Adresse already in use

Sorry for that. I have an systemd-service running, which shows the error, when checking via systemctl bluetooth status

Endpoint registered: sender=:1.128 path=/MediaEndpoint/A2DPSource
: Endpoint registered: sender=:1.128 path=/MediaEndpoint/A2DPSink
: Endpoint registered: sender=:1.238 path=/MediaEndpoint/A2DPSource
: Endpoint registered: sender=:1.238 path=/MediaEndpoint/A2DPSink
: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address already in use (98)
: RFCOMM server failed for :1.238/Profile/HSPHSProfile/00001108-0000-1000-8000-00805f9b34fb: rfcomm_bind: Address already in use (98)
: Endpoint unregistered: sender=:1.128 path=/MediaEndpoint/A2DPSource
: Endpoint unregistered: sender=:1.128 path=/MediaEndpoint/A2DPSink
: Endpoint unregistered: sender=:1.238 path=/MediaEndpoint/A2DPSource
: Endpoint unregistered: sender=:1.238 path=/MediaEndpoint/A2DPSink

My desktop enviroment is gnome. And also tlp is installed with the option RESTORE_DEVICE_STATE_ON_STARTUP=1.

Last edited by bgth (2019-03-22 08:13:19)

Offline

#5 2019-03-22 08:16:25

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 9,995

Re: Bluetooth-Error: RFCOMM Server Adresse already in use

Did you already rule out GDM interference? https://wiki.archlinux.org/index.php/Bl … e_with_GDM

Offline

#6 2019-03-22 09:05:43

bgth
Member
Registered: 2018-05-21
Posts: 27

Re: Bluetooth-Error: RFCOMM Server Adresse already in use

I need to correct my first post. The error occurs even if the phone and the laptop are uncoupled, but the bluetooth of the phone is running.
Nevertheless bluetooth works fine in most cases (sound is playing both when the laptop is source or sink), only sometimes it is hard to get connection to my mobile speaker.  I am not sure if this is related to this error.

V1del wrote:

Did you already rule out GDM interference? https://wiki.archlinux.org/index.php/Bl … e_with_GDM

First, thank you for your answer. I checked via htop but there is no pulse audio process of user gdm running. So I think this does not apply. Or am I wrong on this?

Last edited by bgth (2019-03-22 09:17:39)

Offline

#7 2020-06-26 00:23:02

minifridge
Member
Registered: 2020-06-21
Posts: 3

Re: Bluetooth-Error: RFCOMM Server Adresse already in use

I had a similar problem with my bluetooth receiver being ignored by pulse audio

sudo systemctl status bluetooth
● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
     Active: active (running) since Fri 2020-06-26 01:04:01 BST; 8min ago
       Docs: man:bluetoothd(8)
   Main PID: 459 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 38150)
     Memory: 3.9M
     CGroup: /system.slice/bluetooth.service
             └─459 /usr/lib/bluetooth/bluetoothd

Jun 26 01:04:20 minifridge bluetoothd[459]: Endpoint registered: sender=:1.110 path=/MediaEndpoint/A2DPSource/VENDOR/APTX
Jun 26 01:04:20 minifridge bluetoothd[459]: Endpoint registered: sender=:1.110 path=/MediaEndpoint/A2DPSource/AAC
Jun 26 01:04:20 minifridge bluetoothd[459]: Endpoint registered: sender=:1.110 path=/MediaEndpoint/A2DPSource/SBC
Jun 26 01:04:20 minifridge bluetoothd[459]: Endpoint registered: sender=:1.110 path=/MediaEndpoint/A2DPSink/VENDOR/APTXHD
Jun 26 01:04:20 minifridge bluetoothd[459]: Endpoint registered: sender=:1.110 path=/MediaEndpoint/A2DPSink/VENDOR/APTX
Jun 26 01:04:20 minifridge bluetoothd[459]: Endpoint registered: sender=:1.110 path=/MediaEndpoint/A2DPSink/AAC
Jun 26 01:04:20 minifridge bluetoothd[459]: Endpoint registered: sender=:1.110 path=/MediaEndpoint/A2DPSink/SBC
Jun 26 01:04:20 minifridge bluetoothd[459]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address already in use (98)
Jun 26 01:04:20 minifridge bluetoothd[459]: RFCOMM server failed for :1.110/Profile/HSPHSProfile/00001108-0000-1000-8000-00805f9b34fb: rfcomm_bind: Address already in use (98)
Jun 26 01:10:18 minifridge bluetoothd[459]: Unable to get io data for Hands-Free Voice gateway: getpeername: Transport endpoint is not connected (107)

The following commands fixed it:

$ sudo rfkill block bluetooth
$ sudo rfkill unblock bluetooth
$ sudo systemctl restart bluetooth

Offline

Board footer

Powered by FluxBB