You are not logged in.

#1 2020-06-25 15:30:25

Rumcajs
Member
Registered: 2009-09-25
Posts: 36

[SOLVED] bctoolbox dependencies problem

sudo pacman -Su

error: failed to prepare transaction (could not satisfy dependencies)
:: installing bctoolbox (4.4.0-1) breaks dependency 'bctoolbox=4.3.1' required by belle-sip

and belle-sip is required by linphone

any idea?

Last edited by Rumcajs (2020-06-26 07:00:45)

Offline

#2 2020-06-25 15:33:51

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,792
Website

Re: [SOLVED] bctoolbox dependencies problem

Update belle-sip.

Mod note: Moving to AUR Issues.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#3 2020-06-25 15:42:44

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 9,983

Re: [SOLVED] bctoolbox dependencies problem

Remove the belle-sip package (use -Rdd), update your system, adjust the PKGBUILD for belle-sip remove the hard dependency on the 4.3 version, rebuild it and reinstall, if it works ask the packager to not set hard limits if it isn't necessary.

Moving to AUR issues...

Offline

#4 2020-06-26 07:00:14

Rumcajs
Member
Registered: 2009-09-25
Posts: 36

Re: [SOLVED] bctoolbox dependencies problem

i have uninstall linphone (i don't use it anyway) and belle-sip

Offline

Board footer

Powered by FluxBB