You are not logged in.

#1 2020-06-07 13:01:48

Registered: 2013-06-09
Posts: 5

[Solved] Blender 2.83 & 2.82 crashes at startup in various ways

Last time I run blender was probably few months ago, so I dont know exactly, when the issue started.

First, I got immediate crashes and gdb told me the problem is around Open Image Denoise:

Thread 1 "blender" received signal SIGILL, Illegal instruction.
0x00007ffff355191d in ?? () from /usr/lib/
(gdb) bt
#0  0x00007ffff355191d in ?? () from /usr/lib/
#1  0x00007ffff7fe20f2 in call_init.part () from /lib64/
#2  0x00007ffff7fe2201 in _dl_init () from /lib64/
#3  0x00007ffff7fd313a in _dl_start_user () from /lib64/
#4  0x0000000000000001 in ?? ()
#5  0x00007fffffffeaf5 in ?? ()
#6  0x0000000000000000 in ?? ()

I downgraded blender to 2.82 version, but was the same. Then, again with 2.83, I downgraded openimagedenoise twice, to version 1.1.0. Blender started longer, with visible window frame, but then also crashed, in different way:

hread 1 "blender" received signal SIGSEGV, Segmentation fault.
0x00005555583df8f7 in GPU_draw_list_command_add ()
(gdb) bt
#0  0x00005555583df8f7 in GPU_draw_list_command_add ()
#1  0x000055555660d355 in draw_call_batching_flush ()
#2  0x000055555660ec94 in drw_draw_pass_ex ()
#3  0x0000555556639916 in OVERLAY_draw_scene ()
#4  0x00005555566062f3 in drw_engines_draw_scene ()
#5  0x00005555566065f7 in DRW_draw_render_loop_ex ()
#6  0x0000555556cbcdd8 in view3d_main_region_draw ()
#7  0x000055555688ae61 in ED_region_do_draw ()
#8  0x0000555556519a75 in wm_draw_update ()
#9  0x0000555556517a34 in WM_main ()
#10 0x000055555622631b in main ()

I have old nvidia Geforce 8600GTM card, legacy nvidia-340xx driver and mesa-*-noglvnd packages family from AUR - as fresh, as possible. I have this configuration since recently. This may be problematic, but I'm nearly shure I run blender withour problems already with these packages. In fact, I installed it just because of libglvnd package, which appeared incompatibile with legacy nvidia and most of 3D programs stopped to work.

So, anyone experienced similar problems? Or rather should I post an issue on

Last edited by pirogornian (2020-06-28 18:45:12)


#2 2020-06-07 13:59:38

Bug Wrangler
Registered: 2012-09-01
Posts: 7,893

Re: [Solved] Blender 2.83 & 2.82 crashes at startup in various ways

openimagedenoise currently requires SSE 4.1. Your CPU is too old. It's being looked into.


#3 2020-06-28 18:44:35

Registered: 2013-06-09
Posts: 5

Re: [Solved] Blender 2.83 & 2.82 crashes at startup in various ways

I solved this issue (claimed after few tests) by modyfing blender-2.83-git package from AUR to not include openimagedenoise and Cycles support.


Board footer

Powered by FluxBB