You are not logged in.

#1 2020-06-28 16:41:30

zozozo
Member
Registered: 2020-03-17
Posts: 3

High-pitched distorted sound with usb external sound card after reboot

I use pulseaudio, and I recently received and plugged a full-digital-amplifier using a usb cable to my PC; the computer was already running, I plugged it and everything worked out of the box.

However, now that I rebooted the pc, the sound that is coming out of the speakers (which are plugged into the amplifier) is very high-pitched and unintelligible, almost like some kind of high-pitched white noise, but it still changes with the sound being played by the pc, so I guess the sound is simply extremely distorted, to the point that it is not recognizable anymore (and extremely unnerving, ^^). When plugging the amplifier (or headphones) using a jack cable, everything works fine, but it's quite a waste to have a brand new digital amplifier and use it with an analog cable.

I tried changing the sampling rate in the puleaudio config (as suggested in https://wiki.archlinux.org/index.php/Pu … eshooting), and the amplifier correctly recognizes the new sampling rate, but it doesn't seem to affect the distortion much.

What's strange is that it worked at first, and now that I rebooted (and changed a few settings in the configuration of Xorg, but I doubt that would affect pulseaudio ?), the distortion appeared. Are there any configuration steps for external sound cards that I missed somewhere ?

Offline

#2 2020-06-28 16:55:27

zozozo
Member
Registered: 2020-03-17
Posts: 3

Re: High-pitched distorted sound with usb external sound card after reboot

So, actually, something I didn't notice with music playing, but apparent with a video, is that when trying to use the usb digital output with the amplifier, the videos actually play extremely slowly, which might explain the problems with the sound, but I don't know why the playback would be that slow.

Offline

#3 2020-06-28 18:36:39

SoylentSorbet
Member
Registered: 2020-06-28
Posts: 3

Re: High-pitched distorted sound with usb external sound card after reboot

So I'm having a similar issue; but for me it's a simple USB to headphone jack converter that only started acting up since I recently upgraded. The device itself works fine, as it still works fine if I boot into say Ubuntu. After your comment about slow video playback I checked and playback is also extremely slow when the audio is sent to the device. I'm by no means an expert but my understanding is that the drivers for these devices are usually included directly into the Linux kernel, so perhaps a later version of the kernel broke something in some way? I'm just glad to know that I'm not the only one affected.

Offline

#4 2020-06-29 10:45:08

itmecho
Member
Registered: 2020-06-29
Posts: 3

Re: High-pitched distorted sound with usb external sound card after reboot

I'm also hitting this on both my desktop and laptop. Dell USB C dock sound is broken as well as the onboard sound on the desktop motherboard. Built-in laptop sound and a USB headset (Corsair Vengeance 1500) both work fine.

I tried rolling back to the previous versions of alsa-lib and alsa-ucm-conf but I still get the problem. Same with the LTS kernel.

Here's a video of the problem: https://photos.google.com/share/AF1QipP … tmcFFOMHN3

Last edited by itmecho (2020-06-29 10:47:01)

Offline

#5 2020-06-29 15:47:50

SoylentSorbet
Member
Registered: 2020-06-28
Posts: 3

Re: High-pitched distorted sound with usb external sound card after reboot

So I think the same issue is being discussed elsewhere on the forum here, where they seemed to have narrowed it down to a specific commit in the kernel. I also found this kernel bug issue where the author of that commit is addressing a similar issue and released a test patch that seemed to work for the reporter of that bug (haven't tried it myself).

itmecho wrote:

I'm also hitting this on both my desktop and laptop. Dell USB C dock sound is broken as well as the onboard sound on the desktop motherboard. Built-in laptop sound and a USB headset (Corsair Vengeance 1500) both work fine.

I tried rolling back to the previous versions of alsa-lib and alsa-ucm-conf but I still get the problem. Same with the LTS kernel.

Here's a video of the problem: https://photos.google.com/share/AF1QipP … tmcFFOMHN3

Yeah that's exactly like my experience. I'm a little concerned though that you're experiencing it with the LTS kernel, as I wouldn't expect it to have the offending commit they identified in the other post.

Offline

#6 2020-06-30 07:55:48

itmecho
Member
Registered: 2020-06-29
Posts: 3

Re: High-pitched distorted sound with usb external sound card after reboot

Good find! Reading that kernel bug it looks like it was initially raised against the LTS version so that explains it! The comments say it's affecting 5.4.49 as well as 5.7.6 but they already have a patch that fixes it. Fingers crossed we get a new release ASAP

Offline

#7 2020-07-01 22:51:20

SoylentSorbet
Member
Registered: 2020-06-28
Posts: 3

Re: High-pitched distorted sound with usb external sound card after reboot

linux 5.7.7.arch1-1 is in testing right now and it looks like it contains the fix.

Offline

#8 2020-07-02 11:15:39

antalm
Member
Registered: 2020-07-02
Posts: 1

Re: High-pitched distorted sound with usb external sound card after reboot

I have the exact same issue with a Dell WD19 docking station's USB audio. If I select USB audio headphones output videos play about 1/6 of their normal speed and the sound is extremely distorted and is also about 1/6 of their normal speed. When there's no sound there's a high pitched noise (almost white noise) that is modulated very slowly. This "ALSA: usb-audio: Fix packet size calculation" fix in the mentioned Kernel sounds good smile I'm glad I found this topic, this bug almost got on my nerves.
EDIT: I can confirm that USB audio headphones work fine on both linux-lts-5.4.50-1 and linux-5.7.7.arch1-1 that were released this morning. Thank you!

Last edited by antalm (Yesterday 07:12:27)

Offline

#9 Yesterday 08:52:00

itmecho
Member
Registered: 2020-06-29
Posts: 3

Re: High-pitched distorted sound with usb external sound card after reboot

5.7.7 was released, I've upgraded this morning and it has fixed the issue for me!

Last edited by itmecho (Yesterday 08:52:16)

Offline

Board footer

Powered by FluxBB