You are not logged in.

#1 2020-06-29 23:23:06

Registered: 2020-06-29
Posts: 1

ser_open(): can't open device no such file or directory

Hi this is my first time trying to flash an arduino, so workflow is probably all over the place...

I'm specifically trying to flash the dactyl manuform 4x5 keymap onto it (

The output I'm getting is:

Reset your Pro Micro now
avrdude: ser_open(): can't open device "/dev/ttyACM0": No such file or directory

avrdude done.  Thank you.

However the output of

ls -la /dev/ttyACM0


crw-rw---- 1 root uucp 166, 0 Jun 29 23:58 /dev/ttyACM0

All I can think of as happening is that avrdude is trying to access it before the handshake is complete (I'm using the pro micro which apparently resets the connection on reset).  However I have no idea of how one could fix that.

I've tried the standard fixes I've found so far: I've added mysefl to uucp, dialout and tty.

I've also tried using the official arduino software but although that software has claimed to flash the arduino with the blink program, there are several initial flashes on the Rx, Tx leds, but then no actual blinking of the leds.


Board footer

Powered by FluxBB