You are not logged in.

#1 2020-07-09 07:12:08

markand
Member
Registered: 2015-04-09
Posts: 25

Not booting with quiet mode

Hello there,

I have a very strange issue. My laptop don't always boot if I boot in quiet mode. I usually boot directly via efibootmgr and it should work. However, if I put the quiet mode my UEFI logo stays during boot and I should reach GDM quite quickly. When disabling quiet mode it works just fine, systemd messages are print and I reach the GDM screen in around 2 seconds.

In quiet mode, my screen stays black (with the Lenovo logo) and my external screen does not get any signal. The system seems stuck because it does not shutdown with power button or the tree-finger salute combo. It does not even react to REISUB either.

I'm unable to understand the issue. Did someone had already faced this issue?

Content of my /etc/mkinitcpio.conf:

# vim:set ft=sh
# MODULES
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(piix ide_disk reiserfs)
MODULES=(i915)

# BINARIES
# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries
BINARIES=()

# FILES
# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way.  This is useful for config files.
FILES=()

# HOOKS
# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
##   This setup specifies all modules in the MODULES setting above.
##   No raid, lvm2, or encrypted root is needed.
#    HOOKS=(base)
#
##   This setup will autodetect all modules for your system and should
##   work as a sane default
#    HOOKS=(base udev autodetect block filesystems)
#
##   This setup will generate a 'full' image which supports most systems.
##   No autodetection is done.
#    HOOKS=(base udev block filesystems)
#
##   This setup assembles a pata mdadm array with an encrypted root FS.
##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
#    HOOKS=(base udev block mdadm encrypt filesystems)
#
##   This setup loads an lvm2 volume group on a usb device.
#    HOOKS=(base udev block lvm2 filesystems)
#
##   NOTE: If you have /usr on a separate partition, you MUST include the
#    usr, fsck and shutdown hooks.
HOOKS=(base systemd sd-vconsole autodetect modconf block filesystems keyboard fsck)

# COMPRESSION
# Use this to compress the initramfs image. By default, gzip compression
# is used. Use 'cat' to create an uncompressed image.
#COMPRESSION="gzip"
#COMPRESSION="bzip2"
#COMPRESSION="lzma"
#COMPRESSION="xz"
#COMPRESSION="lzop"
#COMPRESSION="lz4"

# COMPRESSION_OPTIONS
# Additional options for the compressor
#COMPRESSION_OPTIONS=()

My kernel command line is (through efibootmgr) initrd=intel-ucode.img initrd=initramfs-linux.img root=/dev/nvme0n1p2 quiet rw

Offline

#2 2020-07-09 18:13:36

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,480
Website

Re: Not booting with quiet mode

markand wrote:

I usually boot directly via efibootmgr and it should work. However, if I put the quiet mode

Please post the exact, full efibootmgr(8) commands used to achieve the different boot techniques.

Have you checked the journal for one of the failed boots?

Offline

#3 2020-07-09 18:35:23

markand
Member
Registered: 2015-04-09
Posts: 25

Re: Not booting with quiet mode

Head_on_a_Stick wrote:
markand wrote:

I usually boot directly via efibootmgr and it should work. However, if I put the quiet mode

Please post the exact, full efibootmgr(8) commands used to achieve the different boot techniques.

Have you checked the journal for one of the failed boots?

I use

efibootmgr -c -d /dev/nvme0n1 -L "Arch" -l vmlinuz-linux -u "initrd=intel-ucode.img initrd=initramfs-linux.img root=/dev/nvme0n1p2 quiet rw"

I only have two partitions, so that's why I can easily boot through efibootmgr directly:

  • /dev/nvme0n1p1 -> EFI mounted directly as /boot

  • /dev/nvme0n1p2 -> /

You're right I should have looked at the journal because there is something wrong:

Jul 09 08:52:30 archlinux kernel: BUG: kernel NULL pointer dereference, address: 0000000000000078
Jul 09 08:52:30 archlinux kernel: #PF: supervisor read access in kernel mode
Jul 09 08:52:30 archlinux kernel: #PF: error_code(0x0000) - not-present page
Jul 09 08:52:30 archlinux kernel: PGD 0 P4D 0 
Jul 09 08:52:30 archlinux kernel: Oops: 0000 [#1] PREEMPT SMP PTI
Jul 09 08:52:30 archlinux kernel: CPU: 1 PID: 22 Comm: kworker/1:0 Not tainted 5.7.7-arch1-1 #1
Jul 09 08:52:30 archlinux kernel: Hardware name: LENOVO 20FBCTO1WW/20FBCTO1WW, BIOS N1FET68W (1.42 ) 03/13/2019
Jul 09 08:52:30 archlinux kernel: Workqueue: events_long drm_dp_mst_link_probe_work [drm_kms_helper]
Jul 09 08:52:30 archlinux kernel: RIP: 0010:intel_psr_atomic_check+0x33/0xa0 [i915]
Jul 09 08:52:30 archlinux kernel: Code: 80 2d 06 00 00 20 74 42 80 b8 34 70 00 00 00 74 39 48 8b 72 08 48 85 f6 74 30 80 b8 f8 70 00 00 00 74 27 4c 8b 87 80 04 00 00 <41> 8b 78 78 83 ff 08 77 18 31 c9 83 ff 05 77 18 48 81 c1 28 01 00
Jul 09 08:52:30 archlinux kernel: RSP: 0018:ffff9f818011fb08 EFLAGS: 00010202
Jul 09 08:52:30 archlinux kernel: RAX: ffff94cfd4400000 RBX: ffff94cfd309c000 RCX: 0000000000000000
Jul 09 08:52:30 archlinux kernel: RDX: ffff94cfd29276c0 RSI: ffff94cfd4b9f800 RDI: ffff94cfd309f000
Jul 09 08:52:30 archlinux kernel: RBP: ffff94cfd309f000 R08: 0000000000000000 R09: ffff94cfd40b8420
Jul 09 08:52:30 archlinux kernel: R10: ffff94cfd2927180 R11: ffff94cfd29276c0 R12: ffff94cfd29276c0
Jul 09 08:52:30 archlinux kernel: R13: ffff94cfd2927f00 R14: ffff94cfd309c000 R15: ffff94cfd487c400
Jul 09 08:52:30 archlinux kernel: FS:  0000000000000000(0000) GS:ffff94cfda480000(0000) knlGS:0000000000000000
Jul 09 08:52:30 archlinux kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Jul 09 08:52:30 archlinux kernel: CR2: 0000000000000078 CR3: 0000000214780002 CR4: 00000000003606e0
Jul 09 08:52:30 archlinux kernel: Call Trace:
Jul 09 08:52:30 archlinux kernel:  intel_digital_connector_atomic_check+0x4e/0x130 [i915]
Jul 09 08:52:30 archlinux kernel:  intel_dp_mst_atomic_check+0x59/0x240 [i915]
Jul 09 08:52:30 archlinux kernel:  drm_atomic_helper_check_modeset+0x403/0xb20 [drm_kms_helper]
Jul 09 08:52:30 archlinux kernel:  intel_atomic_check+0x9d/0x22b0 [i915]
Jul 09 08:52:30 archlinux kernel:  drm_atomic_check_only+0x57c/0x7f0 [drm]
Jul 09 08:52:30 archlinux kernel:  drm_atomic_commit+0x13/0x50 [drm]
Jul 09 08:52:30 archlinux kernel:  drm_client_modeset_commit_atomic+0x1e1/0x220 [drm]
Jul 09 08:52:30 archlinux kernel:  drm_client_modeset_commit_locked+0x54/0x150 [drm]
Jul 09 08:52:30 archlinux kernel:  drm_client_modeset_commit+0x24/0x40 [drm]
Jul 09 08:52:30 archlinux kernel:  drm_fb_helper_set_par+0xa5/0xd0 [drm_kms_helper]
Jul 09 08:52:30 archlinux kernel:  drm_fb_helper_hotplug_event.part.0+0xa3/0xc0 [drm_kms_helper]
Jul 09 08:52:30 archlinux kernel:  drm_kms_helper_hotplug_event+0x26/0x30 [drm_kms_helper]
Jul 09 08:52:30 archlinux kernel:  process_one_work+0x1da/0x3d0
Jul 09 08:52:30 archlinux kernel:  worker_thread+0x4d/0x3e0
Jul 09 08:52:30 archlinux kernel:  ? rescuer_thread+0x3f0/0x3f0
Jul 09 08:52:30 archlinux kernel:  kthread+0x13e/0x160
Jul 09 08:52:30 archlinux kernel:  ? __kthread_bind_mask+0x60/0x60
Jul 09 08:52:30 archlinux kernel:  ret_from_fork+0x35/0x40
Jul 09 08:52:30 archlinux kernel: Modules linked in: ext4 crc32c_generic crc16 mbcache jbd2 rtsx_pci_sdmmc serio_raw mmc_core atkbd libps2 xhci_pci xhci_hcd crc32c_intel rtsx_pci i8042 serio i915 intel_gtt i2c_algo_bit drm_kms_helper syscopyarea sysfillrect sysimgblt fb_sy>
Jul 09 08:52:30 archlinux kernel: CR2: 0000000000000078
Jul 09 08:52:30 archlinux kernel: ---[ end trace 4e3718ffa8414be8 ]---
Jul 09 08:52:30 archlinux kernel: RIP: 0010:intel_psr_atomic_check+0x33/0xa0 [i915]
Jul 09 08:52:30 archlinux kernel: Code: 80 2d 06 00 00 20 74 42 80 b8 34 70 00 00 00 74 39 48 8b 72 08 48 85 f6 74 30 80 b8 f8 70 00 00 00 74 27 4c 8b 87 80 04 00 00 <41> 8b 78 78 83 ff 08 77 18 31 c9 83 ff 05 77 18 48 81 c1 28 01 00
Jul 09 08:52:30 archlinux kernel: RSP: 0018:ffff9f818011fb08 EFLAGS: 00010202
Jul 09 08:52:30 archlinux kernel: RAX: ffff94cfd4400000 RBX: ffff94cfd309c000 RCX: 0000000000000000
Jul 09 08:52:30 archlinux kernel: RDX: ffff94cfd29276c0 RSI: ffff94cfd4b9f800 RDI: ffff94cfd309f000
Jul 09 08:52:30 archlinux kernel: RBP: ffff94cfd309f000 R08: 0000000000000000 R09: ffff94cfd40b8420
Jul 09 08:52:30 archlinux kernel: R10: ffff94cfd2927180 R11: ffff94cfd29276c0 R12: ffff94cfd29276c0
Jul 09 08:52:30 archlinux kernel: R13: ffff94cfd2927f00 R14: ffff94cfd309c000 R15: ffff94cfd487c400
Jul 09 08:52:30 archlinux kernel: FS:  0000000000000000(0000) GS:ffff94cfda480000(0000) knlGS:0000000000000000
Jul 09 08:52:30 archlinux kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033

This is when booted in quiet mode.

Offline

#4 2020-07-09 18:46:33

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,480
Website

Re: Not booting with quiet mode

It's best to post the full log rather than just a snippet.

Does the LTS kernel boot with the quiet parameter applied?

Can other bootloaders get the system running with the quiet parameter applied?

Offline

#5 2020-07-09 19:11:29

madaramost
Member
Registered: 2015-05-25
Posts: 34

Re: Not booting with quiet mode

please use wiki's efibootmgr commands then try ctrl+alt+f2 login and run:

pacman -Sy linux-firmware

Offline

#6 2020-07-09 19:16:25

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,480
Website

Re: Not booting with quiet mode

madaramost wrote:
pacman -Sy linux-firmware

https://wiki.archlinux.org/index.php/Sy … nsupported

Offline

Board footer

Powered by FluxBB