You are not logged in.

#1 2003-02-03 22:50:24

beniro
Member
From: St. Petersburg, FL, USA
Registered: 2002-12-31
Posts: 312

Two packages install fine, but segfault...

I installed idesk and audacity from the unofficial pkgs and when I try to run them, I just get:

segmentation fault

I have other unofficial packages installed and working (thanks to BluPheonyx and the other helpers in this forum).  These are the only ones that I've had problems with.  I BELIEVE that I have the most recent ABS releases of these programs (I'm going to confirm that today when I get home).

Here's the really newbie part of my question:  where can I find a better log of what goes wrong when I try to run these apps than simply: "segmentation" fault???

In the unofficial repository, should problems be reported directly to the releasers of the packages?  How do we find out who did each pkg?

Simply put:  what is the best way to resolve this problem?

Thanks alot.  smile

Offline

#2 2003-02-03 23:19:58

BluPhoenyx
Member
Registered: 2002-12-23
Posts: 239

Re: Two packages install fine, but segfault...

Where a program logs errors or other info really depends on the program. For that matter, some programs don't log anything at all. Also, error output can depend on compile time settings and most production packages tend to turn this stuff off. Generally, programs will either write log entries into the system log areas or the users home or a subdirectory thereof.

There could be several reasons why the error happens including different sound options on the system, variant library versions between the packager's system and yours or even missing files from either the package or something the package relies on. While this info may not help, it might give you an idea where to look. FWIW, this doesn't include possible problems with hardware or larger desktop systems such as KDE or Gnome.

I can't help with regard to reporting the problems. I think that would be up to the developers and this bbs' management. You might be able to find some contact info inside the pkg itself. There is a file .PKGINFO with some text about the package for pacman. However, the packager may not use their name or it may say 'Arch Linux ...'

I suppose you could always find a copy of the source and build it yourself to see it it works. Personally, I prefer having the source so I can use my own compile options but I'm a perfectionist.


BluPhoenyx

Offline

#3 2003-02-03 23:33:55

apeiro
Daddy
From: Victoria, BC, Canada
Registered: 2002-08-12
Posts: 771
Website

Re: Two packages install fine, but segfault...

If a package segfaults, you can always try building it from source.  It's quite easy to do in Arch Linux.

First install the 'cvsup' package, then run 'abs' to sync your build tree.

# pacman -Sy cvsup
# abs

Then head into the directory of the package you wish to build and run 'makepkg'.  For example, to build the freeciv package:

# cd /usr/abs/unofficial/games/freeciv
# makepkg

The end result should be a freeciv-1.14.0-1.pkg.tar.gz in the package dir that you can install with pacman.

Offline

#4 2003-02-04 00:31:21

jk
Member
From: Groningen, The Netherlands
Registered: 2002-10-24
Posts: 66
Website

Re: Two packages install fine, but segfault...

Dunno about audacity, but idesk is a bit of a strange program. It indeed tends to segfault if you don't have a ~/.ideskrc and ~/.idesktop/ directory. Check it's homepage at http://linuxhelp.hn.org/idesk.php on how to do that...

Offline

#5 2003-02-04 00:48:35

beniro
Member
From: St. Petersburg, FL, USA
Registered: 2002-12-31
Posts: 312

Re: Two packages install fine, but segfault...

Ok.  Thanks so much for the replies.

I'm going to try to build them from source.  I'll report back with my findings.  smile

Thanks again!

Offline

#6 2003-02-04 19:53:51

beniro
Member
From: St. Petersburg, FL, USA
Registered: 2002-12-31
Posts: 312

Re: Two packages install fine, but segfault...

Hehe...I got idesk working.  I don't think I was missing a file, but I -Syu'd everything and re-pacmanned idesk and it worked great.

-Syu'd?  Re-pacman?  It's called Archspeak.

I'm still working with audacity, though.  I'll get it yet!  smile

Offline

#7 2003-02-04 20:00:58

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: Two packages install fine, but segfault...

i will take a look at audacity when i get a chance it could be another application which is built to my computers specs more than it should be.

i will check depends and ./configure options and see if i cannot get a fix posted soon.


AKA uknowme

I am not your friend

Offline

#8 2003-02-04 20:42:50

beniro
Member
From: St. Petersburg, FL, USA
Registered: 2002-12-31
Posts: 312

Re: Two packages install fine, but segfault...

Ok.  Thanks loads, sarah.  smile

Please know, thouhg that I'm still not sure it's not a problem on my end, since I'm not quite an epert at this.  I may very well be doing something incredibly newbie-ish.

I'd like to think that I contribute that essential element of wide-eyed wonder that only a forum's "Resident Newbie" can supply.  big_smile

Offline

#9 2003-02-07 20:29:16

beniro
Member
From: St. Petersburg, FL, USA
Registered: 2002-12-31
Posts: 312

Re: Two packages install fine, but segfault...

I have an additional question:  when I install audacity directly from source (untar, ./configure, make, make install with the audacity 1.1.1 source code), everything appears to go smoothly, but when I type "audacity", it proceeds to tell me that there is no such command.  Am I missing something?  What should I be reading?  I perused extensively the README, etc...

I think I may not fully understand this by-hand install process.

Offline

#10 2003-02-08 00:08:18

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: Two packages install fine, but segfault...

audacity appears not to like some setting in arch linux i tried various different things and yet it still segfaults with no information as to why. my theory is the it does not like something about wxgtk though this is pure speculation.

so if anyone has some ideass or suggestions i am all ears if i hear nothing in the next day or two audacity will unfortunately have to be removed from the unoffcial tree.


AKA uknowme

I am not your friend

Offline

#11 2003-02-08 02:07:55

beniro
Member
From: St. Petersburg, FL, USA
Registered: 2002-12-31
Posts: 312

Re: Two packages install fine, but segfault...

Hmmm...well at least I'm not totally insane.  Thanks so much for checking into it, sarah31.  smile

Offline

Board footer

Powered by FluxBB