You are not logged in.

#1 2020-07-19 12:49:31

Registered: 2020-07-19
Posts: 1

Very slow random boot time and other bootloaders don't work [SOLVED]

So I have been struggling to get my Thinkpad T470 booting with a new ssd on uefi. GRUB works but it can take anything between 1 or 10 minutes. Does anyone know what could cause this problem?

In general, I have not been able to get systemd-boot, EFISTUB, or rEFInd to work (though I don't really know what I'm doing with rEFInd). I did manage to get systemd-boot to work after a firmware update but it's stopped working again... These bootloaders all load their menus properly but when a boot option is selected they tend to hang for a long time on a blank screen and then the laptop restarts. Ideally I would like to get a minimal bootloader like systemd-boot or EFISTUB working.

My drives are set up in the following way with gpt and protective mbr:

loop0                 7:0    0 545.2M  1 loop 
sda                   8:0    0 465.8G  0 disk 
|-sda1                8:1    0   300M  0 part /boot
`-sda2                8:2    0 465.5G  0 part 
  |-vgroup0-lv_root 254:0    0    50G  0 lvm  /
  `-vgroup0-lv_home 254:1    0   200G  0 lvm  /home

/dev/sda1 is an EFI partition.

In the case of systemd-boot my configuration files are setup as follows.


default arch
timeout 4


title Archlinux
linux /vmlinuz-linux
initrd /intel-ucode.img
initrd /initramfs-linux.img
options root=/dev/mapper/vgroup0-lv_root rw

Before anyone posts a link to Improving performance/Boot process I have already gone through this several times.

Please do ask for any extra information/terminal output you want smile thank you. Also first time posting on this forum big_smile

EDIT: The archiso removable media boots perfectly fine so It should be possible to get this to work properly. Also I am definitely booted in efi mode

SOLVED: On closer inspection of my Samsung 860 evo SSD it seemed to be accumulating a lot of CRC errors. Presumably this was a problem with the cable (or the Samsung's pickiness over cables) since the Samsung worked fine over USB3. So I bought a new nvme drive since I have the original nvme caddy and cable for the laptop. Now it works perfectly fine booting with EFISTUB. For thinkpad t470 it looks like the kernel image must be given the .efi file extension for the firmware to recognise it and load it ("vmlinuz-linux.efi").

Last edited by mhilton2013 (2020-08-05 10:40:20)


Board footer

Powered by FluxBB