You are not logged in.

#1 2020-07-20 21:04:49

Attius_Sullivan
Member
Registered: 2019-11-02
Posts: 42

[solved] Enable tap to click for a libinput touchpad

Hi,

I'm having the following problem:
When I just ceate the file

/etc/X11/xorg.conf.d/50-libinput.conf

and put

Section "InputClass"
        Identifier "SynPS/2 Synaptics TouchPad"
                MatchIsTouchpad "on"
        Driver "libinput"
        Option "Tapping" "on"
                Option "libinput Tapping Enabled" 1
EndSection

tapping isn't enabled when starting. But if I run this command `xinput set-prop "SynPS/2 Synaptics TouchPad" "libinput Tapping Enabled" 1` tapping works just fine.

Can anyone tell me what is wrong with my xorg.conf file?

Last edited by Attius_Sullivan (2020-07-20 21:40:08)

Offline

#2 2020-07-20 21:16:45

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 901

Re: [solved] Enable tap to click for a libinput touchpad

Although I can't see the issue with your conf file this is what I used to use before I switched to plasma-wayland when the xorg conf files are not used. 

Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
        Option "Tapping" "on"
        Option "DisableWhileTyping" "on"
        Option "ScrollMethod" "edge"
EndSection

This used to work fine for me.  Also depending on the desktop you are using there may also be configuration options - such as in plasma running in xorg.


Mike C

Offline

#3 2020-07-20 21:26:47

Attius_Sullivan
Member
Registered: 2019-11-02
Posts: 42

Re: [solved] Enable tap to click for a libinput touchpad

Looks like a merge of my

/usr/share/X^^/xorg.conf.d/

and

/etc/X11/xorg.conf.d/

libinput config file to me. I'll try it.

Oh and my "DE" is bspwm (a window manager) so from this side there isn't much configuration

Offline

#4 2020-07-20 21:39:47

Attius_Sullivan
Member
Registered: 2019-11-02
Posts: 42

Re: [solved] Enable tap to click for a libinput touchpad

mcloaked wrote:

Although I can't see the issue with your conf file

Well actually there was none, the one and only problem was set umask (a bit too paranoid) so that the permissions of the file in /etc/X11/xorg.conf.d were set so that only root was allowed to read the file.

Nevertheless, thanks for your time wink

Offline

Board footer

Powered by FluxBB