You are not logged in.

#1 2020-07-22 06:50:07

ItzZed
Member
Registered: 2020-07-22
Posts: 13

iwctl and previous iso wifi-menu didn't work. wlan0 was missing.

I have an ethernet connection but it is around 3x slower than my wifi.
In the most recent iso, the following output occurs:

root@archiso ~ # iwctl
[iwd]# device list
                                                   Devices                                                   *
-------------------------------------------------------------------------------------------------
   Name          Address                         Powered          Adapter     Mode
-------------------------------------------------------------------------------------------------

[iwd]#

I usually run Windows 10 and my wifi is an pci (I believe) wifi card that looks to be this card or is like this :  https://www.dell.com/en-ca/shop/asus-pc … lsrc=aw.ds

the command :

 lspci -vnn -d 14e4: 

outputs the following.

root@archiso ~ # lspci -vnn -d 14e4:
02:00.0 Network controller [0280]: Broadom Inc. and subsidiaries BCM4352 802.11ac Wireless Network Adapter [14e4:43b1] (rev 03)
             Subsystem: ASUSTeK Computer Inc. Device [1043:85ba]
             Flags: bus master, fast devsel, latency 0, IRQ 17
             Memory at f6a00000 (64-bit, non-prefetchable) [size=32K]
             Memory at f6800000 (64-bit, non-prefetchable) [size=2M]
             Capabilities: [48] Power Managent version 3
             Capabilities: [58] MSI: Enable- Count=1.1 Maskable- 64bit+
             Capabilities: [68] Vendor Specific Information: Len=44 <?>
             Capabilities: [ac] Express Endpoint, MSI 00
             Capabilities: [100] Advanced Error Reporting
             Capabilities: [13c] Device Serial Number XX-XX-XX-XX-XX-XX-XX-XX 
             Capabilities: [150] Power Budgeting <?>
             Capabilities: [160] Virtual Channel
             Capabilities: [1b0] Latency Tolerance Reporting
             Capabilities: [220] Physical Resizable BAR
             Kernel driver in use: bcma-pci-bridge
             Kernel modules: bcma

root@archiso ~ #

Device Serial Number : Redacted In Place Of X's cuz I don't wanna post it.
(Typos may be in console please inform me if there is one and you need clarification)

Thanks for the help! I'm a new arch user and am sick of windows and wanna dual boot.

Offline

#2 2020-07-22 06:52:26

ItzZed
Member
Registered: 2020-07-22
Posts: 13

Re: iwctl and previous iso wifi-menu didn't work. wlan0 was missing.

Quick Note, let me know if you need more info.

Offline

#3 2020-07-24 01:01:21

GaKu999
Member
Registered: 2020-06-21
Posts: 126

Re: iwctl and previous iso wifi-menu didn't work. wlan0 was missing.

ItzZed wrote:

Quick Note, let me know if you need more info.

You don't need to do a bump...

Now since you are on the live iso, lets do the following:

1 - Do a clean boot.
2 - Connect to the internet through ethernet
3 - Attempt connection with iwctl
4 - Run 'systemctl restart iwd'
5 - If still no device by iwctl do: "journalctl -b |& curl -F 'f:1=<-' ix.io"

Aaaand post the link from next line so we all know what happened with your device...

Offline

#4 2020-07-24 04:02:27

ItzZed
Member
Registered: 2020-07-22
Posts: 13

Re: iwctl and previous iso wifi-menu didn't work. wlan0 was missing.

GaKu999 wrote:

1 - Do a clean boot.

How do I do a clean boot? I can't seem to find any guides to do so.
Didn't mean to bump, my bad. I'll go ahead and try the other steps with a fresh arch install.

Offline

#5 2020-07-24 04:20:58

ItzZed
Member
Registered: 2020-07-22
Posts: 13

Re: iwctl and previous iso wifi-menu didn't work. wlan0 was missing.

GaKu999 wrote:
ItzZed wrote:

Quick Note, let me know if you need more info.

You don't need to do a bump...

Now since you are on the live iso, lets do the following:

1 - Do a clean boot.
2 - Connect to the internet through ethernet
3 - Attempt connection with iwctl
4 - Run 'systemctl restart iwd'
5 - If still no device by iwctl do: "journalctl -b |& curl -F 'f:1=<-' ix.io"

Aaaand post the link from next line so we all know what happened with your device...

1. Booted into archiso
2. Ethernet usually works but didn't.
3. No devices listed and did not work
4. Didn't Work
5.

root@archiso ~ # journalctl -b |& curl -F 'f:1=<-' ix.io
curl: (6) Could not resolve host: ix.io
6 root@archiso ~ #

Offline

#6 2020-07-24 05:51:43

GaKu999
Member
Registered: 2020-06-21
Posts: 126

Re: iwctl and previous iso wifi-menu didn't work. wlan0 was missing.

ItzZed wrote:
GaKu999 wrote:
ItzZed wrote:

Quick Note, let me know if you need more info.

You don't need to do a bump...

Now since you are on the live iso, lets do the following:

1 - Do a clean boot.
2 - Connect to the internet through ethernet
3 - Attempt connection with iwctl
4 - Run 'systemctl restart iwd'
5 - If still no device by iwctl do: "journalctl -b |& curl -F 'f:1=<-' ix.io"

Aaaand post the link from next line so we all know what happened with your device...

1. Booted into archiso
2. Ethernet usually works but didn't.
3. No devices listed and did not work
4. Didn't Work
5.

root@archiso ~ # journalctl -b |& curl -F 'f:1=<-' ix.io
curl: (6) Could not resolve host: ix.io
6 root@archiso ~ #

Yesh no internet at all! That's a problem...
Attempt to do journalctl -b > (YOUR LOCATION HERE) and then use a pastebin client from Windows...
That's likely the only option for posting the journal if the live iso doesn't have the firmware needed for your device(s).

Now, have you hibernated Windows? Sometimes Windows does that to the network devices, and also disable Windows Fast Boot.
Those two can be the cause...if not, them no clue at all without the journal...

Offline

#7 2020-07-24 06:10:56

ItzZed
Member
Registered: 2020-07-22
Posts: 13

Re: iwctl and previous iso wifi-menu didn't work. wlan0 was missing.

Windows is not hibernated, fast boot is off too.
Managed to get ethernet working so I used the command

journalctl -b |& curl -F 'f:1=<-' ix.io

.
Here is the output http://ix.io/2scU

edit: Quick Note -> I was installing arch using this guide and I executed the commands at 18:53. https://youtu.be/_EMFM0jPwGw?t=1133

Last edited by ItzZed (2020-07-24 06:16:25)

Offline

#8 2020-07-24 06:29:19

progandy
Member
Registered: 2012-05-17
Posts: 3,787

Re: iwctl and previous iso wifi-menu didn't work. wlan0 was missing.

BCM4352 probably needs the broadcom-wl driver.

The iso should include it, if it doesn't work maybe the iso was created just after a kernel update before brodacom-wl was rebuilt? You can compare the version number in the file paths of the broadcom package contents to the linux kernel version:

pacman -Ql broadcom-wl
pacman -Qi linux
uname -r

The driver is not automatically installed to the harddisk, you'll have to do that manually.

Last edited by progandy (2020-07-24 06:37:38)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#9 2020-07-24 06:44:44

ItzZed
Member
Registered: 2020-07-22
Posts: 13

Re: iwctl and previous iso wifi-menu didn't work. wlan0 was missing.

progandy wrote:

BCM4352 probably needs the broadcom-wl driver.
The iso should include it, if it doesn't work maybe the iso was created just after a kernel update before brodacom-wl was rebuilt? You can compare the version number in the file paths of the broadcom package contents to the linux kernel version:

pacman -Ql broadcom-wl
pacman -Qi linux
uname -r
[zachary@archbios ~]$ pacman -Ql broadcom-wl
broadcom-wl /usr/
broadcom-wl /usr/lib/
broadcom-wl /usr/lib/modprobe.d/
broadcom-wl /usr/lib/modprobe.d/broadcom-wl.conf
broadcom-wl /usr/lib/modules/
broadcom-wl /usr/lib/modules/5.7.10-arch1-1/
broadcom-wl /usr/lib/modules/5.7.10-arch1-1/extramodules/
broadcom-wl /usr/lib/modules/5.7.10-arch1-1/extramodules/wl.ko.xz
broadcom-wl /usr/share/
broadcom-wl /usr/share/licenses/
broadcom-wl /usr/share/licenses/broadcom-wl/
broadcom-wl /usr/share/licenses/broadcom-wl/LICENSE.shipped
[zachary@archbios ~]$ pacman -Qi linux
Name            : linux
Version         : 5.7.10.arch1-1
Description     : The Linux kernel and modules
Architecture    : x86_64
URL             : https://git.archlinux.org/linux.git/log/?h=v5.7.10-arch1
Licenses        : GPL2
Groups          : None
Provides        : VIRTUALBOX-GUEST-MODULES  WIREGUARD-MODULE
Depends On      : coreutils  kmod  initramfs
Optional Deps   : crda: to set the correct wireless channels of your country
                  linux-firmware: firmware images needed for some devices [installed]
Required By     : broadcom-wl
Optional For    : base
Conflicts With  : None
Replaces        : virtualbox-guest-modules-arch  wireguard-arch
Installed Size  : 75.83 MiB
Packager        : Jan Alexander Steffens (heftig) <heftig@archlinux.org>
Build Date      : Wed 22 Jul 2020 01:57:42 PM MDT
Install Date    : Fri 24 Jul 2020 12:32:43 AM MDT
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature
[zachary@archbios ~]$ uname -r
5.7.10-arch1-1

Here are the outputs.

Offline

#10 2020-07-24 06:56:46

GaKu999
Member
Registered: 2020-06-21
Posts: 126

Re: iwctl and previous iso wifi-menu didn't work. wlan0 was missing.

ItzZed wrote:

Windows is not hibernated, fast boot is off too.
Managed to get ethernet working so I used the command

journalctl -b |& curl -F 'f:1=<-' ix.io

.
Here is the output http://ix.io/2scU

edit: Quick Note -> I was installing arch using this guide and I executed the commands at 18:53. https://youtu.be/_EMFM0jPwGw?t=1133

Try to enable the broadcom-wl driver, as suggested by @progandy.
Also note that this forum does not support any other external "guides" besides the official Arch Linux Installation guide
This is a rolling release distro, any external guide is prone to be outdated...

Pruning the journal from the link...

...
Jul 23 23:51:58 archbios kernel: b43-phy0: Broadcom 4352 WLAN found (core revision 42)
Jul 23 23:51:58 archbios kernel: b43-phy0 ERROR: FOUND UNSUPPORTED PHY (Analog 12, Type 11 (AC), Revision 1)
Jul 23 23:51:58 archbios kernel: b43: probe of bcma0:1 failed with error -95
Jul 23 23:51:58 archbios kernel: Broadcom 43xx driver loaded [ Features: PNLS ]
...

Yep, it's a broadcom-wl driver issue...

Last edited by GaKu999 (2020-07-24 07:04:20)

Offline

#11 2020-07-24 08:11:37

progandy
Member
Registered: 2012-05-17
Posts: 3,787

Re: iwctl and previous iso wifi-menu didn't work. wlan0 was missing.

ItzZed wrote:

Here are the outputs.

That seems to be correct. Try to run as sudo/root:

rmmod b43
rmmod bcma
rmmod ssb
modprobe wl

This should normally be done by the file broadcom-wl.conf during boot. If you have just installed the package, then you should reboot.

Last edited by progandy (2020-07-24 08:12:34)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#12 2020-07-24 08:13:20

ItzZed
Member
Registered: 2020-07-22
Posts: 13

Re: iwctl and previous iso wifi-menu didn't work. wlan0 was missing.

Sorry for linking an unofficial guide. This has been happening with and without these guides and on multiple arch installs and iso's flashed with different tools.

I reinstalled the drivers turned them on and followed the https://wiki.archlinux.org/index.php/Br … stallation guide and I got a new device when I do "ip a" called "wlp2s0" I unplugged ethernet but no luck to this new device.

Offline

#13 2020-07-24 08:17:23

ItzZed
Member
Registered: 2020-07-22
Posts: 13

Re: iwctl and previous iso wifi-menu didn't work. wlan0 was missing.

progandy wrote:
ItzZed wrote:

Here are the outputs.

That seems to be correct. Try to run as sudo/root:

rmmod b43
rmmod bcma
rmmod ssb
modprobe wl

This should normally be done by the file broadcom-wl.conf during boot. If you have just installed the package, then you should reboot.

These commands gave the following output.

[root@archbios ~]# rmmod 43
rmmod: ERROR: Module b43 is not currently loaded
[root@archbios ~]# rmmod bcma
rmmod: ERROR: Module bcma is not currently loaded
[root@archbios ~]# rmmod ssb
rmmod: ERROR: Module ssb is not currently loaded
[root@archbios ~]# modprobe wl
[root@archbios ~]# 

Tried

ping google.com

but to no avail.

Offline

#14 2020-07-24 08:20:21

progandy
Member
Registered: 2012-05-17
Posts: 3,787

Re: iwctl and previous iso wifi-menu didn't work. wlan0 was missing.

but no luck to this new device.

Luck with what? What do you have installed for wireless connections? After you have installed the driver you need either iwd or wpa_supplicant to establish the connection. Then you will need something to negotiate the IP with DHCP.

https://wiki.archlinux.org/index.php/Ne … n/Wireless

Last edited by progandy (2020-07-24 08:21:53)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#15 2020-07-24 08:23:04

ItzZed
Member
Registered: 2020-07-22
Posts: 13

Re: iwctl and previous iso wifi-menu didn't work. wlan0 was missing.

progandy wrote:

but no luck to this new device.

Luck with what? What do you have installed for wireless connections?

https://wiki.archlinux.org/index.php/Ne … n/Wireless

By luck I meant I was hoping that this new device that appeared would give me a signal/work.

How do I check for what I have installed? (Sorry this is my first time with arch)

Offline

#16 2020-07-24 08:31:54

ItzZed
Member
Registered: 2020-07-22
Posts: 13

Re: iwctl and previous iso wifi-menu didn't work. wlan0 was missing.

Ok, so I got wlan0 in "ip a" after doing iwctl, which gave me a waiting for it to start thingy. So I googled and used "systemctl is-enabled iwd" (it wasn't) then "systemctl enable iwd", then "iwctl" and I FINALLY GOT IT TO SHOW UP.

I connected to my wifi but it wouldn't work.

(I'll edit this with some more info in just a sec.)

Offline

#17 2020-07-24 08:34:50

progandy
Member
Registered: 2012-05-17
Posts: 3,787

Re: iwctl and previous iso wifi-menu didn't work. wlan0 was missing.

After that you'll need dhcp. Either enable the one in iwd or if you need more control use an external dhcp client.

https://wiki.archlinux.org/index.php/Iw … figuration
https://wiki.archlinux.org/index.php/Ne … ation#DHCP
or https://wiki.archlinux.org/index.php/Sy … ss_adapter (wlan0 is you device name)

Alternatively networkmanager is an option with a GUI and can be configured to use iwd.

Last edited by progandy (2020-07-24 08:39:06)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#18 2020-07-24 08:53:51

ItzZed
Member
Registered: 2020-07-22
Posts: 13

Re: iwctl and previous iso wifi-menu didn't work. wlan0 was missing.

progandy wrote:

After that you'll need dhcp. Either enable the one in iwd or if you need more control use an external dhcp client.

https://wiki.archlinux.org/index.php/Iw … figuration
https://wiki.archlinux.org/index.php/Ne … ation#DHCP
or https://wiki.archlinux.org/index.php/Sy … ss_adapter (wlan0 is you device name)

Alternatively networkmanager is an option with a GUI and can be configured to use iwd.

I went ahead and enabled the one in iwd, I also got dhcp installed with the Systemd option. I'll restart it and I'll inform you if it works.

Edit: Still doesn't work., sorry I'm not sure how to describe these errors. If any

[root@archbios ~]# ping -I wlan0 google.com
ping: google.com: Temporary failure in name resolution
[root@archbios ~]# 

Last edited by ItzZed (2020-07-24 08:58:30)

Offline

#19 2020-07-24 14:08:07

GaKu999
Member
Registered: 2020-06-21
Posts: 126

Re: iwctl and previous iso wifi-menu didn't work. wlan0 was missing.

ItzZed wrote:
progandy wrote:

After that you'll need dhcp. Either enable the one in iwd or if you need more control use an external dhcp client.

https://wiki.archlinux.org/index.php/Iw … figuration
https://wiki.archlinux.org/index.php/Ne … ation#DHCP
or https://wiki.archlinux.org/index.php/Sy … ss_adapter (wlan0 is you device name)

Alternatively networkmanager is an option with a GUI and can be configured to use iwd.

I went ahead and enabled the one in iwd, I also got dhcp installed with the Systemd option. I'll restart it and I'll inform you if it works.

Edit: Still doesn't work., sorry I'm not sure how to describe these errors. If any

[root@archbios ~]# ping -I wlan0 google.com
ping: google.com: Temporary failure in name resolution
[root@archbios ~]# 


Now, your journal shows that you have NetworkManager installed and enabled...at this point 3/4 of the mods would tell you that the "guide" ended with a broken system...
Run 'systemctl disable --now NetworkManager', don't have two different networking tools coexisting because that causes issues...
Or you can follow @progrady and use NetworkManager instead of IWD...
And post 'systemctl status'.

If the previous didn't already fix the issue and you choose IWD:
Add the output of 'ip a l'.
If there's ipv4 add 'ping -I wlan0 8.8.8.8'
For the sake of post health, post YOUR modifications to '/etc/iwd/main.conf' to enable IWD built in DHCP client..

If that's not the problem, you have a DNS issue, run 'cat /etc/resolv.conf', IWD should have filled that file with your router/internet source with the respective DNS configuration, if not, then something is wrong.
IWD by default uses systemd for DNS, while it's not mandatory, follow the instructions here

dhcp? dhcpcd is the one, probably typo, and you also have systemd-networkd built-in...
Chose the one that you feel more comfortable with...and then you don't need the others (except systemd-networkd, it will stick in your system)

Last edited by GaKu999 (2020-07-24 14:50:20)

Offline

#20 2020-07-24 20:18:10

ItzZed
Member
Registered: 2020-07-22
Posts: 13

Re: iwctl and previous iso wifi-menu didn't work. wlan0 was missing.

GaKu999 wrote:
ItzZed wrote:
progandy wrote:

After that you'll need dhcp. Either enable the one in iwd or if you need more control use an external dhcp client.

https://wiki.archlinux.org/index.php/Iw … figuration
https://wiki.archlinux.org/index.php/Ne … ation#DHCP
or https://wiki.archlinux.org/index.php/Sy … ss_adapter (wlan0 is you device name)

Alternatively networkmanager is an option with a GUI and can be configured to use iwd.

I went ahead and enabled the one in iwd, I also got dhcp installed with the Systemd option. I'll restart it and I'll inform you if it works.

Edit: Still doesn't work., sorry I'm not sure how to describe these errors. If any

[root@archbios ~]# ping -I wlan0 google.com
ping: google.com: Temporary failure in name resolution
[root@archbios ~]# 


Now, your journal shows that you have NetworkManager installed and enabled...at this point 3/4 of the mods would tell you that the "guide" ended with a broken system...
Run 'systemctl disable --now NetworkManager', don't have two different networking tools coexisting because that causes issues...
Or you can follow @progrady and use NetworkManager instead of IWD...
And post 'systemctl status'.

If the previous didn't already fix the issue and you choose IWD:
Add the output of 'ip a l'.
If there's ipv4 add 'ping -I wlan0 8.8.8.8'
For the sake of post health, post YOUR modifications to '/etc/iwd/main.conf' to enable IWD built in DHCP client..

If that's not the problem, you have a DNS issue, run 'cat /etc/resolv.conf', IWD should have filled that file with your router/internet source with the respective DNS configuration, if not, then something is wrong.
IWD by default uses systemd for DNS, while it's not mandatory, follow the instructions here

dhcp? dhcpcd is the one, probably typo, and you also have systemd-networkd built-in...
Chose the one that you feel more comfortable with...and then you don't need the others (except systemd-networkd, it will stick in your system)

There is no ipv4 in 'ip a I'
Sorry this is super confusing but Im going to use IWD, I disabled network manager too.

Offline

#21 2020-07-24 21:03:58

GaKu999
Member
Registered: 2020-06-21
Posts: 126

Re: iwctl and previous iso wifi-menu didn't work. wlan0 was missing.

ItzZed wrote:
GaKu999 wrote:
ItzZed wrote:

I went ahead and enabled the one in iwd, I also got dhcp installed with the Systemd option. I'll restart it and I'll inform you if it works.

Edit: Still doesn't work., sorry I'm not sure how to describe these errors. If any

[root@archbios ~]# ping -I wlan0 google.com
ping: google.com: Temporary failure in name resolution
[root@archbios ~]# 


Now, your journal shows that you have NetworkManager installed and enabled...at this point 3/4 of the mods would tell you that the "guide" ended with a broken system...
Run 'systemctl disable --now NetworkManager', don't have two different networking tools coexisting because that causes issues...
Or you can follow @progrady and use NetworkManager instead of IWD...
And post 'systemctl status'.

If the previous didn't already fix the issue and you choose IWD:
Add the output of 'ip a l'.
If there's ipv4 add 'ping -I wlan0 8.8.8.8'
For the sake of post health, post YOUR modifications to '/etc/iwd/main.conf' to enable IWD built in DHCP client..

If that's not the problem, you have a DNS issue, run 'cat /etc/resolv.conf', IWD should have filled that file with your router/internet source with the respective DNS configuration, if not, then something is wrong.
IWD by default uses systemd for DNS, while it's not mandatory, follow the instructions here

dhcp? dhcpcd is the one, probably typo, and you also have systemd-networkd built-in...
Chose the one that you feel more comfortable with...and then you don't need the others (except systemd-networkd, it will stick in your system)

There is no ipv4 in 'ip a I'
Sorry this is super confusing but Im going to use IWD, I disabled network manager too.

I meant an ipv4 address, like 192.168.1.2 for example, anyways that’s the right call I guess.

If your issue is solved and you can use NetworkManager without problems remember to edit your first post and add [SOLVED] to the tittle.

Offline

#22 2020-07-24 21:07:21

ItzZed
Member
Registered: 2020-07-22
Posts: 13

Re: iwctl and previous iso wifi-menu didn't work. wlan0 was missing.

Not solved. I dont have an ipv4 address only ipv6.

Offline

#23 2020-07-24 21:26:04

GaKu999
Member
Registered: 2020-06-21
Posts: 126

Re: iwctl and previous iso wifi-menu didn't work. wlan0 was missing.

ItzZed wrote:

Not solved. I dont have an ipv4 address only ipv6.

Post the output of ‘ip a l’, and ‘systemctl status’

Now did you follow the instructions at the wiki for NetworkManager?

Remember don’t leave two different network managers running, make sure you have NetworkManager or IWD, not both, also don’t leave dhcpcd enabled as well...

Just to make sure we are on the same page, run:

systemctl disable —now NetworkManager iwd dhcpcd systemd-networkd systemd-resolved

Reboot and then follow the wiki...

Last edited by GaKu999 (2020-07-24 21:28:58)

Offline

Board footer

Powered by FluxBB