You are not logged in.

#1 2020-07-30 07:50:00

omniscient_potato
Member
Registered: 2020-07-12
Posts: 9

Deep sleep not possible on XPS15 9500

Hey,

I recently installed Arch with xmonad on my XPS15, I'm still a newbie, so still figuring everything out.
I can normally suspend the laptop, and that works perfectly fine, but I'm noticing significant battery loss over time, about 30-40 percent during a period of 12 hours.
I'm not perfectly familiar to the suspend-then-hibernate thing, and I haven't found much info on this, so what I tried is the deep sleep mode.
Suspending then still works and looking at journalctl shows that it suspends everything correctly, but when I turn the laptop on again, it does not go past the boot logo and the fans turn on after a couple of seconds.
I've tried some kernel parameters, since it has a dedicated graphics card, which I'm usually disabling with bbswitch and bumblebee, but to no avail. Maybe some of you have encountered this issue.

Thanks in advance!

Offline

#2 2020-08-03 14:59:10

denbot
Member
Registered: 2020-06-27
Posts: 5

Re: Deep sleep not possible on XPS15 9500

I'm having similar problems on the XPS 17 9700 using the grub kernel parameter mem_sleep_default=deep.

I also did the following:
- Turned off TPM, SGX, SMM and Absolute security settings in the BIOS.
- Enabled the power on lid setting in BIOS
- Disabled early sign of life in BIOS

Deep sleep only seems to work if I boot up the laptop while connected to a power source.

If I boot up the laptop disconnected from power / running on battery and then run systemctl suspend, the following happens:
- screen immediately turns blank
- keyboard back-light remains on, pressing any key will light the keyboard back-light up (this shouldn't be happening, it should be completely off)
- pressing power button has no effect, does not wake laptop
- have to hold power button for 10 seconds to force shutdown

I checked the dmesg/journalctl log of the previous boot (wgere s3 deep sleep froze my system) and couldn't see any errors:

Aug 03 14:51:17 fatpug kernel: sof-audio-pci 0000:00:1f.3: ipc tx succeeded: 0x40020000
Aug 03 14:51:21 fatpug systemd-sleep[2050]: Suspending system...
Aug 03 14:51:21 fatpug kernel: PM: suspend entry (deep)

Relevant laptop specs:
- Intel 10th Gen i7-10875H
- NVIDIA RTX 2060 GPU

I spoke with some others regarding this issue and it seems a user with only integrated graphics on the XPS 17 seems to have working s3 deep sleep on battery with the above steps. Perhaps the issue i'm having is related to the nvidia dGPU?

I hope some of this information helps you OP, I am looking for a proper solution myself and would be happy to help if possible.

Last edited by denbot (2020-08-03 15:02:47)

Offline

#3 2020-08-05 16:00:10

CaeZaR
Member
Registered: 2020-01-23
Posts: 1

Re: Deep sleep not possible on XPS15 9500

I have the same setup with the same issue. If running of battery, suspend does not function properly.

Offline

#4 2020-08-09 09:59:13

omniscient_potato
Member
Registered: 2020-07-12
Posts: 9

Re: Deep sleep not possible on XPS15 9500

denbot wrote:

I'm having similar problems on the XPS 17 9700 using the grub kernel parameter mem_sleep_default=deep.

I also did the following:
- Turned off TPM, SGX, SMM and Absolute security settings in the BIOS.
- Enabled the power on lid setting in BIOS
- Disabled early sign of life in BIOS

Deep sleep only seems to work if I boot up the laptop while connected to a power source.

If I boot up the laptop disconnected from power / running on battery and then run systemctl suspend, the following happens:
- screen immediately turns blank
- keyboard back-light remains on, pressing any key will light the keyboard back-light up (this shouldn't be happening, it should be completely off)
- pressing power button has no effect, does not wake laptop
- have to hold power button for 10 seconds to force shutdown

I checked the dmesg/journalctl log of the previous boot (wgere s3 deep sleep froze my system) and couldn't see any errors:

Aug 03 14:51:17 fatpug kernel: sof-audio-pci 0000:00:1f.3: ipc tx succeeded: 0x40020000
Aug 03 14:51:21 fatpug systemd-sleep[2050]: Suspending system...
Aug 03 14:51:21 fatpug kernel: PM: suspend entry (deep)

Relevant laptop specs:
- Intel 10th Gen i7-10875H
- NVIDIA RTX 2060 GPU

I spoke with some others regarding this issue and it seems a user with only integrated graphics on the XPS 17 seems to have working s3 deep sleep on battery with the above steps. Perhaps the issue i'm having is related to the nvidia dGPU?

I hope some of this information helps you OP, I am looking for a proper solution myself and would be happy to help if possible.

I tried your suggestions, but unfortunately, none of them fixed the problem. I found somebody else having the same problem on reddit, but they haven't found a solutions there either, could be a hardware problem....

Offline

#5 2020-08-10 18:47:49

angelo2020
Member
Registered: 2020-08-10
Posts: 1

Re: Deep sleep not possible on XPS15 9500

I am having the same problem I change my graphics card which trigerred the issue. Now I am trying to resolve it on the new graphics card.


I will be the greatest geame ron earth.

Offline

Board footer

Powered by FluxBB