You are not logged in.

#1 2020-07-16 01:14:02

Raymo111
Member
Registered: 2019-08-27
Posts: 23

Kwin compositing issues

Every time I wake from sleep, kwin compositing crashes. I've tried changing ~/.config/kwinrc, as well as changing settings in the compositor window of systemsettings5, but nothing works. Here are my compositor settings:

[$Version]
update_info=kwin.upd:replace-scalein-with-scale,kwin.upd:port-minimizeanimation-effect-to-js,kwin.upd:port-scale-effect-to-js,kwin.upd:port-dimscreen-effect-to-js,kwin.upd:auto-bordersize,kwin.upd:animation-speed

[Compositing]
GLCore=true
GLPreferBufferSwap=0
GLTextureFilter=0
HiddenPreviews=5
OpenGLIsUnsafe=false
WindowsBlockCompositing=false
XRenderSmoothScale=false

[Desktops]
...

When I try doing pkill kwin_x11 && kwin_x11 &, here's what happens:

qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 180, resource id: 14680074, major code: 20 (GetProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 181, resource id: 14680074, major code: 20 (GetProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 5 (BadAtom), sequence: 2061, resource id: 0, major code: 20 (GetProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 5 (BadAtom), sequence: 2114, resource id: 0, major code: 20 (GetProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 5 (BadAtom), sequence: 2142, resource id: 0, major code: 20 (GetProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 2316, resource id: 14680104, major code: 18 (ChangeProperty), minor code: 0
QGLXContext: Failed to create dummy context
No provider of glXCreateContextAttribsARB found.  Requires one of:
    GLX_ARB_create_context
Application::crashHandler() called with signal 6; recent crashes: 1
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = kwin_x11 path = /usr/bin pid = 20315
KCrash: Arguments: /usr/bin/kwin_x11 
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 180, resource id: 14680074, major code: 20 (GetProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 181, resource id: 14680074, major code: 20 (GetProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 5 (BadAtom), sequence: 2044, resource id: 0, major code: 20 (GetProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 5 (BadAtom), sequence: 2097, resource id: 0, major code: 20 (GetProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 5 (BadAtom), sequence: 2125, resource id: 0, major code: 20 (GetProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 2289, resource id: 14680102, major code: 18 (ChangeProperty), minor code: 0
kwin_core: Compositing is not possible
/bin/bash: line 1: 20315 Aborted                 (core dumped) kwin_x11

Note that as soon as that happens, the config file's openGLIsUnsafe gets set to true. Also, upon restart everything is good as new. I'm on an HP Envy with dual Intel/Nvidia graphics. glxgears works fine. GPU mode is set to Nvidia through optimus-manager. It's a nightmare.

Last edited by Raymo111 (2020-07-16 01:20:25)

Offline

#2 2020-07-16 11:37:57

d_fajardo
Member
Registered: 2017-07-28
Posts: 800

Re: Kwin compositing issues

I am experiencing the same problem. That thread was initially for freezes but should also include compositor crashing. It looks like related to nvidia 450 but so this might be related to optimus as well. I can confirm it has to do with nvidia this because downgrading the driver makes everything work fine.
My question is, are you also getting freezes when you leave the computer to auto screen lock? How are you starting KDE?

Online

#3 2020-07-16 14:22:29

Raymo111
Member
Registered: 2019-08-27
Posts: 23

Re: Kwin compositing issues

I get both your problems, although slightly differently (probably because we're on different gpus) (I'm on an Mx150.) I feel like this is indeed an nVidia problem. For your other problem, see if this helps: https://superuser.com/questions/1564895 … to-dolphin

Offline

#4 2020-07-16 18:27:25

d_fajardo
Member
Registered: 2017-07-28
Posts: 800

Re: Kwin compositing issues

upower seems ok in my system. Besides it's a desktop so I don't have issues with batteries and the like.
Are you using sddm? I'm just trying to see if it could be sddm.

Online

#5 2020-07-16 18:30:22

Raymo111
Member
Registered: 2019-08-27
Posts: 23

Re: Kwin compositing issues

I am using SDDM. But it has no issues. I have another issue that my network shuts down and the kde nm and ip a command freeze quite often, out of the blue. I'm plugged in to Ethernet through a USB-C adapter. Also my system clock seems to randomly jump as well. Everything with my system just seems a little off.

Offline

#6 2020-07-30 07:42:46

jeremija
Member
Registered: 2016-10-09
Posts: 5

Re: Kwin compositing issues

I'm getting the same issue as OP on a ThinkPad X1 Extreme Gen 1. Running Nvidia drivers only (no optimus) because I have external monitors.

Also lockscreen is sometimes all black and the only way to unlock it is to blindly enter the password.

I'm running KDE from tty via `startx` (no display manager).

Last edited by jeremija (2020-07-30 07:44:51)

Offline

#7 2020-07-30 10:35:54

d_fajardo
Member
Registered: 2017-07-28
Posts: 800

Re: Kwin compositing issues

@jeremija You can file a bug report to nvidia which I have done. This is definitely a 450 version problem. I think the more noise we make the more we'll likely be heard.
1. Run this in terminal:
sudo nvidia-bug-report.sh
This will create nvidia-bug-report.log.gz file
2. Send this file and how to reproduce issue to this email: linux-bugs [ at ] nvidia [ dot ] com

Online

Board footer

Powered by FluxBB