You are not logged in.

#1 2020-07-31 23:25:02

tony5429
Member
Registered: 2006-03-28
Posts: 980

[SOLVED] Build of Arch ISO Failing

Using the instructions on the wiki (see https://wiki.archlinux.org/index.php/archiso), I think I should be able to build the Arch ISO on my own with:

cp -r /usr/share/archiso/configs/releng archlive
cd archlive
./build.sh -v

However, when I try using the commands above, the end of the output is as follows and no iso file is created:

==> Generating module dependencies
==> Creating xz-compressed initcpio image: /boot/archiso.img
==> Image generation successful

[mkarchiso] INFO: Configuration settings
[mkarchiso] INFO:                   Command:   run
[mkarchiso] INFO:              Architecture:   x86_64
[mkarchiso] INFO:         Working directory:   work/x86_64
[mkarchiso] INFO:    Installation directory:   arch
[mkarchiso] INFO:               Run command:   /root/customize_airootfs.sh

==> WARNING: work/x86_64/airootfs is not a mountpoint. This may have undesirable side effects.
Generating locales...
  en_US.UTF-8... done
Generation complete.
passwd: password expiry information changed.
cp: cannot stat 'work/x86_64/airootfs/usr/share/licenses/amd-ucode/LICENSE': No such file or directory

Any ideas?

Last edited by tony5429 (2020-08-01 02:52:29)

Offline

#2 2020-07-31 23:29:49

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,025
Website

Re: [SOLVED] Build of Arch ISO Failing


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#3 2020-07-31 23:34:49

qinohe
Member
From: Netherlands
Registered: 2012-06-20
Posts: 1,045

Re: [SOLVED] Build of Arch ISO Failing

Yes, JWR is right. However, you mention you copied the profile, there was an update for archiso, today...

Offline

#4 2020-08-01 02:52:15

tony5429
Member
Registered: 2006-03-28
Posts: 980

Re: [SOLVED] Build of Arch ISO Failing

Ah; updating archiso solved the problem. Thanks!

Offline

Board footer

Powered by FluxBB