You are not logged in.

#1 2020-08-01 16:18:23

whitesnow
Member
Registered: 2015-01-04
Posts: 51

Boot problem on encrypted system.

Boot problem on encrypted system.

I'm unable to boot since about last sunday. Tried to repair myself without much success.


It appeared somehow after a stopped updated, it was writing to hdd without much progess,
I thought the hdd might be broken, but now the scrub says everything fine.
And I copied it over to another hdd using the zfs tools, which I could boot from the rootfs prompt, but still not directly.

I did redo the update, maybe I should reinstall something.

I started it now in Qemu, to be able to write it down.

Loading Linux linux
Loading initial ramdisk
running early hook [udev]
Starting version 245.6-8-arch
running hook [udev]
Triggering uevents...
running hook [encrypt]
waiting 10 seconds for device /dev/disk/by/uuid/b91bf882-df26-420d-93ad-b8d0a4cd7778
running hook [zfs]
Error device ZFS=zpool-x220-2/ROOT/rootfs not found.Skipping fsck.
ZFS: Importing zpool-x220-2.
cannot import 'zpool-x220-2': no such pool or dataset
       Destroy and re-create the pool from
       a backup source.
ERROR: ZFS: Unable to import pool zpool-x220-2.
[35.670776] Kernel panic - not syncing: Attempted to kill init! exitcode=0x00000100

The

cryptdevice=PARTLABEL=Linux-system-zpool-x220-2:cryptroot-x220-2 and 
cryptdevice=/dev/disk/by-uuid/b91bf882-df26-420d-93ad-b8d0a4cd7778:cryptroot-x220-2

I tried them both, did not help.

These are about the last kernels I have.
linux-5.7.5.arch1-1
linux-5.7.9.arch1-1
linux-5.7.10.arch1-1

this is the menuentry in grub.cfg.

A bit manual and automatic configuration.

menuentry 'Arch Linux [rootfs]' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-33a6be6857683db9' {
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_gpt
        insmod ext2
        set root='hd0,gpt1'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,gpt1' --hint-bios=hd1,gpt1 --hint-efi=hd1,gpt1 --hint-baremetal=ahci1,gpt1  e2800d6e-a6c2-4059-a638-32dbd8b948
81
        else
          search --no-floppy --fs-uuid --set=root e2800d6e-a6c2-4059-a638-32dbd8b94881
        fi
        echo    'Loading Linux linux ...'
        linux   /vmlinuz-linux acpi_osi="!Windows 2012" root=/dev/mapper/cryptroot cryptdevice=PARTLABEL=Linux-system-zpool-x220-2:cryptroot zfs=zpool-x220-2/ROOT/rootfs boot=zfs root=ZFS=zpool-
x220-2/ROOT/rootfs rw acpi_osi="Linux" verbose   
        #i915.enable_guc=3 i915.enable_guc_submission=1 i915.enable_huc=1 i915.enable_psr=1 i915.disable_power_well=0 i915.enable_rc6=7 i915.enable_gvt=1 i915.enable_dc=2
        # unknown parameter i915.enable_guc_loading=1
 

        echo    'Loading initial ramdisk ...'
        initrd  /intel-ucode.img /initramfs-linux.img
}

Yes, sure it can not import the zpool, as long as the encrypted device gets not opened.
It did not ask me for the password.
I had occasions (in between the changes probably) where I got asked, but the same result.

I cloned that to another disk, on another computer with similar hardware. Tried with the usb-installer and refind.
Installed an unencrypted basic archlinux to another partition, this did not boot successfully, but at least I landed at the
rootfs prompt
with

mount: /new_root: unknown filesystem type 'ext4'

From where I could decrypt the device, import the pool and boot just fine.

Now I am writing from a hardly used install, which I did not update since February.

grep HOOKS /etc/mkinitcpio.conf
...
HOOKS=(base udev autodetect modconf block keyboard encrypt zfs filesystems fsck shutdown)

Thanks in advance.

Edit:

continuing.
Now into different but similar machine, booting with refind, at least into emergency shell.

Tried to start X. complained about missing module.
Reinstalled that Kernel 5.7.10-arch1-1 and the relevant zfs-linux module.
These modules had been missing.

Last edited by whitesnow (2020-08-01 17:20:44)

Offline

Board footer

Powered by FluxBB