You are not logged in.

#1 2006-09-07 11:40:55

cyfdecyf
Member
From: China
Registered: 2006-07-27
Posts: 4
Website

The package mkinitcpio corrupted!

I've just installed Arch on a 64bit system. I chose to install from ftp and found that the mkinitcpio in the repository is corrupted :-( The tarball can't be extracted, and I've tried several repository.

This caused me a little trouble. I had to chroot and then use abs to build the package. After that I could install the kernel. Is the package in the repository broken?

By the way, I didn't find a community repository for x86_64 system, is there any one?

Offline

#2 2006-09-07 11:52:46

Purch
Member
From: Finland
Registered: 2006-02-23
Posts: 229

Re: The package mkinitcpio corrupted!

Did you install arch32 or arch64?

For arch64, try another x86_64 repository. I did not find any problems in estonian repo. Also there is no community repository available, yet. Dev's and TU's are making the packages at the moment.

Offline

#3 2006-09-08 05:23:22

cyfdecyf
Member
From: China
Registered: 2006-07-27
Posts: 4
Website

Re: The package mkinitcpio corrupted!

I installed arch64 when I found mkinitcpio corrupted. And I found there were other packages corrupted when I tried to install xfce4.

Besides there is no community repository now, I reinstalled arch32 on the 64bit system.

ABS is greate, but it can't resolve the dependency automaticly, so I don't want to use abs to compile packages which belongs to community.

Offline

#4 2006-09-08 05:52:45

Purch
Member
From: Finland
Registered: 2006-02-23
Posts: 229

Re: The package mkinitcpio corrupted!

Did you use the latest ftp-iso? ( http://www.archlinux.org/download/ )

Offline

#5 2006-09-08 19:02:07

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,636

Re: The package mkinitcpio corrupted!

:: Retrieving packages from current...
mkinitcpio-0.5.5-1       [################] 100%      11K     6.5K/s  00:00:01

checking package integrity... done.
loading package data... done.
checking for file conflicts... done.
upgrading mkinitcpio... done.
[root@workstation64 andyrtr]#


The package is ok.

Offline

Board footer

Powered by FluxBB