You are not logged in.

#1 2020-08-24 09:06:11

Yann
Member
Registered: 2017-11-23
Posts: 197

[picom] All windows get transparent

Hi everyone,

I use arch, with i3, with picom. Everything up to date. Since 36h I all my windows get transparent (like 20% transparent).

When I save my picom config, sometimes transparency disappears for all windows, if I resave it, transparency reappears.

The end of my picom config:

opacity-rule = [
        "90:window_type = 'dock' && class_g = 'i3bar'",
        "92:class_g = 'URxvt' && !focused"
];

When I remove the line

"90:window_type = 'dock' && class_g = 'i3bar'"

transparency disappears totally, is there a problem with that line?


all different - all equal

Offline

#2 2020-08-24 09:10:12

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,747

Re: [picom] All windows get transparent

I'd assume that that line matches more than you intend, run xprop on the i3bar and other windows resulting in the issue to identify more unique identifiers/why that rule seems to match more than you intend.

Offline

#3 2020-08-24 09:21:48

Yann
Member
Registered: 2017-11-23
Posts: 197

Re: [picom] All windows get transparent

When running xprop on Brave, there is neither dock nor i3bar in the output. However, if I just remove this line everything seems to revert the last behavior.

I didn't change anything for months, I guess one package changes something. Does i3bar not need anymore to be referenced to picom to get a transparent background?


all different - all equal

Offline

#4 2020-08-25 03:41:45

heavynetol
Member
From: Ecuador
Registered: 2012-10-17
Posts: 3

Re: [picom] All windows get transparent

Hi.
I think it is a bug related to Picom, it has nothing to do with the configuration file.
I have recorded a video showing how to reproduce this bug.
https://youtu.be/mpQqR-GyFn8

# ~/.config/picom/picom.conf
unredir-if-possible	= false;

mark-ovredir-focused	= true;
active-opacity		= 0.99;
inactive-opacity	= 0.72;
frame-opacity		= 0.80;

opacity-rule = [
	"99:_NET_WM_STATE@:32a = '_NET_WM_STATE_FULLSCREEN'",
        "50:class_g  = 'Bspwm' && class_i = 'presel_feedback'",
	"99:class_g  = 'Rofi'",
	"99:class_g  = 'Polybar'",
	"99:class_g = 'vlc' && focused",
	"96:class_g  = 'vlc' && !focused",
	"91:class_g  = 'Guake'",
	"99:class_g  = 'Audacious'",
	"91:class_g = 'Terminator'",
	"91:class_g =  'Lxterminal'"
];

Regards!

Last edited by heavynetol (2020-08-25 03:46:01)

Offline

#5 2020-08-25 10:00:22

Yann
Member
Registered: 2017-11-23
Posts: 197

Re: [picom] All windows get transparent

Indeed, I did get this random behavior. Once on 4, transparency is normal, but the others attempts made all the windows transparent.
However, it seems true that removing the line "90:window_type = 'dock' && class_g = 'i3bar'" in my conf file removed totally this buggy behavior.
Also, picom did not get updated since the 8th of august 2020 (17 days ago), and I did not change the conf file. So, I guess the issue comes from dependencies.


all different - all equal

Offline

#6 2020-08-25 10:26:18

aitbits
Member
Registered: 2018-02-19
Posts: 1

Re: [picom] All windows get transparent

I have two systems with picom installed, and they share exact same config. I see this bug on a system with Radeon graphics, but a system with intel igpu has no problem.

EDIT: Well, nevermind. I'm seeing same thing on my intel machine after rebooting.

EDIT2: This issue sounds relevant to me. https://github.com/yshui/picom/issues/470

Last edited by aitbits (2020-08-25 10:39:56)

Offline

#7 2020-08-25 11:45:46

Yann
Member
Registered: 2017-11-23
Posts: 197

Re: [picom] All windows get transparent

Are your system up to date? I guess, to make progress, we should find the dependencies causing the change?

After checking the last updates. Any of them are directly related to picom. So, I guess it might be a more abstract dependency.

Last edited by Yann (2020-08-25 11:51:52)


all different - all equal

Offline

#8 2020-08-25 15:28:22

code2501
Member
Registered: 2019-03-10
Posts: 2

Re: [picom] All windows get transparent

I have the same problem. I found the problematic dependency in the updated package through binary search, which is glibc(maybe also libxcrypt)

Offline

#9 2020-08-25 18:29:26

Yann
Member
Registered: 2017-11-23
Posts: 197

Re: [picom] All windows get transparent

They are not in the direct dependencies of picom, but, as I said, I think the issue is caused by a deeper dependency.
I updated both of them the day before of the first apparition of the problem. So, could be..


all different - all equal

Offline

#10 2020-08-27 18:19:50

caellian
Member
Registered: 2020-08-27
Posts: 1

Re: [picom] All windows get transparent

Had the same issue with bspwm this morning (haven't done a system-wide update in a while). Whichever settings (shadows as reported in the issue or transparency) are applied to the WM get applied recursively to all windows "owned"/displayed by the WM because '&&' doesn't work properly as mentioned in the issue.

Disabling whichever setting specifies class_g of the wm seems to be a temporary fix for this problem.

In my case it was:

opacity-rule = [ "10:class_g = 'Bspwm' && class_i = 'presel_feedback'" ];

From skimming at the code, the issue seems to be with libconfig, not picom itself.

At least I don't need to replace my laptop display. smile

EDIT:
Downgrading libconfig from 1.7.2-3 to 1.7.2-2 seems to have fixed the issue for me.

Last edited by caellian (2020-08-27 18:25:57)

Offline

#11 2020-08-27 19:39:40

Qwerty-Space
Member
Registered: 2020-03-13
Posts: 7

Re: [picom] All windows get transparent

This JUST started happening to me, and I am using compton-tryone-git, which hasn't been updated in quite a while.  However xorg did just update, so maybe that caused it?

Edit:  Simply reopening the affected windows seemed to fix it, I think?

Last edited by Qwerty-Space (2020-08-27 19:46:02)

Offline

#12 2020-08-27 21:08:01

Yann
Member
Registered: 2017-11-23
Posts: 197

Re: [picom] All windows get transparent

I think the problem we were talking about is not a question of just reopening the windows. But, if it's really your case, could be good to confirm it.
Also, if it reappears, could you try downgrading xorg? So far, it seems that the responsible packages are either glibc, libxcrypt or libconfig.


all different - all equal

Offline

#13 2020-08-28 09:50:40

Qwerty-Space
Member
Registered: 2020-03-13
Posts: 7

Re: [picom] All windows get transparent

It happened again today, and it only worked after restarting compton and then reopening windows.  But reopening them immediately didn't work, I had to wait a bit.

I might try downgrading xorg later, but I am a bit busy today

Offline

#14 2020-08-29 18:07:44

rharish
Member
Registered: 2018-02-19
Posts: 16

Re: [picom] All windows get transparent

The latest updates to the next branch of picom fix these issues. Try it out with the picom-git AUR package.

Offline

#15 2020-09-06 16:22:48

Phydoux
Member
Registered: 2020-03-02
Posts: 30

Re: [picom] All windows get transparent

My issue is similar with Doom Emacs. But if I do an Alt-x doom/set-frame-opacity and type in 100. it's all good. But I have to do this every time I start Emacs now. I get the same results if I kill picom and load compton. But when I kill compton the opacity goes away. Must be an xorg thing or something.

Last edited by Phydoux (2020-09-06 16:31:56)

Offline

#16 2020-09-10 20:48:20

GOKOP
Member
Registered: 2018-04-29
Posts: 44

Re: [picom] All windows get transparent

I still experience this issue with picom-git

Offline

#17 2020-09-10 21:07:09

rharish
Member
Registered: 2018-02-19
Posts: 16

Re: [picom] All windows get transparent

GOKOP wrote:

I still experience this issue with picom-git

In that case, please post on the issue at https://github.com/yshui/picom/issues/470. If your problem is different, then you should open a new issue upstream.

Offline

#18 2020-09-30 15:27:46

korikori
Member
Registered: 2020-09-30
Posts: 1

Re: [picom] All windows get transparent

I've had this issue for a few weeks now. After spending this afternoon on finally solving it, I found the following comment (https://github.com/yshui/picom/issues/4 … -691024627):

I've had the same issue, it seems the arch maintainers changed the default config file which ships with the package in archlinux/svntogit-community@1bad31a#diff-8d0411b338c83cd8cd8ad9d9db127101 , which enabled transparency along with some other settings.

So in order to solve this, I changed my basic autostart line from:

picom -bcCGfF -o 0.38 -O 200 -I 200 -t 0 -l 0 -r 3 -D2 -m 0.88&

to:

picom -bcCGfF -o 0.38 -O 200 -I 200 -t 0 -l 0 -r 3 -D2 -m 0.88 --config /dev/null &

Last edited by korikori (2020-09-30 15:29:17)

Offline

Board footer

Powered by FluxBB