You are not logged in.

#26 2020-08-11 07:41:52

progandy
Member
Registered: 2012-05-17
Posts: 3,824

Re: Installation failed on Virtualbox: PGP errors when running pacstrap

Maybe it is possible to keep hyper-v enabled, but change some settings for libgrypt not to use some hardware features with /etc/gcrypt/hwf.deny

https://www.gnupg.org/documentation/man … tures.html


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#27 2020-08-12 05:24:20

geofft
Member
Registered: 2020-08-12
Posts: 1

Re: Installation failed on Virtualbox: PGP errors when running pacstrap

I ran into this same problem running inside hardware-accelerated-QEMU on macOS (-accel hvf), where I was previously having trouble with rdtsc (and had to specify "-cpu host,-rdtscp" to get the system to boot at all).

I noticed that dmesg contained a complaint about the clocksource being unstable and needing to switch to hpet. Rebooting with clocksource=hpet fixed it and I'm able to verify signatures now. I wonder if that will work for Hyper-V too.

Offline

#28 2020-08-28 05:38:33

scorpion50
Member
Registered: 2020-08-28
Posts: 1

Re: Installation failed on Virtualbox: PGP errors when running pacstrap

I am currently facing the same issue installing on Virtualbox 6.1.12 with Hyper-V enabled. I cannot disable Hyper-V and downgrade virtualbox because I am currently using WSL2, which requires support for Hyper-V.

I have tried every other solution for invalid pgp keys I could find but none of them work. I was able to get into a usable arch linux installation by disabling pgp checking, but this can not be a permanent solution and the issue is still very irritating.

Offline

#29 2020-08-29 21:44:49

ViggoGaming
Member
Registered: 2020-08-29
Posts: 1

Re: Installation failed on Virtualbox: PGP errors when running pacstrap

I have the exact same problem. Windows 10 Pro and Virtual box. Is there any fix for it yet?

Offline

Board footer

Powered by FluxBB