You are not logged in.

#1 2020-09-03 00:20:19

blu4lyf
Member
Registered: 2020-07-27
Posts: 3

PCGEN Install Fails

Attempts to install PCGEN from AUR results in the following error.

Gradle could not start your build.
> Could not initialize native services.
   > Failed to load native library 'libnative-platform.so' for Linux amd64.

Any suggestions on how I debug this? Thanks.

Offline

#2 2020-09-03 11:07:28

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 8,470

Re: PCGEN Install Fails

You are trying to build https://aur.archlinux.org/packages/pcgen-git ?

Please post the output of

$ archlinux-java status
$ pacman -Qg base-devel .

When was your last pacman -Syu ?

Are you familiar with https://wiki.archlinux.org/index.php/Ar … Repository , https://wiki.archlinux.org/index.php/PKGBUILD , https://wiki.archlinux.org/index.php/Makepkg ?


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2020-09-03 11:35:44

blu4lyf
Member
Registered: 2020-07-27
Posts: 3

Re: PCGEN Install Fails

To clarify, yes I'm attempting to install pcgen-git from AUR using PIKAUR.

It had been a couple of days since I had updated. So I updated this morning and reattempted the install from AUR and received the same error.

archlinux-java status
Available Java environments:
  java-11-openjdk (default)
pacman -Qg base-devel 
base-devel autoconf
base-devel automake
base-devel binutils
base-devel bison
base-devel fakeroot
base-devel file
base-devel findutils
base-devel flex
base-devel gawk
base-devel gcc
base-devel gettext
base-devel grep
base-devel groff
base-devel gzip
base-devel libtool
base-devel m4
base-devel make
base-devel pacman
base-devel patch
base-devel pkgconf
base-devel sed
base-devel sudo
base-devel texinfo
base-devel which

I'll take a look through the links that you provided.

Last edited by blu4lyf (2020-09-03 11:36:31)

Offline

#4 2020-09-03 12:34:17

blu4lyf
Member
Registered: 2020-07-27
Posts: 3

Re: PCGEN Install Fails

Just realized that I don't need the AUR install for this. I can run it directly from the command line. Sorry for disturbing anyone.

Offline

Board footer

Powered by FluxBB