You are not logged in.

#1 2020-09-03 21:00:54

shoelesshunter
Member
Registered: 2014-05-18
Posts: 52

conky manager not setting themes

I am entirely new to conky. I have installed conky-manager. I have installed themes. When I select widgets in the manager window, the running default conky does not change. When I select entirely new themes (any theme) from the manager, conky crashes completely. Under both circumstances, the output references;

attempt to call a nil value (global 'loadstring')

Am I missing some key lesson here in the setup process?

I am using i3-gaps with compton.

conky 1.11.5.

Offline

#2 2020-09-04 08:28:16

d_fajardo
Member
Registered: 2017-07-28
Posts: 937

Re: conky manager not setting themes

I have installed conky-manager.

Which conky manager are you talking about?
Have you tried running the scripts manually?

Offline

#3 2020-09-04 10:12:14

kermit63
Member
Registered: 2018-07-04
Posts: 30

Re: conky manager not setting themes

The default sample themes provided by conky-manager is still in the old config format. Previous versions of conky used to be able to automatically translate old configs into new configs before running, but the current version of conky can not.

The solution is to convert the old config files into the new format, either by editing manually or by using translators available on the internet (github, I think), but you have search for it since I have zero experience with these translators.

Offline

#4 2020-09-04 10:58:42

d_fajardo
Member
Registered: 2017-07-28
Posts: 937

Re: conky manager not setting themes

The solution is to convert the old config files into the new format

I tried the translators before but didn't work very well. Doing it by hand is not much work really, and it helps to understand the new syntax as well.

Offline

#5 2020-09-04 12:28:59

robson75
Member
From: Poland
Registered: 2020-06-28
Posts: 9

Re: conky manager not setting themes

The new syntax of conky 1.10 is not displayed in the conky-manager, to convert to the new syntax you just need to

cp /usr/share/doc/conky-1.11.5_pre/convert.lua ~/
chmod +x ~/convert.lua
./convert.lua ~/.conky/Gotham/Gotham

Arch Linux Xfce+compiz - 64Bit Linux User #621110

Offline

Board footer

Powered by FluxBB