You are not logged in.

#1 2020-09-04 20:30:33

lngndvs
Member
Registered: 2012-08-28
Posts: 13

yet another urxvt unicode font question

Bashtop, Bpytop, Gotop use line/box drawing characters in unicode.  These characters display as something diffferent on urxvt. 

Other terminals that work: kitty, alacritty, xfce4-terminal, xst, st, tilix.  At least. 

I've spent way too many hours trying to get to the bottom of it.  Google searches lead to dozens of posts.  The answers are usually something like "it's probably a locale issue" or "it works with such and such font".  Etc.  Nothing I have tried works. 

I have grown weary of reading the responses to such questions from new users or experienced users such as "I don't know but maybe..." or "Next time post correctly".   This kind of well-meaning or magnanimous posturing used to be found in Debian or Ubuntu mailing lists.  Gentoo was best.  Arch has been great.  But now I'm seeking such answers in Arch forums.  I understand because I used to do it.  I was thrilled to participate in the community, but my answers were crap.  It just confuses people. 

Someone out there knows the answer to this.  Is there anyone who can explain it in simple English?

Thank you,

Alan Davis

Offline

#2 2020-09-04 20:58:53

seth
Member
Registered: 2012-09-03
Posts: 16,607

Re: yet another urxvt unicode font question

Please provide a screenshot of the issue so we can ballpark the problem.
(Only post a link or thumbnail, the board rules limit images to 200x200)

There're 2+1 typical problems here:
1. is actually the locale - but it's unlikely to vary between VTEs (unless you explicitly change the shell and/or shell's rc)
2. is that the used font doesn't provide those glyphs
+1. Is that vanilla urxvt is a bit picky about glyph boxes - if you define a substitution font that has those glyphs but they exceed the pixel size of the main font, urxvt will just not print them

Therefore:

locale
locale -a
xrdb -q | grep -iE '(urxvt|font)'

Offline

#3 2020-09-04 21:24:16

GaKu999
Member
From: US/Eastern
Registered: 2020-06-21
Posts: 379

Re: yet another urxvt unicode font question

Yeepers with bashtop 5k lines of code in pure bash...

Now it works fine with terminus font in the virtual terminal...well, cubes anyways but not broken glyphs at least...

It indeed looks awful in urxvt and I’m using Hack with regular style...
With regular monospace it stills looks awful...

Also it haves other misinteractions that are unrelated to fonts...weird coloring in wrong places...

st manages to draw without the misinteractions that urxvt haves, but the glyphs are still wrong.
And that with both monospace and hack...

Just copied the glyphs outside of bashtop and it’s still the same, just without the overlay...

These seem to be the broken ones, spaced the first from the second one:

⡀ ⣄

And the rest of the same family, they are actually displaying correctly, just different, this is weird.
Are they supposed to be dots building up in a 2x4 fashion?

Last edited by GaKu999 (2020-09-04 21:30:30)


My reposSome snippets

Heisenberg might have been here.

Offline

Board footer

Powered by FluxBB