You are not logged in.

#1 2020-09-01 11:35:36

MGDV
Member
Registered: 2020-09-01
Posts: 7

[SOLVED] Installer stuck on "GRUB _"

Hello all,

I am trying to install Arch from a USB on my x220. I have done this in the past without any issues

Since having Manjaro installed, when I try to boot into the usb install, the screen just says "GRUB _" without the option to type anything

the usb was created using dd bs=4M if=path/to/archlinux.iso of=/dev/sdx status=progress oflag=sync and was formatted with Ext4 before hand

the same usb works fine on another computer. I'm guessing I might need to wipe the SSD before trying to install Arch?

Any help would be greatly appreciated. Really want to understand what the issue is here

---
MGDV

Last edited by MGDV (2020-09-09 11:09:35)

Offline

#2 2020-09-01 12:05:41

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,507

Re: [SOLVED] Installer stuck on "GRUB _"

You need to configure your EFI/firmware to boot into the usb. The Arch iso doesn't use GRUB so you definitely are not booting from the usb stick.  There's usually a button to change the boot order/enter your firmware setup - F12 or delete or f10 or so, check your instruction booklet.  (btw formatting a stick before writing an image over it is unnecessary).

Last edited by V1del (2020-09-01 12:07:26)

Offline

#3 2020-09-01 12:39:01

MGDV
Member
Registered: 2020-09-01
Posts: 7

Re: [SOLVED] Installer stuck on "GRUB _"

Thanks

I've definitely set the boot order to try the USB first via the BIOS. I'll have another look at this though

Offline

#4 2020-09-01 14:16:49

MGDV
Member
Registered: 2020-09-01
Posts: 7

Re: [SOLVED] Installer stuck on "GRUB _"

Can confirm that the BIOS is reading from the USB drive first before the SSD. The boot order is set that way in the BIOS and I have even forced it to boot from the USB via the Boot Setup Menu

Just wondering, what could cause it to sit at the Grub even though an OS is installed and can be loaded normally without the USB stick inserted?

Offline

#5 2020-09-03 13:23:56

fistrosan
Member
Registered: 2020-04-01
Posts: 97

Re: [SOLVED] Installer stuck on "GRUB _"

An X220 is an old model. Are you sure it supports UEFI boot ? Maybe you need to create your USB using a different partioning (MBR instead of GPT) ? https://wiki.archlinux.org/index.php/partitioning

Offline

#6 2020-09-03 14:08:54

MGDV
Member
Registered: 2020-09-01
Posts: 7

Re: [SOLVED] Installer stuck on "GRUB _"

Surprisingly, the BIOS gives the option for UEFI and Legacy boot

To reiterate, I have been able to install Arch on this machine multiple times. This issue has only happened since installing Manjaro

And yes, I am asking on the Manjaro forums as well. This is exactly the kind of issue that's brought me back to Arch

Offline

#7 2020-09-03 18:26:21

fistrosan
Member
Registered: 2020-04-01
Posts: 97

Re: [SOLVED] Installer stuck on "GRUB _"

Ok got it ... and I assume that you have UEFI boot enabled in the BIOS right ? If you do, try disabling secure boot and if it is already disabled then I am out of ideas sad

Offline

#8 2020-09-03 18:49:28

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,537
Website

Re: [SOLVED] Installer stuck on "GRUB _"

fistrosan wrote:

Maybe you need to create your USB using a different partioning (MBR instead of GPT) ?

Any pre-existing partitioning would be eradicated when the ISO image is transferred to the USB stick.

@OP: can we see

efibootmgr -v

^ That should display the entry from which removable devices are booted.

Can the machine boot other distributions' ISO images? Can you boot the Arch ISO image in non-UEFI mode?

If we can't get to the bottom of this then it is possible to install Arch from your extant Manjaro system:

https://wiki.archlinux.org/index.php/In … ting_Linux

Offline

#9 2020-09-03 20:40:52

MGDV
Member
Registered: 2020-09-01
Posts: 7

Re: [SOLVED] Installer stuck on "GRUB _"

@OP: can we see

efibootmgr -v

^ That should display the entry from which removable devices are booted.

This gives me

 EFI variables are not supported on this system 

So does this mean that the x220 doesn't support UEFI?

Offline

#10 2020-09-04 13:13:40

MGDV
Member
Registered: 2020-09-01
Posts: 7

Re: [SOLVED] Installer stuck on "GRUB _"

Can the machine boot other distributions' ISO images? Can you boot the Arch ISO image in non-UEFI mode?

No and no. I tried another Manjaor installer and both installers on legacy and UEFI but all variations ended up with "GRUB _"

Offline

#11 2020-09-04 21:16:41

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,537
Website

Re: [SOLVED] Installer stuck on "GRUB _"

See the last point here.

MGDV wrote:

This gives me

EFI variables are not supported on this system

So does this mean that the x220 doesn't support UEFI?

That message indicates that efivarfs is not mounted, perhaps because you're not booted in UEFI mode. See also https://wiki.archlinux.org/index.php/Un … le_support

The X220 supports UEFI booting.

Offline

#12 2020-09-09 07:58:46

MGDV
Member
Registered: 2020-09-01
Posts: 7

Re: [SOLVED] Installer stuck on "GRUB _"

This is solved now with the help of the Arch group on freenodes smile

Turns out I am an idiot and I wrote the iso to sdb1 instead of sdb. As always it pays to RTFM

Run the following command, replacing /dev/sdx with your drive, e.g. /dev/sdb. (Do not append a partition number, so do not use something like /dev/sdb1)

https://wiki.archlinux.org/index.php/US … ion_medium

This can be marked as solved

Thank you all

Offline

#13 2020-09-09 08:44:15

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,507

Re: [SOLVED] Installer stuck on "GRUB _"

Great, please mark as [SOLVED] by editing the title in your first post.

Offline

Board footer

Powered by FluxBB