You are not logged in.

#1 2020-09-08 17:45:07

mohamedafify
Member
Registered: 2020-09-08
Posts: 2

[SOLVED]sound not working (Dummy output)

I am currently having a problem with my new laptop i just installed arch linux and sound is not working at all i tried a lot of things but i still didn't get how to solve the problem
i am going to run some commands that can be helpful for anyone who can help:

# aplay -l :

 **** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

# fuser -v /dev/snd/* :

USER        PID ACCESS COMMAND
/dev/snd/controlC0:  mohamedafify   1237 F.... pulseaudio

# sudo journalctl -k | grep -E  'snd|sof' :

Sep 08 21:10:47 mohamedafify kernel: PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
Sep 08 21:10:47 mohamedafify kernel: software IO TLB: mapped [mem 0x6a4c9000-0x6e4c9000] (64MB)
Sep 08 21:10:56 mohamedafify kernel: snd_hda_intel 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
Sep 08 21:10:56 mohamedafify kernel: snd_hda_intel 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
Sep 08 21:10:56 mohamedafify kernel: snd_hda_intel 0000:01:00.1: enabling device (0000 -> 0002)
Sep 08 21:10:56 mohamedafify kernel: snd_hda_intel 0000:01:00.1: Disabling MSI
Sep 08 21:10:56 mohamedafify kernel: snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
Sep 08 21:10:56 mohamedafify kernel: sof-audio-pci 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
Sep 08 21:10:56 mohamedafify kernel: sof-audio-pci 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
Sep 08 21:10:56 mohamedafify kernel: sof-audio-pci 0000:00:1f.3: enabling device (0000 -> 0002)
Sep 08 21:10:56 mohamedafify kernel: sof-audio-pci 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if 0x040100
Sep 08 21:10:56 mohamedafify kernel: sof-audio-pci 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
Sep 08 21:10:56 mohamedafify kernel: sof-audio-pci 0000:00:1f.3: use msi interrupt mode
Sep 08 21:10:56 mohamedafify kernel: sof-audio-pci 0000:00:1f.3: hda codecs found, mask 5
Sep 08 21:10:56 mohamedafify kernel: sof-audio-pci 0000:00:1f.3: using HDA machine driver skl_hda_dsp_generic now
Sep 08 21:10:56 mohamedafify kernel: sof-audio-pci 0000:00:1f.3: Direct firmware load for intel/sof/sof-cfl.ri failed with error -2
Sep 08 21:10:56 mohamedafify kernel: sof-audio-pci 0000:00:1f.3: error: request firmware intel/sof/sof-cfl.ri failed err: -2
Sep 08 21:10:56 mohamedafify kernel: sof-audio-pci 0000:00:1f.3: error: failed to load DSP firmware -2
Sep 08 21:10:56 mohamedafify kernel: sof-audio-pci 0000:00:1f.3: error: sof_probe_work failed err: -2
Sep 08 21:10:56 mohamedafify kernel: snd_hda_intel 0000:01:00.1: bound 0000:01:00.0 (ops nv50_audio_component_bind_ops [nouveau]) 

# lspci -nnk | grep -A2 Audio :

 01:00.1 Audio device [0403]: NVIDIA Corporation Device [10de:10fa] (rev a1)
	Subsystem: Dell Device [1028:0949]
	Kernel driver in use: snd_hda_intel

Last edited by mohamedafify (2020-09-09 11:13:45)

Offline

#2 2020-09-08 18:37:20

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,507

Re: [SOLVED]sound not working (Dummy output)

Offline

#3 2020-09-09 11:11:24

mohamedafify
Member
Registered: 2020-09-08
Posts: 2

Re: [SOLVED]sound not working (Dummy output)

thanks, the package that solved the problem was alsa-ucm-conf the other both was already installed.

Offline

Board footer

Powered by FluxBB