You are not logged in.

#1 2020-09-15 14:35:18

dioramaramen
Member
Registered: 2020-09-12
Posts: 6

[SOLVED] System locks up after enabling Nvidia DRM Kernel Mode Setting

In order to solve an issue where my system was falling back on software rendering instead of using the nvidia driver, I added add the nvidia-drm.modeset=1 as a kernel parameter, added "nvidia", "nvidia-drm", and "nvidia-modeset" to the MODULES array in mkinitcpio.conf, and ran mkinitcpio -P. This successfully caused my Nvidia drivers to be used, but now I'm experiencing system crashing where the screen stops responding to input (but audio that was playing continues to play) and I have to hold down the power button to shut down- trying to switch to a different tty doesn't work.

I gathered full journals from each boot where I experienced a crash. I believe the relevant section of each log begins with kernel: BUG: kernel NULL pointer dereference, address: 0000000000000000.

Journal from boot for crash #1
Journal from boot for crash #2
Journal from boot for crash #3

I'm not savvy enough to know what's going on from these logs and would appreciate some help. Thanks in advance.

Last edited by dioramaramen (2020-09-18 16:08:37)

Offline

#2 2020-09-15 14:51:09

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,508

Re: [SOLVED] System locks up after enabling Nvidia DRM Kernel Mode Setting

If you keep the modules in the initramfs but don't enable modesetting do you still have either issue? The modeset parameter shouldn't inherently be necessary for xorg and the race condition should be fulfilled by the presence of the modules in the initramfs.

Offline

#3 2020-09-15 15:11:33

dioramaramen
Member
Registered: 2020-09-12
Posts: 6

Re: [SOLVED] System locks up after enabling Nvidia DRM Kernel Mode Setting

I've removed the kernel parameter and it's correctly using the driver. No crashes yet, but they would happen intermittently. I'll post back with another log if I experience another crash, but if it runs smoothly through tomorrow I'll go ahead and mark the thread solved. Thank you!

Edit: Haven't experienced any more crashes, marking this as solved.

Last edited by dioramaramen (2020-09-18 16:09:02)

Offline

Board footer

Powered by FluxBB