You are not logged in.

#1 2020-09-16 20:11:36

Registered: 2020-09-05
Posts: 2

Can't find refind...

I have refind installed on my pc, can boot without problems, and iam trying to install themes on refind, and noticed that the "/boot/efi" folder is empty so i checked the fstab but I don't see a problem


Static information about the filesystems.
# See fstab(5) for details.

# <file system> <dir> <type> <options> <dump> <pass>
# /dev/sda7
UUID=9ac66e7a-3fc1-4acf-b091-0f7114e44f57       /               btrfs           rw,relatime,ssd,space_cache,subvolid=5,subvol=/ 0 0

# /dev/sda5
UUID=6BF2-ABA9          /boot/efi       vfat            rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro       0 2

# /dev/sda6
UUID=9505a7f0-267c-4232-a05e-d0b5a8cde8cf       none            swap            defaults        0 0

# /dev/sdb1

/dev/sdb1              /home/dante/Storage/   exfat   rw,suid,dev,exec,auto,async,noatime,uid=1000,gid=985  0 2

Also tried to mount manually by "sudo mount -v /dev/sda5 /mnt/efil" without showing any error, but  "/mnt/efil" is also empty. Then tried to mount it in another folder but the terminal says it is already mounted


#2 2020-09-16 21:08:09

Registered: 2014-03-06
Posts: 11,633

Re: Can't find refind...

Please post commands and their outputs,  file contents e.t.c. in code tags not quote tags.  Please post the command you used and their outputs rather than a narrative of what you did.

Have you checked all other filesystems for a directory named EFI?


#3 2020-09-17 06:36:12

From: Italy
Registered: 2020-03-04
Posts: 15

Re: Can't find refind...

Your /boot/efi directory is really empty or not ?
If it's empty you can generate it with bootctl tool :

bootctl --path=$BOOTPARTITIONMOUNTPOINT install

Last edited by Khere (2020-09-17 06:37:32)

Italian' GoDz Proud


#4 2020-09-17 07:47:55

Registered: 2017-07-28
Posts: 916

Re: Can't find refind...

Khere wrote:

If it's empty you can generate it with bootctl tool :

The OP is using rEFInd. It's probably best not to mix up rEFInd and systemd-boot together, or at least try to resolve the rEFInd issue first.

@Durante rEFInd is able to boot so your installation seems OK. As loqs said, just post the commands you did installing rEFInd.
Also are you able to locate your refind_linux.conf?


#5 2020-09-17 09:29:50

From: Netherlands, Europe
Registered: 2005-10-04
Posts: 8,344

Re: Can't find refind...

Efi System Partition can be (and usually is) mounted by systemd before fstab is being processed.
Post what loqs asked, include

$ lsblk -f

Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them


Board footer

Powered by FluxBB