You are not logged in.

#1 2020-09-26 14:00:07

cb951303
Member
Registered: 2007-03-17
Posts: 76

Booting installer from hdd partition

Due to not having access to a USB drive I was experimenting with trying to install arch from a FAT32 partition I've made in Windows.

I've started by mounting the *.iso file and I've copied the content over the new partition.

My BIOS automatically recognized this partition as UEFI bootable and by trying to boot from it I ended up in an EFI shell where I can navigate the install files.

Then I tried  running EFI>BOOT>BOOx64.EFI and I ended up in the EFI shell again. (Which I'm assuming is the shellx64.efi program in the root of the partition)

Afterwards I tried to rename the arch>boot>x86_64>vmlinux-linux to vmlinuz-linux.efi and run it as shown in here.

> FS2:
> cd arch/boot/x86_64
> mv vmlinuz-linux vmlinuz-linux.efi
> vmlinuz-linux.efi root=PARTUUID=15733d45-3c61-4f65-b2fb-de14332432c0 rw initrd=\arch\boot\x86_64\archiso.img

Where the PARTUUID is the GUID of the FAT32 partition where the installer is, given by the EFI shell map command. This indeed started the normal installer boot process just like it would via USB however got stuck with an error saying the the partition with given GUID is not found and threw me to a bash prompt.

At this point I'm out of ideas and would appreciate any help
Thanks

Offline

#2 2020-09-27 11:33:05

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 8,631

Re: Booting installer from hdd partition

The archlinux installation iso can also be burned on an optical disk, does that help ?

Almost any usb memory stick will be sufficient, it just has to store 1 GiB .
(I recently used a 12+ year old USB 1.1  memory stick with 1 GiB space to install archlinux. it was very slow but did work)


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Online

#3 2020-09-27 11:52:26

frostschutz
Member
Registered: 2013-11-15
Posts: 993

Re: Booting installer from hdd partition

If the system has plenty RAM you can try your luck with the netboot - https://www.archlinux.org/releng/netboot/

I've never copied ISO contents before, I provide the ISO file itself ( kernel + initrd from inside the ISO, which you're already using I guess, with parameters `img_dev=/dev/disk/by-label/boot_iso img_loop=archlinux-2019.11.01-x86_64.iso earlymodules=loop` )

Online

Board footer

Powered by FluxBB