You are not logged in.

#1 2020-10-01 19:59:06

fileserverpls
Member
Registered: 2018-10-21
Posts: 15

Circular update with libutil-linux

Updating my system results in the following and I cannot get it to go away. I cannot remove any package because the package that needs to be removed has lots and lots of dependencies. Also saying no to the package that has a conflict ends the update. How do I fix this?

:: Synchronizing package databases...
 core                                                                                                               130.8 KiB  9.13 MiB/s 00:00 [########################################################################################] 100%
 extra                                                                                                             1656.0 KiB  47.6 MiB/s 00:00 [########################################################################################] 100%
 community                                                                                                            5.2 MiB  64.7 MiB/s 00:00 [########################################################################################] 100%
 multilib                                                                                                           157.4 KiB  0.00   B/s 00:00 [########################################################################################] 100%
 chaotic-aur                                                                                                       1369.0 KiB   951 KiB/s 00:01 [########################################################################################] 100%
 sublime-text                                                                                                      1828.0   B  0.00   B/s 00:00 [########################################################################################] 100%
 sublime-text.sig                                                                                                   543.0   B  0.00   B/s 00:00 [########################################################################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
:: util-linux-libs and libutil-linux-selinux are in conflict (libutil-linux). Remove libutil-linux-selinux? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing libutil-linux-selinux breaks dependency 'libutil-linux-selinux' required by util-linux-selinux

Offline

#2 2020-10-01 20:24:39

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,020
Website

Re: Circular update with libutil-linux

What is "libutil-linux-selinux" and where does it come from?

Mod note: Moving to AUR Issues.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#3 2020-10-01 20:35:38

fileserverpls
Member
Registered: 2018-10-21
Posts: 15

Re: Circular update with libutil-linux

I am actually unsure, I am guessing selinux got along when I installed selinux?

Edit I also cannot remove libutil-linux-selinux because of

pacman -R libutil-linux-selinux
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing libutil-linux-selinux breaks dependency 'libutil-linux' required by cryptsetup
:: removing libutil-linux-selinux breaks dependency 'libuuid.so=1-64' required by cryptsetup
:: removing libutil-linux-selinux breaks dependency 'libutil-linux' required by e2fsprogs
:: removing libutil-linux-selinux breaks dependency 'libutil-linux' required by glib2
:: removing libutil-linux-selinux breaks dependency 'libmount.so=1-64' required by glib2
:: removing libutil-linux-selinux breaks dependency 'libutil-linux' required by libsm
:: removing libutil-linux-selinux breaks dependency 'libutil-linux' required by lvm2
:: removing libutil-linux-selinux breaks dependency 'libblkid.so=1-64' required by lvm2
:: removing libutil-linux-selinux breaks dependency 'libutil-linux' required by parted
:: removing libutil-linux-selinux breaks dependency 'libutil-linux-selinux' required by util-linux-selinux
:: removing libutil-linux-selinux breaks dependency 'libutil-linux' required by wget

Last edited by fileserverpls (2020-10-01 20:43:10)

Offline

#4 2020-10-01 21:45:30

loqs
Member
Registered: 2014-03-06
Posts: 11,869

Re: Circular update with libutil-linux

Does the following resolve the conflict by removing the selinux variant packages?

pacman -Syu util-linux-libs util-linux

Offline

#5 2020-10-01 22:14:14

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,020
Website

Re: Circular update with libutil-linux

fileserverpls wrote:

I am actually unsure, I am guessing selinux got along when I installed selinux?

Edit I also cannot remove libutil-linux-selinux because of

pacman -R libutil-linux-selinux
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing libutil-linux-selinux breaks dependency 'libutil-linux' required by cryptsetup
:: removing libutil-linux-selinux breaks dependency 'libuuid.so=1-64' required by cryptsetup
:: removing libutil-linux-selinux breaks dependency 'libutil-linux' required by e2fsprogs
:: removing libutil-linux-selinux breaks dependency 'libutil-linux' required by glib2
:: removing libutil-linux-selinux breaks dependency 'libmount.so=1-64' required by glib2
:: removing libutil-linux-selinux breaks dependency 'libutil-linux' required by libsm
:: removing libutil-linux-selinux breaks dependency 'libutil-linux' required by lvm2
:: removing libutil-linux-selinux breaks dependency 'libblkid.so=1-64' required by lvm2
:: removing libutil-linux-selinux breaks dependency 'libutil-linux' required by parted
:: removing libutil-linux-selinux breaks dependency 'libutil-linux-selinux' required by util-linux-selinux
:: removing libutil-linux-selinux breaks dependency 'libutil-linux' required by wget

So how did you install selinux?


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#6 2020-10-01 22:32:53

fileserverpls
Member
Registered: 2018-10-21
Posts: 15

Re: Circular update with libutil-linux

pacman -Syu util-linux-libs util-linux:

:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 sublime-text is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
:: util-linux-libs and libutil-linux-selinux are in conflict (libutil-linux). Remove libutil-linux-selinux? [y/N] y
:: util-linux and util-linux-selinux are in conflict (rfkill). Remove util-linux-selinux? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing util-linux-selinux breaks dependency 'util-linux-selinux' required by systemd-selinux

WorMzy I installed it using pikaur I guess. About a year ago and have had no problems since. A bit of a weird question, there is not a lot of ways to install packages lol (do not comment on that, then you are wasting everybodys time).

Offline

#7 2020-10-01 22:39:01

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,049
Website

Re: Circular update with libutil-linux

fileserverpls post #1 wrote:
:: Synchronizing package databases...
...
 chaotic-aur                                                                                                       1369.0 KiB   951 KiB/s 00:01 [########################################################################################] 100%
...
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
fileserverpls last post wrote:
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 sublime-text is up to date
:: Starting full system upgrade...
resolving dependencies...

Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#8 2020-10-01 22:39:13

loqs
Member
Registered: 2014-03-06
Posts: 11,869

Re: Circular update with libutil-linux

Install util-linux-selinux 2.36-4 and util-linux-libs-selinux 2.36-4 in the same transaction before the update or add systemd to the list of variant packages to replace.

Last edited by loqs (2020-10-01 22:39:26)

Offline

#9 2020-10-01 23:07:31

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,976

Re: Circular update with libutil-linux

If you're going to replace low-level packages like this, you really need to be building them in a chroot and adding them to a local repo. You are also responsible for keeping them up to date.

With the questions you're asking, I would strongly advise going back to the official packages.

Last edited by Scimmia (2020-10-01 23:07:49)

Offline

#10 2020-10-02 07:27:50

fileserverpls
Member
Registered: 2018-10-21
Posts: 15

Re: Circular update with libutil-linux

loqs wrote:

Install util-linux-selinux 2.36-4 and util-linux-libs-selinux 2.36-4 in the same transaction before the update or add systemd to the list of variant packages to replace.

Thanks for the tip, it fixed it! Finally someone who does not come up with unproductive comments such as "where did you install the package" or random quotes of my comments!

Offline

#11 2020-10-02 14:14:42

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,976

Re: Circular update with libutil-linux

Yes, how dare people question inconsistencies and want more information!

Offline

Board footer

Powered by FluxBB