You are not logged in.

#1 2020-10-06 05:40:02

nyaa
Member
Registered: 2020-10-06
Posts: 5

[SOLVED] Cannot upgrade because of error: failed to commit

Hi,

I cannot upgrade because of 'error: failed to commit transaction (conflicting files)', I already read the according section in the Arch wiki (https://wiki.archlinux.org/index.php/Pacman), however, there are so many files to deal with manually I wonder if there is a more elegant solution to this problem.

Here is the output:

:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
:: Replace pygobject-devel with extra/python-gobject? [Y/n] 
resolving dependencies...
looking for conflicting packages...

Package (75)                    Old Version            New Version             Net Change

extra/alsa-card-profiles                               13.99.2+7+g6101798c7-1    0.14 MiB
extra/cheese                    3.34.0+23+gcac6d3a1-1  3.34.0+91+gc5cf9af9-1     0.07 MiB
extra/eog                       3.36.3-1               3.38.0-1                  0.04 MiB
extra/epiphany                  3.36.4-1               3.38.0-1                 -1.29 MiB
extra/evince                    3.36.7-1               3.38.0+1+gffa3fd98-1     -0.01 MiB
extra/evolution                 3.36.5-1               3.38.1-1                  0.11 MiB
extra/evolution-data-server     3.36.5-1               3.38.1-1                  0.36 MiB
extra/folks                     0.14-1                 0.14-2                    0.06 MiB
extra/gdm                       3.36.3-6               3.38.0-1                  0.04 MiB
extra/gedit                     3.36.2-1               3.38.0-1                 -0.75 MiB
extra/gjs                       2:1.64.4-1             2:1.66.0-2                0.04 MiB
extra/glade                     3.36.0+1+g3907987d-1   3.38.1-1                  0.18 MiB
core/glib2                      2.66.0-1               2.66.1-1                  0.09 MiB
community/gnome-boxes           3.36.6-1               3.38.0-1                  0.00 MiB
extra/gnome-calculator          3.36.0-1               3.38.1-1                  0.20 MiB
extra/gnome-calendar            3.36.2-1               3.38.1-1                  0.02 MiB
extra/gnome-clocks              3.36.2-2               3.38.0-1                  0.08 MiB
extra/gnome-contacts            3.36.2-1               3.38-1                    0.00 MiB
extra/gnome-control-center      3.36.4-1               3.38.1-1                  0.04 MiB
extra/gnome-desktop             1:3.36.6-1             1:3.38.1-1                0.01 MiB
extra/gnome-devel-docs          3.32.1+30+gf3ad0fe5-1  3.38.1-1                  0.06 MiB
extra/gnome-maps                3.36.4-1               3.38.1-1                  0.10 MiB
extra/gnome-photos              3.34.2-1               3.38.0-1                  0.04 MiB
extra/gnome-screenshot          3.36.0-1               3.38.0-1                 -0.02 MiB
extra/gnome-session             3.36.0-1               3.38.0-1                  0.03 MiB
extra/gnome-settings-daemon     3.36.1-1               3.38.0-1                  0.14 MiB
extra/gnome-shell               1:3.36.6-1             1:3.38.1-1                0.30 MiB
extra/gnome-shell-extensions    3.36.5-1               3.38.1-1                  0.00 MiB
extra/gnome-software            3.36.1-2               3.38.0-2                  2.04 MiB
extra/gnome-sound-recorder      3.34.0+10+gc4bdfa0-1   3.38.0-1                  0.00 MiB
extra/gnome-terminal            3.36.2-1               3.38.1-1                  0.20 MiB
extra/gnome-todo                3.28.1+22+gd56e14e-2   3.28.1+33+gc03a4c1-1      0.04 MiB
extra/gnome-tweaks              3.34.0-3               3.34.0-4                  0.00 MiB
extra/gnome-usage               3.33.2-2               3.38.0-1                  0.02 MiB
extra/gnome-user-docs           3.36.6-1               3.38.1-1                  0.45 MiB
extra/grilo-plugins             1:0.3.12-1             1:0.3.12-2                0.00 MiB
community/gst-editing-services                         1.16.2-1                  3.25 MiB
extra/gtk-update-icon-cache     1:3.24.23-1            1:3.24.23-3               0.00 MiB
extra/gtk3                      1:3.24.23-1            1:3.24.23-3               0.07 MiB
extra/gvfs                      1.44.1-4               1.46.1-1                 -0.01 MiB
extra/gvfs-afc                  1.44.1-4               1.46.1-1                  0.00 MiB
extra/gvfs-goa                  1.44.1-4               1.46.1-1                  0.00 MiB
extra/gvfs-google               1.44.1-4               1.46.1-1                  0.00 MiB
extra/gvfs-gphoto2              1.44.1-4               1.46.1-1                  0.00 MiB
extra/gvfs-mtp                  1.44.1-4               1.46.1-1                  0.00 MiB
extra/gvfs-nfs                  1.44.1-4               1.46.1-1                  0.00 MiB
extra/gvfs-smb                  1.44.1-4               1.46.1-1                  0.00 MiB
multilib/lib32-glib2            2.66.0-1               2.66.1-1                  0.00 MiB
multilib/lib32-libpulse         13.0-1                 13.99.2+7+g6101798c7-1    0.00 MiB
extra/libcloudproviders         0.3.1-1                0.3.1-2                   0.16 MiB
extra/libgdm                    3.36.3-6               3.38.0-1                 -0.28 MiB
extra/libhandy                  0.0.13-2               1.0.0-1                   0.53 MiB
extra/libhandy0                                        0.0.13+12+gaa6b6f4-1      2.10 MiB
extra/libnautilus-extension     3.36.3-1               3.38.1-1                  0.00 MiB
extra/libpeas                   1.26.0-1               1.28.0-1                  0.01 MiB
extra/libportal                                        0.3-2                     0.55 MiB
extra/libpulse                  13.0-3                 13.99.2+7+g6101798c7-1    0.01 MiB
extra/libsoup                   2.72.0+5+g0b094bff-1   2.72.0+5+g0b094bff-3      0.01 MiB
extra/mutter                    3.36.6-1               3.38.1-1                 -0.40 MiB
extra/nautilus                  3.36.3-1               3.38.1-1                  0.17 MiB
extra/pango                     1:1.46.2-1             1:1.46.2-3                0.01 MiB
extra/pipewire                  0.3.13-1               0.3.13-2                 -0.14 MiB
extra/pulseaudio                13.0-3                 13.99.2+7+g6101798c7-1    0.01 MiB
extra/pulseaudio-bluetooth      13.0-3                 13.99.2+7+g6101798c7-1    0.00 MiB
pygobject-devel                 3.36.1-1                                        -0.02 MiB
extra/python-gobject            3.36.1-1               3.38.0-1                  0.02 MiB
extra/python2-gobject           3.36.1-1               3.36.1-2                  0.01 MiB
extra/ruby                      2.7.1-3                2.7.2-1                   0.01 MiB
extra/rygel                     0.38.4-1               0.40.0-1                  0.07 MiB
extra/sysprof                   3.36.0+9+gf2c5b2c-1    3.38.0+11+gb39a43d-1      0.14 MiB
extra/tepl                      4.4.0-1                5.0.0-1                  -0.01 MiB
extra/totem                     3.34.1-2               3.38.0-1                  0.30 MiB
extra/tracker-miners            2.3.5-1                2.3.5-2                  -0.02 MiB
extra/tracker3                                         3.0.1-1                   4.02 MiB
extra/tracker3-miners                                  3.0.1-1                   3.62 MiB

Total Installed Size:  576.95 MiB
Net Upgrade Size:       17.02 MiB

:: Proceed with installation? [Y/n] 
(74/74) checking keys in keyring                                                                      [------------------------------------------------------------] 100%
(74/74) checking package integrity                                                                    [------------------------------------------------------------] 100%
(74/74) loading package files                                                                         [------------------------------------------------------------] 100%
(74/74) checking for file conflicts                                                                   [------------------------------------------------------------] 100%
error: failed to commit transaction (conflicting files)
libhandy: /usr/include/libhandy-1/handy.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-action-row.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-animation.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-application-window.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-avatar.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-carousel-indicator-dots.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-carousel-indicator-lines.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-carousel.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-clamp.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-combo-row.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-deck.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-deprecation-macros.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-enum-value-object.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-enums.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-expander-row.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-header-bar.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-header-group.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-keypad.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-leaflet.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-main.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-navigation-direction.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-preferences-group.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-preferences-page.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-preferences-row.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-preferences-window.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-search-bar.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-squeezer.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-swipe-group.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-swipe-tracker.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-swipeable.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-title-bar.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-types.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-value-object.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-version.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-view-switcher-bar.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-view-switcher-title.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-view-switcher.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-window-handle.h exists in filesystem (owned by libhandy1)
libhandy: /usr/include/libhandy-1/hdy-window.h exists in filesystem (owned by libhandy1)
libhandy: /usr/lib/girepository-1.0/Handy-1.typelib exists in filesystem (owned by libhandy1)
libhandy: /usr/lib/glade/modules/libglade-handy-1.so exists in filesystem (owned by libhandy1)
libhandy: /usr/lib/libhandy-1.so exists in filesystem (owned by libhandy1)
libhandy: /usr/lib/libhandy-1.so.0 exists in filesystem (owned by libhandy1)
libhandy: /usr/lib/pkgconfig/libhandy-1.pc exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gir-1.0/Handy-1.gir exists in filesystem (owned by libhandy1)
libhandy: /usr/share/glade/catalogs/libhandy-1.xml exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyActionRow.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyApplicationWindow.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyAvatar.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyCarousel.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyCarouselIndicatorDots.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyCarouselIndicatorLines.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyClamp.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyComboRow.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyDeck.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyEnumValueObject.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyExpanderRow.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyHeaderBar.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyHeaderGroup.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyKeypad.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyLeaflet.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyPreferencesGroup.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyPreferencesPage.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyPreferencesRow.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyPreferencesWindow.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdySearchBar.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdySqueezer.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdySwipeGroup.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdySwipeTracker.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdySwipeable.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyTitleBar.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyValueObject.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyViewSwitcher.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyViewSwitcherBar.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyViewSwitcherTitle.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyWindow.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/HdyWindowHandle.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/annotations-glossary.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/api-index-full.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/avatar.png exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/build-howto.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/core-api.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/hdy-migrating-0-0-to-1.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/header-bar.png exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/helpers.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/home.png exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/index.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/intro.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/keypad.png exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/left-insensitive.png exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/left.png exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/libhandy-Animation-Helpers.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/libhandy-HdyNavigationDirection.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/libhandy-hdy-main.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/libhandy-hdy-version.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/libhandy.devhelp2 exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/list.png exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/migrating.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/object-tree.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/preferences-window.png exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/right-insensitive.png exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/right.png exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/search.png exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/style.css exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/up-insensitive.png exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/up.png exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/view-switcher-bar.png exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/view-switcher.png exists in filesystem (owned by libhandy1)
libhandy: /usr/share/gtk-doc/html/libhandy-1/visual-index.html exists in filesystem (owned by libhandy1)
libhandy: /usr/share/locale/en_GB/LC_MESSAGES/libhandy.mo exists in filesystem (owned by libhandy1)
libhandy: /usr/share/locale/es/LC_MESSAGES/libhandy.mo exists in filesystem (owned by libhandy1)
libhandy: /usr/share/locale/eu/LC_MESSAGES/libhandy.mo exists in filesystem (owned by libhandy1)
libhandy: /usr/share/locale/id/LC_MESSAGES/libhandy.mo exists in filesystem (owned by libhandy1)
libhandy: /usr/share/locale/pl/LC_MESSAGES/libhandy.mo exists in filesystem (owned by libhandy1)
libhandy: /usr/share/locale/pt_BR/LC_MESSAGES/libhandy.mo exists in filesystem (owned by libhandy1)
libhandy: /usr/share/locale/ro/LC_MESSAGES/libhandy.mo exists in filesystem (owned by libhandy1)
libhandy: /usr/share/locale/uk/LC_MESSAGES/libhandy.mo exists in filesystem (owned by libhandy1)
libhandy: /usr/share/vala/vapi/libhandy-1.deps exists in filesystem (owned by libhandy1)
libhandy: /usr/share/vala/vapi/libhandy-1.vapi exists in filesystem (owned by libhandy1)
Errors occurred, no packages were upgraded.
error installing repo packages

Last edited by nyaa (2020-10-06 13:40:37)

Offline

#2 2020-10-06 06:00:02

ayekat
Member
Registered: 2011-01-17
Posts: 1,398
Website

Re: [SOLVED] Cannot upgrade because of error: failed to commit

nyaa wrote:

[…] there are so many files to deal with manually I wonder if there is a more elegant solution to this problem.

From a quick glance, it appears that most (if not all) cases are libhandy1 files. Where does that libhandy1 package come from?

I suspect that this is an earlier (and inofficial) variant of libhandy version 1 (potentially the AUR?), and package conflicts have therefore not been declared correctly.


{,META,RE}PKGBUILDSpacman-hacks (includes makemetapkg and remakepkg) │ dotfiles

Offline

#3 2020-10-06 06:05:53

loqs
Member
Registered: 2014-03-06
Posts: 11,898

Offline

#4 2020-10-06 07:22:14

nyaa
Member
Registered: 2020-10-06
Posts: 5

Re: [SOLVED] Cannot upgrade because of error: failed to commit

ayekat wrote:
nyaa wrote:

[…] there are so many files to deal with manually I wonder if there is a more elegant solution to this problem.

From a quick glance, it appears that most (if not all) cases are libhandy1 files. Where does that libhandy1 package come from?

I suspect that this is an earlier (and inofficial) variant of libhandy version 1 (potentially the AUR?), and package conflicts have therefore not been declared correctly.


Mhhh, I did not explicitly install the libhandy1 package it seems it was pulled as a dependency of some official gnome apps.

Offline

#5 2020-10-06 07:24:46

nyaa
Member
Registered: 2020-10-06
Posts: 5

Re: [SOLVED] Cannot upgrade because of error: failed to commit


I do not get this entirely, does that mean that the libhandy1 package will be automatically deleted whenever the request is implemented?

I am still not sure how to proceed from here.

Offline

#6 2020-10-06 07:26:35

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,734

Re: [SOLVED] Cannot upgrade because of error: failed to commit

nyaa wrote:

Mhhh, I did not explicitly install the libhandy1 package it seems it was pulled as a dependency of some official gnome apps.

There has never been a libhandy1 package in the official repos, so no.

Offline

#7 2020-10-06 07:29:50

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,734

Re: [SOLVED] Cannot upgrade because of error: failed to commit

nyaa wrote:

I do not get this entirely, does that mean that the libhandy1 package will be automatically deleted whenever the request is implemented?

I am still not sure how to proceed from here.

No. libhandy1 is not, and was never, supported, so you'll have to remove it yourself.

Last edited by arojas (2020-10-06 07:30:40)

Offline

#8 2020-10-06 07:30:03

nyaa
Member
Registered: 2020-10-06
Posts: 5

Re: [SOLVED] Cannot upgrade because of error: failed to commit

arojas wrote:
nyaa wrote:

Mhhh, I did not explicitly install the libhandy1 package it seems it was pulled as a dependency of some official gnome apps.

There has never been a libhandy1 package in the official repos, so no.

Yes, that is why I am a bit puzzled about it, but see for yourself:

pacman -Qi libhandy1                                                                                                                                             1 ↵
Name            : libhandy1
Version         : 1.0.0-2
Description     : Library full of GTK+ widgets for mobile phones (1.0, can be installed alongside 0.0)
Architecture    : x86_64
URL             : https://gitlab.gnome.org/GNOME/libhandy
Licenses        : LGPL2.1
Groups          : None
Provides        : libhandy=1  libhandy-1.so=0-64
Depends On      : gtk3
Optional Deps   : None
Required By     : epiphany  gnome-clocks  gnome-contacts  gnome-control-center  gnome-tweaks
Optional For    : None
Conflicts With  : libhandy-git
Replaces        : None
Installed Size  : 2.64 MiB
Packager        : Unknown Packager
Build Date      : Fri 25 Sep 2020 08:38:21 AM CEST
Install Date    : Fri 25 Sep 2020 08:39:25 AM CEST
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : None

Offline

#9 2020-10-06 07:31:40

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,734

Re: [SOLVED] Cannot upgrade because of error: failed to commit

nyaa wrote:

Yes, that is why I am a bit puzzled about it, but see for yourself:

So what? The fact that you have a package installed on your system doesn't mean that you installed it from the official repositories. The "Unknown packager" bit should give you a hint that this is not an official package.

Last edited by arojas (2020-10-06 07:32:26)

Offline

#10 2020-10-06 07:43:44

nyaa
Member
Registered: 2020-10-06
Posts: 5

Re: [SOLVED] Cannot upgrade because of error: failed to commit

Okay thanks everyone for your help! I removed the libhandy1 package and then the update went through without any issues. I really do not have a clue how the libhandy1 package was installed on my system.

This issue can be closed.

Last edited by nyaa (2020-10-06 07:49:56)

Offline

#11 2020-10-06 12:42:45

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 3,399

Re: [SOLVED] Cannot upgrade because of error: failed to commit

nyaa wrote:

This issue can be closed.

We don't usually close solved topics. We ask that you mark your thread [SOLVED] by editing your first post and adding [SOLVED] to the title.

https://wiki.archlinux.org/index.php/Co … ow_to_post

Offline

Board footer

Powered by FluxBB