You are not logged in.

#1 2020-10-08 18:28:13

penguinbliss
Member
Registered: 2020-10-08
Posts: 3

[SOLVED]Error: Timed out waiting for device /dev/mapper/archlinux-root

Greetings Archlinux family smile

I have been a Linux Mint user but now decided to try using Arch Linux.

I did the installation part as the installation guide says, but I face a problem with booting it up.

Screenshot of the error: https://imgur.com/a/nZEE59V

I double-checked the UUID part and grub settings, it looks fine to me, but there must be something that seems to be missed or not catching my eyes. Could you guys help?.

I ignored the /dev/sda1 which is my second HDD, and sdc is my installation media)

It is UEFI on my laptop so I created separate vfat partition sdb1 for efi:

Installation media prompt:

root@archiso ~ # lsblk --output NAME,MOUNTPOINT,SIZE,FSTYPE,UUID,ROTA,MODEL
NAME              MOUNTPOINT                  SIZE FSTYPE      UUID                                   ROTA MODEL
loop0             /run/archiso/sfs/airootfs 566.2M squashfs                                              1
sda                                         931.5G                                                       1 ST1000LM035-1RK172
└─sda1                                      931.5G ext4        e1e97afa-165a-4b15-8ad3-4541d0fd0fff      1
sdb                                         119.2G                                                       0 SK_hynix_SC311_SATA_128GB
├─sdb1                                        2.8G vfat        2945-BE61                                 0
├─sdb2                                        2.8G ext4        110a1a15-64f8-4e5b-b0fe-8c1dcb282ae9      0
└─sdb3                                      113.7G LVM2_member jqTlrC-2HYa-zcO1-IDvY-9I9v-Qye3-0diLlr    0
  ├─archinux-swap                             7.5G swap        d73373e1-d1dc-4cb4-ae8b-8a93b737ad55      0
  └─archinux-root                           106.2G ext4        6e7eed5f-69c0-4e71-b9da-8630e1561ba4      0
sdc                                          14.5G                                                       1 Cruzer_Blade
└─sdc1            /run/archiso/bootmnt       14.5G vfat        D617-28D3                                 1

root@archiso ~ # mount /dev/mapper/archinux-root /mnt
root@archiso ~ #
root@archiso ~ # mount /dev/sdb2 /mnt/boot
root@archiso ~ #
root@archiso ~ # mount /dev/sdb1 /mnt/boot/efi
root@archiso ~ #

Now chrooted to Installed OS:

root@archiso ~ # arch-chroot /mnt
[root@archiso /]#
[root@archiso /]# df -hT
Filesystem                Type      Size  Used Avail Use% Mounted on
/dev/mapper/archinux-root ext4      105G  3.6G   96G   4% /
/dev/sdb2                 ext4      2.7G   69M  2.5G   3% /boot
/dev/sdb1                 vfat      2.8G  160K  2.8G   1% /boot/efi
udev                      devtmpfs  7.7G     0  7.7G   0% /dev
shm                       tmpfs     7.7G     0  7.7G   0% /dev/shm
run                       tmpfs     7.7G  143M  7.6G   2% /run
tmp                       tmpfs     7.7G     0  7.7G   0% /tmp

[root@archiso /]# blkid
/dev/sda1: UUID="e1e97afa-165a-4b15-8ad3-4541d0fd0fff" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="ae70fef3-dcbc-f749-8cb0-080c664aabb0"
/dev/sdb1: UUID="2945-BE61" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="bde260c5-8cb7-4f80-8f88-56a041071cf8"
/dev/sdb2: UUID="110a1a15-64f8-4e5b-b0fe-8c1dcb282ae9" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="90c68213-aa72-4e76-a27e-4b19bb4c720d"
/dev/sdb3: UUID="jqTlrC-2HYa-zcO1-IDvY-9I9v-Qye3-0diLlr" TYPE="LVM2_member" PARTUUID="ecfa0a98-fcdb-4a3f-97ef-48085fb1bdac"
/dev/sdc1: LABEL="ARCH_202010" UUID="D617-28D3" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="00189aa5-01"
/dev/loop0: TYPE="squashfs"
/dev/mapper/archinux-swap: UUID="d73373e1-d1dc-4cb4-ae8b-8a93b737ad55" TYPE="swap"
/dev/mapper/archinux-root: UUID="6e7eed5f-69c0-4e71-b9da-8630e1561ba4" BLOCK_SIZE="4096" TYPE="ext4"

[root@archiso /]# cat /etc/fstab
# Static information about the filesystems.
# See fstab(5) for details.

# <file system> <dir> <type> <options> <dump> <pass>
# /dev/mapper/archinux-swap
UUID=d73373e1-d1dc-4cb4-ae8b-8a93b737ad55       none            swap            defaults        0 0

# /dev/mapper/archinux-root
UUID=6e7eed5f-69c0-4e71-b9da-8630e1561ba4       /               ext4            rw,relatime     0 1

# /dev/sdb2
UUID=110a1a15-64f8-4e5b-b0fe-8c1dcb282ae9       /boot           ext4            rw,relatime     0 2

# /dev/sdb1
UUID=2945-BE61          /boot/efi       vfat            rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro       0 2


[root@archiso /]# mkinitcpio -P
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 5.8.13-arch1-1
  -> Running build hook: [base]
  -> Running build hook: [systemd]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> Starting build: 5.8.13-arch1-1
  -> Running build hook: [base]
  -> Running build hook: [systemd]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
==> Image generation successful
[root@archiso /]#

[root@archiso /]# ls -la /boot/efi/
total 12
drwxr-xr-x 3 root root 4096 Jan  1  1970 .
drwxr-xr-x 5 root root 4096 Oct  8 13:01 ..
drwxr-xr-x 4 root root 4096 Oct  8 18:44 EFI

[root@archiso /]# grub-install --target=x86_64-efi --bootloader-id=GRUB --efi-directory=/boot/efi
Installing for x86_64-efi platform.
Installation finished. No error reported.

[root@archiso /]# grub-mkconfig -o /boot/grub/grub.cfg
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot: initramfs-linux-fallback.img
done

Am I missing something here?.

Last edited by penguinbliss (2020-10-09 07:27:59)

Offline

#2 2020-10-09 00:45:43

GaKu999
Member
From: US/Eastern
Registered: 2020-06-21
Posts: 380

Re: [SOLVED]Error: Timed out waiting for device /dev/mapper/archlinux-root

Lack of information.

Are you using dracut or mkinitcpio?
What modules are you loading in the case of mkinitcpio?

It’s obvious that the initramfs is systemd based, the issue may be the lack of the lvm2 module.

You have installed it on your system right?
And regenerated the initramfs?


My reposSome snippets

Heisenberg might have been here.

Offline

#3 2020-10-09 01:05:07

solskog
Member
Registered: 2020-09-05
Posts: 247

Re: [SOLVED]Error: Timed out waiting for device /dev/mapper/archlinux-root

Also this:

If the root file system resides in a logical volume, the root= kernel parameter must be pointed to the mapped device, e.g /dev/vg-name/lv-name.
https://wiki.archlinux.org/index.php/In … ot_options

Offline

#4 2020-10-09 01:50:41

GaKu999
Member
From: US/Eastern
Registered: 2020-06-21
Posts: 380

Re: [SOLVED]Error: Timed out waiting for device /dev/mapper/archlinux-root

solskog wrote:

Also this:

If the root file system resides in a logical volume, the root= kernel parameter must be pointed to the mapped device, e.g /dev/vg-name/lv-name.
https://wiki.archlinux.org/index.php/In … ot_options

It still works, it’s deprecated, but still works.
Idk when they plan to nuke it out already.


My reposSome snippets

Heisenberg might have been here.

Offline

#5 2020-10-09 07:21:01

penguinbliss
Member
Registered: 2020-10-08
Posts: 3

Re: [SOLVED]Error: Timed out waiting for device /dev/mapper/archlinux-root

Thank you guys, that shed light on.

I used mkinitcpio, it was missing the lvm2 module. Installed it and had to add the hooks systemd and sd-lvm2 for systemd-based initramfs in /etc/mkinitcpio.conf. https://wiki.archlinux.org/index.php/In … cpio_hooks

Then repeated rest steps:

- Created initramfs like this since it was LVM

# mkinitcpio -P

- Installed GRUB

# grub-install --target=x86_64-efi --bootloader-id=GRUB --efi-directory=/boot/efi

- Generated GRUB config

# grub-mkconfig -o /boot/grub/grub.cfg

Rebooted and it is now up on OS smile

Last edited by penguinbliss (2020-10-09 07:24:36)

Offline

#6 2020-10-09 07:21:53

penguinbliss
Member
Registered: 2020-10-08
Posts: 3

Re: [SOLVED]Error: Timed out waiting for device /dev/mapper/archlinux-root

Between, how to mark this thread solved?.

Offline

#7 2020-10-09 07:26:19

GaKu999
Member
From: US/Eastern
Registered: 2020-06-21
Posts: 380

Re: [SOLVED]Error: Timed out waiting for device /dev/mapper/archlinux-root

penguinbliss wrote:

Between, how to mark this thread solved?.

Edit first post, prepend [SOLVED] to title.


My reposSome snippets

Heisenberg might have been here.

Offline

Board footer

Powered by FluxBB