You are not logged in.

#1 2020-10-15 09:28:26

Arciere
Member
From: Torino, Italy
Registered: 2020-10-07
Posts: 22

English (US intl., with dead keys) keyboard layout

Hello everybody,

I bring you first what I would like, then what I have tried.
I wish I could set the default keyboard layout, which in other distros is called "English (US intl., with dead keys)" if I remember correctly, both for the console and for the rest of the OS.
For the console I should edit /etc/vconsole.conf, but I don't know what I have to write in it to get the layout in question.
For the general system, I noticed the command

setxkbmap -layout us -variant intl

fulfills the function I seek, but only for the current session.

This keyboard layout for the console and for the system however, I would like it to coexist with the system language set differently, ie in en_GB.UTF-8.
I then changed /etc/locale.gen like this:

en_GB.UTF-8 UTF-8

and /etc/locale.conf as follows:

LANG=en_GB.UTF-8

But I'm not totally sure it's the right procedure.

I have read all both this Wiki page and this one, but I admit I don't understand what and how to change xinit.

Thank you in advance!

Last edited by Arciere (2020-10-20 15:09:21)


Arciere

Offline

#2 2020-10-16 04:49:49

solskog
Member
Registered: 2020-09-05
Posts: 247

Re: English (US intl., with dead keys) keyboard layout

For console /etc/vconsole.conf setting, "KEYMAP=" refer to the actual keymap you are using. Try keymap files inside /usr/share/kbd/keymaps/ or define a new one if needed.

man vconsole.conf

To activate setxkbmap setting for every Xorg session, put your command inside ~/.xinitrc or /etc/X11/xinit/xinitrc.

Alternatively, you can generate a /etc/X11/xorg.conf.d/00-keyboard.conf file using

man localectl
# localectl set-x11-keymap us "" altgr-intl

Last edited by solskog (2020-10-16 04:59:04)

Offline

#3 2020-10-20 15:17:46

Arciere
Member
From: Torino, Italy
Registered: 2020-10-07
Posts: 22

Re: English (US intl., with dead keys) keyboard layout

solskog wrote:

For console /etc/vconsole.conf setting, "KEYMAP=" refer to the actual keymap you are using. Try keymap files inside /usr/share/kbd/keymaps/ or define a new one if needed.

man vconsole.conf

To activate setxkbmap setting for every Xorg session, put your command inside ~/.xinitrc or /etc/X11/xinit/xinitrc.

Alternatively, you can generate a /etc/X11/xorg.conf.d/00-keyboard.conf file using

man localectl
# localectl set-x11-keymap us "" altgr-intl

First of all, I apologize if I answer only now, but I haven't had a moment of time these days.
Second, thanks for your reply!
The fact is that I already knew I had to modify /etc/vconsole.conf in order to set the default console layout, by writing

KEYMAP=

but it is right after that "=" that I don't know what to write in order to set the layout called "English (US intl., with dead keys)". I've tried looking for the right layout with both the man command and the Arch Wiki page on keyboard layouts, but can't find the exact name of the layout I'm looking for.
As for the command to insert in the ~/.xinitrc file thank you very much: everything works fine.


Arciere

Offline

#4 2020-10-21 02:23:51

solskog
Member
Registered: 2020-09-05
Posts: 247

Re: English (US intl., with dead keys) keyboard layout

Try this one use terminus-font package

$cat /etc/vconsole.conf

KEYMAP=us-acentos
FONT=ter-114n
FONT_MAP=8859-1

Offline

Board footer

Powered by FluxBB